Question about Technics SA-AX530 Receiver

1 Answer

Technics su z2 amp shuts off sound

Hi,

I have a problem with my old amplifier (Technics SU Z-2), bought second hand. It looks okey (no rust, and I have sprayed it with electronic spray), but shuts off the sound when volume reached 2 out of 10, when speakers are connected. The sound doesn't come on before that point, so before the point where it cuts off it doesn't sound much at all, just a very weak rather scraping sound. When I use headphones it doesn't cut off and I can hear the music, but the sound has too much bass and seems very loud (mostly on the bass) even on a low volume.

It seems like the amp shuts off the sound to protect the speakers from too loud sounds, even though the sound is not very loud or the volume is not set to a loud sound. The sound is also not clean and has too much bass. But I don't know what's wrong and what I could do? I would like to fix it if possible, because even if it's old it looks very nice and I'm sure it once was a very good amplifier. Any suggestions?

Thanks!
Cecilia

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Hello. we cant help if we dont know what music source you are using.

Posted on Sep 01, 2012

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 93 Answers

SOURCE: Technics SU-G91 OVERLOAD PROBLEM

OVERLOAD means that input signal level is too high. Can you be more specific? From which source you play music when OVERLOAD icon appears?

Posted on Oct 11, 2007

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Technics su z2


HI
2 things can do this
1.input selector is dirty and needs to be cleaned.
2.the power module is damaged.
Hope this helps

Dec 28, 2013 | Technics Audio Players & Recorders

1 Answer

Technics SU-X302 Problems


Greetings
Is there any indicator on or its all off?
anyway i will assume that there is none
1.check power fuse if blown.
2.check power transformer if there is any output voltage
3.check internal fuses
more information will give a better idea.
try these steps and hope this helps.

Dec 25, 2013 | Technics Audio Players & Recorders

2 Answers

I need an Operator Manual for a Technics Amplifier SU-600


HI,
I have the User manual of Technics SU-600 in pdf format. If you can sent your email address the i will sent you the manual.Its not possible to sent the manual through this site as it is a pdf file.
OK

Oct 26, 2011 | Technics SUV500 2-Channel Amplifier

1 Answer

Hi I just got a Technics SU V2 amp and can't get sound from the speakers. What size speakers would suit this amp? What is the correct method to connect the speaker leads to the back of this amp,...


Being a 500W amplifier, you need to connect speakers with 300W each. The correct method to connect speakers is red terminal of speaker should be connected to red terminal of amplifier & black to black. The left side to left side speaker & right to right speaker. There may be main & remote terminals. Main speakers are the speakers at local place of the amplifier & remote for remotely placed speakers. I do have Technics SU-V85A which is somewhat similar. Enjoy! A nice piece to listen.

Oct 22, 2011 | Technics SUV500 2-Channel Amplifier

1 Answer

What is technics amplifier su z2 ic number


HI,
The out put ic number of Technics SU Z2 is SVITK2038. If you can sent your email address the i will sent the schematic diagram
OK

Oct 10, 2011 | Technics SUV500 2-Channel Amplifier

1 Answer

Hello I have a Technics SU-V45A amp, it's about 18


See there is a problem with the volume conroller as it is 18 years old the controller has worn out replace the volume controller with a new one and you will be able to enjoy great sound again

Dec 05, 2010 | Technics SUV500 2-Channel Amplifier

1 Answer

Technics amplifier su-v98, cuts off at 22-24 desibls


The most common cause of this is defective coupling caps inside. These allow some DC voltage to pass through to the final amp stage. This DDC voltage is detected by the protection circuit and the unit shuts down. This unit will require service. Please note that this should be a simple and inexpensive repair. The cost should be less than $10 for parts.

Dan

Jul 04, 2009 | Technics SUV500 2-Channel Amplifier

2 Answers

TECHNICS SU-V50


Hi max

I have done a followup with Technics Parts agents in the US, they will get back to me and then me to you shortly :) A vote as FixYa would help improve my ratings. Thanks

Graeme

Feb 06, 2008 | Technics SUV500 2-Channel Amplifier

Not finding what you are looking for?
Technics SA-AX530 Receiver Logo

Related Topics:

1,038 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5487 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Ben Armstrong

Level 2 Expert

357 Answers

Are you a Technics Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...