Question about Bazooka EL1500 Car Audio Amplifier

1 Answer

Got the hot nd ground conted nd the aux cables from the raido conted nd the amp does not turn on

I got a bazooka EL 1500 car amp and i got the ground and hot wire from the battery goin into the truck and the aux cables from the radio to the amp but the amp don't turn on

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 31 Answers

The amp needs a remote signal to turn on. This is provided by wire from the back of your head unit. Also look for a 'REM' or 'remote' connection on the amp (besides the 12v and ground connection).

Look at the wiring/setup diagram for your head unit to determine which wire/connection you should use for this.

If the head unit does not have a specific 'remote' wire, you can usually use the power antenna wire to provide a turn on signal to the amp instead.

Posted on Apr 13, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to i find out whats wrong with my bazooka tube i tried to hook it up to a car battery and car stereo out side but wont work ???


follow this steps and fix it. GOd bless you

  • Verify that the amplifier is turning on by looking to see that it is lit up.

  • 2
    Use a voltmeter to verify your power supply is a good 12 volts by touching the ground lead to you amplifier's ground screw and the positive one to the amplifier's constant power supply screw. Also verify that you have 12 volts coming from the remote lead wire which is usually a thin blue wire between the ground and constant 12 volt supply.

  • 3
    Look for the "thermal overload" light. It is usually a red LED on the side of the amp. If the amp feels really warm and this light is lit, the amp has probably overheated from being tuned wrong or turned up too loud and shut itself down to cool off.

  • 4
    Check the fuses on the amplifier. These can blow with extended use or during heavy bursts of use.

  • 5
    Make sure the "Gain" and other volume controls are turned up.

  • 6
    Confirm that the signal wire is still attached to the amplifier and has not come disconnected by vibrations in the car. Also check that the wires running out of the amp to the speakers are still attached to the amp.

Oct 27, 2013 | Car Audio & Video

1 Answer

Audiopipe amp 1000w on 2 8" double ended bazooka


You may be over driving the speakers or there may be an impedance mismatch between the amplifier and speakers, especially if they are connected in parallel

Nov 12, 2012 | Car Audio & Video

1 Answer

I have a EL 1500wat amp, when I turn it on the little lite comes on and stays yellow, it was green and was working,fine last night. Any ideas?


Look at fuses first. Then if they are ok. You need to check wiring. Ground. Power remote. If those are good. You need a tech.

Apr 16, 2012 | Bazooka EL1500 Car Audio Amplifier

1 Answer

My protection mode red light comes on right when i put the fuse in my power line, even when my cars off!!! is it that my ground is bad? ineed some help!! oh ya, lol, its a ela300.1 bazooka amp!


Check your ground most definitly!, Replace it if needed. Check your remote wire and power wire as well. And if none of this works, then you are having internal issues.

Aug 26, 2009 | Bazooka ELA300.1 Car Audio Amplifier

1 Answer

Bazooka BTA series self-amplified tube subwoofer wont' power on


the blue wire is called the remote wire will go to back of head unit also to a bule wire that will send 2 amps to turn on the speaker only when the head unite is on

Apr 18, 2009 | Infinity BASSLINK Car Subwoofer

1 Answer

No idea!!


Have you checked the on-board fuses on the amp?

Have you confirmed, with a multimeter, that you have B+ and remote voltage AND a good ground? If not, do the following.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Sep 28, 2008 | Bazooka (EL10190PP) Car Audio Amplifier

1 Answer

Bazooka amp


If the amp is in protect mode, it probably has shorted output transistors. To eliminate other possible problems, do the following. I'll assume that you've checked the amplifier's on-board fuses.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it remains in protect mode, the amp almost certainly has shorted output transistors and will need to be repaired.

Jun 15, 2008 | Bazooka Car Audio & Video

Not finding what you are looking for?
Bazooka EL1500 Car Audio Amplifier Logo

Related Topics:

149 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bazooka Car Audio & Video Experts

Radames Pagan
Radames Pagan

Level 3 Expert

196 Answers

Abubacar Alfredo
Abubacar Alfredo

Level 1 Expert

26 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Are you a Bazooka Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...