Question about Rockford Fosgate Power T3002 Car Audio Amplifier

1 Answer

Only thermal light on.

My thermal light on R.F t3002 amp is only light on. subs are not working. when they do work they sound terrible

Posted by on

  • rteemon
    rteemon May 11, 2010

    it it getting good signal?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 578 Answers

Check rca and make sure u have right input to amp and speaker

Posted on Aug 07, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Water spilled on rockford t3002 now protect light is on is amp repairable


All depends, when amp is connected does it blow the fuses, if not, it maybe repairable, But its a long process. when your amp is on and has water spilt onto it, the water inside the amp evaporates and gets into every nuck and cranny due to the amp heating up when powered on. you need to strip amp down to bare basics and completely dry the circuit board and all compnents one by one, hense a long process. Best thing to use is a hair dryer. get the hair dryer into every nuck and cranny, into the connectors, basically everything. once done. put back together and try it then. i had a home amp with water damage and fixed it this way.

Mar 03, 2011 | Rockford Fosgate Power T3002 Car Audio...

1 Answer

I installed a MTX Thunder 3401 with a PA sub. after turning the car oh every things works great. After about 2 mins of play, the thermal light begins flashing red and it will shut off the amp. After the...


You are def overheating, If the ohms rating of the subwoofer is too low it will cause this same thermal over heat. If you have 2ohms in sub and a 4 ohms stable amp, you will overheat. Check the ohms rating of the sub to make sure this is not the problem

Jan 31, 2011 | MTX Thunder 3401 Car Audio Amplifier

1 Answer

I have a t3002 going to a L7 12" sub. it played for bout 5 minutes down my road then no sound. the protect light is on. Y?


It could possibly be a bad ground. I ran in to the same problem the other day, but I wasn't driving. Started my car and everything seemed to work ok then all of sudden nothing. I checked all the voltages when the car is turned on, remote turn on (should have more than 11v), power cable to chassis ground (12+ V), they were all there. Then I finally checked the ground just moving the connection turned it on and then off. This occured repeatedly, then I disconnected the ground and then reconnected, now amp is running like a champ.

Oct 02, 2010 | Rockford Fosgate Power T3002 Car Audio...

1 Answer

My sub has all bin wired up proberly the sub works for about 30 secs then the green light goes out and no power to the sub at all


Green light on amp?? Seems like your amp is going into thermal overload. Check your power connections, and make sure there are no shorted wires. Hope this helps.

Apr 21, 2010 | Fusion FEW12PK Car Subwoofer

2 Answers

Amp wont turn on and theres power to the amp and the fuses are good


check the ground to the amp. then check the remote wire. make sure u have the sub option on ur stereo turned on. if all is wired up correct an u do not have the subs turned on in ur stereo settings then the stereo will not send power through the remote wire an therfore your amp will not power on.

Apr 04, 2010 | Rockford Fosgate Power T3002 Car Audio...

3 Answers

Red thermal light on


well id say you have cooked your amp and or subs they can only take beatings for so long. show it no mercy it gives it back,does amp smell do subs smell borrow amp see if subs are ok if so it will be your amp.new one .keep the gain down??

Jun 11, 2009 | Rockford Fosgate Punch P550.2 2-Channel...

1 Answer

Subs sound terrible (Ive tried so many things)


NO it won't be your battery. Sounds more like your deck.

Jan 22, 2009 | Jl Audio 12W3 Car Subwoofer

1 Answer

Thermal switch or possibly a stressed amplifier module?


I would make shure the Plus and negitive are right. Also if it was smoking you probly blew the power supply out of amp. From to many ohms loads. Hope this helps you out

Jan 04, 2009 | Car Audio & Video

1 Answer

No Sound/ lights flashing on Amp


Disconnect your subs from the amp. If the lights go out then your sub is blown and is putting the amp into protect. If the lights keep flashing even with the subs disconnected than the Amp is toast.

Jul 09, 2007 | Sony XM-752EQX Car Audio Amplifier

Not finding what you are looking for?
Rockford Fosgate Power T3002 Car Audio Amplifier Logo

Related Topics:

148 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Professor_V
Professor_V

Level 2 Expert

92 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Are you a Rockford Fosgate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...