Question about Arris Wireless G Broadband Router (wr850g)

2 Answers

My wireless WR850G requires constant reconnection repair

Please help!! My wireless WR850G requires constant reconnection repair. Every 30 minutes and even sometimes less the darn blinking green light for "modem" will go to red. Sometimes it will go back to green on its own and sometimes it will stall out altogether and i lose my connection to the internet. I game on servers a lot and this just drives me crazy. I replaced a WR850 with this WR850G model and that was because of the very same issue. Usually i have time to do a reconnection repair setting. Only one other comp on the network besides mine. Im direct to the cable-modem,O/S = XP,New Comp as of Jan.2007,P4,AMD Athlon,64proc.,2.40GHz,2.0GB of Ram.. In "DEVICE MAQNAGER" wut is a RAID CONTROLLER??(its got a yellow ? with a yellow circle.(Device status says drivers are not installed Code 28. i have no idea wut this stuff is about..

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers
Re: My wireless WR850G requires constant reconnection...

RAID is a set of Hard disks working in an array (Redundant Array of inexpensive Disks) driven like only one logic disk. Your configuration says me you don't have a RAID. Its possible that your ISP validate your entrance to the server by The MAC address of your PC. If so you can fix the difficult by clonning that MAC in your router. You Can do it into the WAN secction of the web configuration interface. Write the mac address of your ethernet card in MAC address item.

Posted on Sep 14, 2007

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert whose answer gotĀ voted for 20 times.


    An expert who has answered 20 questions.

  • Expert
  • 196 Answers
Re: My wireless WR850G requires constant reconnection...

I would tend to think this is a problem with your gaming server or your ISP. Check with your game forum or your ISP:they will have logs that can tell what's going on. Does this happen when surfing the net, or only when gaming? The RAID issue should be easy to resolve. You probably have a RAID controller on your motherboard, and the driver is missing. It's not a big deal if you're not using RAID, but the driver will be available from your computer maker or your motherboard manufacturer. RAID:

Posted on Sep 05, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Power Problem with 2Wire 2701HG-B

Sounds like a startup self test. All wireless devices go through a power on self test. Does it connect? You can connect to it and go online? I rarely turn mine off, only in a electrical storm.

Nov 22, 2012 | 2wire (2701HG-B) Wireless Router

1 Answer

Wnr834bv2 power light is sometimes on in amber, then blinking green and I keep losing connection

Try resetting and then reconfigure the router.
To RESET the Netgear, power up the Netgear then press andhold the RESET button at the back of the router until all the LEDs flash.Connect a LAN cable from the Netgear to the LAN port on yourcomputer, open a browser and enter the Netgear configuration URL -
The default login = admin
The default PW = passwordYou can now change the default admin password and configurethe wireless settings.
Go to the wireless configuration and set up the SSID and WPA or WPA2encryption.
Now apply these settings to the wireless card in your laptop/computer.
To secure your wireless network from unauthorized access, please click on thislink and follow my instructions :-

Jul 11, 2012 | NetGear WNR834B RangeMax NEXT Wireless-N...

1 Answer

I installed a wr850g wireless router and have really messed up. I can't access with, I can't remember the passwords I used and it comes up with network authentificatiion. I know I...

Please try the reset button on the back of the router in the following ways:

1. Hold the reset button in until the lights flash on the front of the router (about 30-40 seconds). Now unplug the router for a few seconds and then plug it back in. Wait for all the lights to finish blinking. Router should be reset. (see end to tell if it was).

2. Hold the reset button in for 30 secs, continue holding the reset button in while unplugging and plugging the router back in. Release the reset button and wait for the lights to finish flashing.

3. Unplug the router, then hold the reset button in while powering back up. Keep the button held in for a good 30 seconds.

If any of these resets work, you will have reset the router to factory defaults. Check your computers IP address. If it is (for example), then the routers IP address will be and the user name and password will now be back to the defaults.

Hope this is helpful

P.S. I will be 49 this year and need to look at my drivers license too...LOL

Aug 29, 2011 | Arris WR850G Router (DHWR850G)

1 Answer

My router is plugged into my modem but the modem Light on the router is blinking red

Try unplugging the power cords on both for one minute and plug back in. Let me know if that fixes it or not.

Jul 03, 2011 | Arris Wireless G Broadband Router (wr850g)

1 Answer

WRT120N---I keep having to disconnect my linksys, unplug all 3 wires on the back of the router, wait 30 sec...reconnect the router...try to get online...when it works then reconnect the linksys....what am...

Please disconnect and internet link and try to access the the Linsys WRT100 management page and see the logs why the router is loosing the connection. If you dont get anything then it might be some issue on the device. A reset may solve your issue.

Please be aware the if u reset the wireless Router you will loose all your configuration and you have to reconfigure the wireless Router.

Please press the tiny black button at the back/beneath of the wireless Router and keep pressing for 2 minutes. The sys light will start blinking slowly and then rapidly. then release the button and wait for 2 minutes for the device to boot up with factory default settings.

Once you are done you can connect to ip address and it will open the your Linksys Router management web page where you can reconfigure your wireless router again.

Hope this will fix the issue.

Best Regards

Jan 01, 2011 | Linksys RangePlus WRT100 Wireless Router

1 Answer

I checked all my connections and my router, wr850g shows constantly flashing/blinking lights and will not reset in the 10 seconds that it is supposed to. the ip address is also not becoming it...

1. Unplug the ether net cord from the wall and wait 1 minute replug the Ethernet cord.
Try you connection again if no connection then go to the command line at the DOS prompt and type "ipconfig /all to see the devices that are connected.
If you see anything like "media disconnect" then you have an issue with your ISP ( internet Service Provider).

Jul 02, 2010 | Arris Wireless G Broadband Router (wr850g)

1 Answer

Modem light is red won't stay green.

Make sure to configure the router according to your ISP settings. I believe you have a DSL connection. That means you need to configure the router using PPPoE

Apr 26, 2009 | Arris Wireless G Broadband Router (wr850g)

1 Answer

Network switch

Sounds like you know what you're doing... but.. based on what you've typed..

You need to make certain the comcast cable modem is plugged into the seperate port on the back of the router called WAN and not next to the other LAN connectors.

The network is seperate from the internet. The router acts as a firewall and shares the WAN with the LAN internally and automatically.

I assum that you have one red light on WAN.. and three green lights for LAN..

Jun 18, 2008 | Arris Wireless G Broadband Router (wr850g)

1 Answer

WR850 Install Problem on new VAIO Laptop with VIsta

try to change your OS! frfom VISTA to XP. because sometimes the problem is in not the router rather the problem is, conflict bet. IPv6 and IPv4.

Apr 01, 2008 | Arris WR850G Router (DHWR850G)

1 Answer

Cant connect to the internet

red light means moden is out of sync with the isp. Power cycle. by unpluging the power from the back of yoru modem, unplug Your router and also turn off your computer. Turn on your modem frist wait until all lights are green>If they dont turn green. CHeck your cables. make sure telephone line is plugged into it or cable line. . There should be a cable pluged in from your modem to your wan port. Then from your router to your computer. Is this a wired or wireless connection. If its a wireless connection i need to know what what os your using. so i can help you set it up.

Feb 05, 2008 | Arris WR850G Router (DHWR850G)

Not finding what you are looking for?
Arris Wireless G Broadband Router (wr850g) Logo

166 people viewed this question

Ask a Question

Usually answered in minutes!

Top Arris Routers Experts


Level 3 Expert

3287 Answers


Level 2 Expert

175 Answers

Brett Duxbury
Brett Duxbury

Level 3 Expert

2650 Answers

Are you an Arris Router Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides