Question about Audio Players & Recorders

2 Answers

Need Experts Help!!

Hello, I'm having trouble repairing a kenwood DTS Amp model: KRF-7775D. I have the service manual but still could not find any faulty components. Problem with this is that it works on it's own, seems it has a mind of it's own, so I seviced and replaced the memory backup caps near the main u-com and it fixed the "Mind" problem. Now it's doing exactly what I want it except no Audio output. checked everything, output stage, protection, muting etc. no luck. But if I remove the DSP assy ( which has the DAC's, sub u-com and the DSP chip) I can get audio from the dvd 6 channel direct input. sounds great. but if I insert the card the damn thing goes mute. so I checked the card ( voltages and the resets) found that the DSP power (3.3V) is missing. the funny thing is this voltage is present at power on and dies when the protection relay switches on and mute deactivates. The DSP is powered down and is not activated in any sound modes or input modes, so my guess is with the DSP power down the DAC's are not workin, and with the card removed the u-com bypasses this stage. I replaced the sub u-com chip but nothing happened. further checking revealed that after the sub u-com recieves the master reset from the main u-com, it powers down the 3.3V AVR. So after few seconds the after power on the 3.3V dies. I donno why, cud not think of anything, but I did find the master clk from main u-com to the sub u-com is at 3 volts. But to my knowledge it should be 3.3V. Cause the clk goes via level shifter 5V-3.3V IC. After a long struggle I think I have pinpointed the problem. Re-checked every thing, the reset voltages and the supply voltages, audio switching. and these are the results I can get Audio from the speakers only at DVD 6 ch input, and only if I disconnect the sub mute which is activated from the sub u-com. so I think when the sub u-com powers down it mutes the amps, but the main mutes are not activated which means the main u-com is working. After a hard struggle found the Master data out port is always grounded(this is the MDT to the sub u-com) where else the master clk, sub reset and master reset and the volume control data is found the respective ports of the main u-com via to sub u-com. So if U have any idea, or do u believe this is true, pls I need an answer on to which could be the fault. Is the MDT port of the main u-com shorted to ground or is the software malfunctioning ( later is just what I think the Ic is doing). How can I be sure why this pin does not produce any data at swictch on or when I switch the DSP functions are switched. I can get supply variations at the clk, rst and sub rst ports at switch on. but blank on the MDT out. Rifaa

Posted by on

  • Rifaa-ath Razei
    Rifaa-ath Razei Apr 30, 2009

    I was able to fix it after a month of brain storming

  • Rifaa-ath Razei
    Rifaa-ath Razei Apr 13, 2014

    I am not here to help. I needed help but I already fixed mine. If any body need my help, you can fine me here

×

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

My kenwood krf-x7775d sound not coming im not undrstend how to set remote control i wont undrstend how to seting remote control

Posted on Apr 10, 2014

Testimonial: "I am not here to help but to find a solution for my problem. I did not get any help here but however I already fixed mine. You can find me here http://forum.allaboutcircuits.com/index.php I only help here not any where else."

  • Rifaa-ath Razei
    Rifaa-ath Razei Apr 13, 2014

    I am not here to help but to find a solution for my problem. I did not get any help here but however I already fixed mine. You can find me herehttp://forum.allaboutcircuits.com/index.... I only help here not any where else.

×

Ad
  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 2 Answers

My receiver is experiencing the same issue now. I was thinking it was an amplifier output stage going out. I only took the hood off and measured some typical voltage areas, nothing too in depth while on the living room floor. What was your conclusion? I'd much rather fix mine than buy a new one.

Posted on Jul 06, 2010

Testimonial: "I am not here to help but to find a solution for my problem. I did not get any help here but however I already fixed mine. You can find me here http://forum.allaboutcircuits.com/index.php I only help here not any where else."

  • Rifaa-ath Razei
    Rifaa-ath Razei Apr 13, 2014

    I am not here to help but to find a solution for my problem. I did not get any help here but however I already fixed mine. You can find me herehttp://forum.allaboutcircuits.com/index.... I only help here not any where else.

×

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Rifaa
  • 99 Answers

SOURCE: Kenwood KRF 7775D not working with Digital Inputs

First of all my nick is Rifaa.
Secondly do you still have the amp

Posted on Sep 08, 2009

nliwilson
  • 114 Answers

SOURCE: Need Help

I think you've answered your own question, circuit power is not going from one side of the DSP chip to the other and that suggests that the DSP's core is at-least partly DOA. You are indeed correct that functional power should be at 3.3V and yes 0.3V does make a difference to the components that rely on a 3.3V feed, however if the DSP is fried you are not going to see normal functionality or be able to diagnose further.

Posted on Sep 05, 2007

  • 2 Answers

SOURCE: The DTS and DSP selections on my Pioneer HTZ-55DV

Try a factory reset[don't ask me how].Your processor stopped working properly...
Ask on producer's site for help and support.
Maybe you need to flash it.....
M

Posted on Jan 04, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Need Help


I think you've answered your own question, circuit power is not going from one side of the DSP chip to the other and that suggests that the DSP's core is at-least partly DOA. You are indeed correct that functional power should be at 3.3V and yes 0.3V does make a difference to the components that rely on a 3.3V feed, however if the DSP is fried you are not going to see normal functionality or be able to diagnose further.

Sep 04, 2007 | Audio Players & Recorders

1 Answer

I have a kenwood Auto video surround receiver DR / 409 how to reset it


PDF]KRF-V8030D VR-409 - Kenwood

manual.kenwood.com/files/B60-4593-00.pdf
VR-409. INSTRUCTION MANUAL. KENWOOD CORPORATION. B60-4593-00 (EN) ...on the country and sales area. AUDIO VIDEO SURROUND RECEIVER ...

Kenwood VR-409 Manuals

www.manualslib.com > Brands > Kenwood Manuals > Stereo Receiver
View online or download Kenwood VR-409 Instruction Manual. ... Kenwood Instruction Manual Audio Video Surround Receiver KRF-V8030D VR-409.

Kenwood VR-409 Receiver Repair Questions, Solutions ...

www.fixya.com > Forum > Audio & Video Receivers > Kenwood
Recent Kenwood VR-409 Receiver questions, problems & answers. Free expert DIY tips, support, troubleshooting help & repair advice for all Audio & Video ...

Kenwood VR-409 PDF Owner's Manual Download & Preview

www.manualguru.com > Kenwood Manuals > VR-409

Feb 03, 2016 | Kenwood Audio Players & Recorders

1 Answer

My ken wood krf v5050d automatically goes back to standby what is the cause


hello! i need help with this, i have the same amp Kenwood KRF-V5050D it seems that it had a short circuit on the speaker terminals, close to the 2 12v relays wich are close to each other and the 2 transistors kia 7812 and kia 7912 was turned black, i have replaced them, and i have disconnect the 2 big IC but the amp still does go in the protection mode, but when i disconnect the 2 transistors kia 7812 and kia 7912 the amp does stay on. i have checked almost everything and it seemed to be good. i have checked every transistor and replaced some capacitors, but i have not replaced the 4 big capacitors, with all the 0.22j resistors and all the terminal relays and the 2 big ic disconnected the amp still goes on protection mode. i had this amp returned from ebay and the buyer is waiting for it to be repaired, i would aprecciate any help.
ujka.pjetracaj@hotmail.com
Kind Regards.

Oct 07, 2013 | Kenwood Rc-r0511 Home Theater Receiver...

1 Answer

I NEED A manual for a krf v5200d



  • Hope this helps.

Nov 02, 2011 | Kenwood KRF-V5060D Receiver

2 Answers

Hi, I have a KRF-4060D receiver and my problem is, that however the receiver is set to auto detecting, when I start a dts movie, the receiver does not recognize it as a a dts signal. could you please...


What DOES it detect instead - analog or Dolby Digital? If the former, the digital bitstream is not being seen at all - check the digital audio-bearing cabling.

If the latter ---

As dangerously loud undecoded digital bitstream [hash] "noise will be produced when a DTS source is played by selecting the analog input", the DTS soundtrack is not necessarily the default for a movie soundtrack and may need to be manually selected under the movie's own Audio Setup menus.

Jul 11, 2011 | Kenwood KRF-V4060D Receiver

2 Answers

I have a kenwod krf-v5050d amp (old I know). I have my blu ray hooked up via an optical cable however I can not get any sound through the speakers from it. I know it shouldnt be the speakers or the amp...


xjackdeth,

All systems with multiple audio/video inputs for each connection must be told what connection you want it to play. Most likely your selected choice of input is set to an input other than digital. I included a link to download the manual for your Kenwood model; see page 9 for "Input mode settings".

First use the input selector knob to select the input you are using for the blue ray player, then press the input mode button to select digital auto; the Kenwood should take a few seconds to switch over and then you will be in business.

http://audio.manualsonline.com/manuals/mfg/kenwood/krf-v5050d.html

-Chris

Jan 09, 2011 | Kenwood Unity System

1 Answer

Kenwood krf-x9995d surround issue


It's likely the power amp is faulty. However if you can't get in touch with Kenwood, then take it to another repair shop or go back to the other and tell them you can't get in touch with Kenwood and could they have a look at it anyway.

May 27, 2017 | Kenwood Audio Players & Recorders

1 Answer

Kenwood KRF 7775D not working with Digital Inputs


First of all my nick is Rifaa.
Secondly do you still have the amp

Feb 27, 2009 | Kenwood DVT-6200 System

2 Answers

KRF-5030D i stand by mode


Does it go into standby when it's in another mode like : Cd or Video 1 or tape?

When you state that you checked the power amp IC's , how so did you do this?

Thanks n' let me know.

Feb 08, 2008 | Kenwood KRF-V5060D Receiver

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

547 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5349 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

The Knight
The Knight

Level 3 Expert

75178 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...