Question about Edirol UA-25 External Sound System

5 Answers


Hi I am using the Sonar LE program that Edirol UA-25 came with and I want I am following the tutorials. I have followed everything they say but I hear no audio playback when I listen to a file. When I listen to the sample track that comes with the UA-25 it is fine so the problem lies in Sonar LE. I have looked through the troubleshooting and it is useless. PLEASE HELP!

Posted by on

  • 5 more comments 
  • Anonymous Nov 12, 2008


  • Anonymous Nov 12, 2008

    I have

  • acc1 Nov 12, 2008

    I have the Samson G TRACK with SONAR LE. I can play back audio until I export the project file to MY DOCUMENTS or to DVD-RAM Drive (E:). I can not open the file once it is in either of these. I have not tried to download the file to a CD-R as I felt that I should be able to open the file to hear the audio once it was exported.

  • jonathanneit Jan 14, 2009

    I Have The Same Problem EveyTime i Try An listen To my Instrumental I Cant Here AnyThing I Tried EveyThing Thay Said an It Still Havent Worked See This The Type Of Stuff That Make me Mad....

  • Anonymous Mar 23, 2009

    I have the exact same problem. I can't even play the Latin and Downton stuff from the Sample Content.

  • Anonymous Apr 05, 2009

    i cant here any sound

  • rjay217a Apr 10, 2009

    I can get sounds out of the UA-25 EX via the guitar & via other audio files but no out put from Sonar. Not even does it play back the samples that come with the software.

    Any assistance with this problem would be appreciated.



5 Answers

  • Level 1:

    An expert who has achieved level 1.


    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Microsoft re-engineered the audio bus for Windows. HD Audio is hardware specific, in the sense that specific drivers have to be written to make a piece of hardware compatible with it. Roland is not writing a driver for the UA 25 because they want you to buy an UA 25EX. Get my drift? The UA 25 uses Kernel Streaming, the old way, which exists in parallel, sort of, with the HD Audio bus. But the new ways are always prioritized over the old ways in software, so there is bus contention (glitching).

To fix this there are a few things you can try:

1) Roll back to SP2. SP3 implements the HD Audio bus, so don't use that implementation. If your laptop has an HD audio sound card then I doubt it would work, but your UA 25 would.

2) Try ASIO 4 ALL. This fixed everything but glitching in VST instruments.

3) Reduce the amount of stuff your computer is doing. Optimize your OS by turning off the cute shaded windows and desktops and various processes that you don't need to see or use. There are sites for this. This increases available RAM, CPU time, etc.

4) Video hardware acceleration, sometimes, would fix bugs in software left in by not so clever programmers.

4) You can always just give-up and go along with the bastards and buy new stuff and toss the old stuff.


Posted on Sep 15, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I am using SONAR LE with the SAMSON G TRACK and could not play the file once it was EXPORTED. Windows Media Player would not play the file or any of my LifeCam files I had until the USB cord was disconnected from the Samson G Track. It then played great. This could be a glitch between the software and the component. I hope that this may be of some help to you.

Posted on Nov 13, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.


    An expert who has written 50 answers of more than 400 characters.


    An expert who has answered 200 questions.

  • Expert
  • 231 Answers

Hi, try changing your settings in the Audio and sound devices in control panel. Goodluck mistyman

Posted on Sep 04, 2007

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that has over 10 points.


    An expert whose answer got voted for 2 times.

  • Contributor
  • 22 Answers

As to not getting registration window- you have to right click icon and run as admin to provide permissions to actually enter in the registration code. That stops the window from re-appearing

Posted on Apr 27, 2010

Make sure, if you are using windows you have the right sound card settings (control panel->audio and sound devices or however) as mentioned in the manual. Also, using sonar LE make sure to have correct settings (options->audio settings). i had trouble with playback too but now everything's working fine. in my sonar settings i use the ASIO driver mode, and mark 'share with other programs'. make sure the right sound card is selected too (options->audio->drivers) and then it sould appear in the advanced window (as for the playback and the record timing master). other possible solutions might be in the options-> midi devices window, though i doubt that. I hope this can be helpfull. Good luck! btw, any solutions on how to NOT get the registration window on the startup?

Posted on Sep 22, 2007

1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Problems with sound that is coming from computer (output monitoring)

The first thing you should do is to uninstall the EDIROL UA-101 USB2 Driver Ver.1.0.3 for Windows XP and reinstall the system. If the problem persist try to use other usb cable, if the problem still the same please let me know inorder to make another procedure to follow to identify the problem.

Hope this will be helpful.

Nov 28, 2007 | Edirol UA-101 External Sound System

1 Answer

Cakewalk Sonar - Edirol UA-1000 crackles on playback!

That's a latency issue it sounds like.
There's a slider under "Audio" .

Move it in increments towards "slow", test it as you go.
Leave it at the highest setting possible that doesn't crackle.

I've heard this so bad that it sounds like a gun going off.
It scares the Hell out of you when it happens !

Jan 20, 2009 | Edirol UA-1000 External Sound System

1 Answer

No midi sound

In sonar go to the options menu and select: Audio -->advance. and from the list select the "Asio" driver, then you'll have a new midi output (synthe sw...) select it to have a sound while playing MIDI files.

Sep 21, 2008 | Edirol UA-25 External Sound System

1 Answer

Recordin audio problems (drop out)

cheak msconfig start ups eating ram that needs alot ram be nice to add 1 gb more run cc tool get junk out update your software form webite fl latest flash adobe shockwave and java run spyware clean up close out all other programs when u work in studio program

Mar 17, 2008 | Edirol UA-4FX External Sound System

1 Answer

Edirol UA 4FX _Short Audio Signal dropout

try runing a cleaner ccleaner and ace utituies ok that stop those hickups give a atry make pc run alsot faster

Jan 28, 2008 | Edirol UA-4FX External Sound System

2 Answers

Crackling noise - help

check all your cords make sure they are connected proper if they are then its internal. Is the gear brand new if so its under warranty if not then come back and ask again. It takes a brave person to answer your direct email address that means you are able to see who the person is ie his email address you will know. On fixya people dont like emailing others because the others maybe spammers....hence the Report abuse button on this program!

May 17, 2007 | Edirol UA-25 External Sound System

1 Answer

Problem with stability

Celeron CPU's will struggle with making music and limit what you can do with audio. Celerons are ok to play music but nor really for making music. Firewire is a better option for making music as it's really fast unlike USB. An option would be to get a faster CPU and try the soundcard again. But i would not use USB audio and would use an Audiophile 2496 soundcard as they are really cheap. Also midi is data and not audio, midi just works virtual instruments and is able to control keyboards through midi out. But first try a better CPU as a celeron isant that good for makign music. I know becouse i've been there done that and go really upset with the same problems your having at the moment. I played the midi files on cuabse and recorded it onto an audio chanel.

Aug 29, 2006 | Edirol UA-4FX External Sound System

Not finding what you are looking for?
Edirol UA-25 External Sound System Logo

3,027 people viewed this question

Ask a Question

Usually answered in minutes!

Top Edirol Computers & Internet Experts

Folusho Adeyanju
Folusho Adeyanju

Level 2 Expert

131 Answers


Level 3 Expert

781 Answers

Ben Armstrong

Level 2 Expert

357 Answers

Are you an Edirol Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides