Question about Sony LBT-W300 Shelf System

2 Answers

Sony lbt w300

My sony radio is displaying power protect error and cannot play anything

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 9 Answers

To isolate the source of the problem disconnect all speakers and turn on the unit, if it works that means that you have to check cables and speakers. If the problem remains that means the problem is with the unit. Professional technician is required: The problem is at the power output section (Defective out put IC or Voltage error?) Good Luck Toufic Malek

Posted on Sep 25, 2007

Ad
  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 2 Answers

Outher than that it could be bad solder on the speaker connectors?

Posted on Dec 04, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE:

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

While playing my unit we had a brief power outage. When the power supply returned the " PROTECT PUSH POWER " message comes on. Is there a button that I can push to reset my unit-LBT-X50 .


Hi,
Your sound system may have a circuit breaker.
Check the rear of the sound system for a circuit breaker that has popped out, Then push it back in.
It may be labelled.
  • circuit breaker
  • protect push power
Otherwise unplug your unit from the wall and wait 5min before you plug it back in, then press the power button on the front of your system and your remote control.

I hope this helps

MobileJB

Jul 13, 2011 | Sony LBT-LX50 CD Shelf System

1 Answer

It comes on and goes back off, and is asking me to push power pro


HiFi system goes to standby because protection circuit detects error in amplifier section, you need to take unit to qualified tech for fix.

Jul 24, 2009 | Sony LBT-W300 Shelf System

1 Answer

Sony LBT W5000


According to Page 46 of the LBT-W5000 Operating Instructions:
"The display stars flashing as soon as you plug in the power cord even though you haven't turned on the system (demonstration mode).
Press DISPLAY (for LBT-W5000 / W300 / XB700 / XB500) or DEMO (STANDBY) (for other models) while the system is off. If the system is in the Power Saving mode, press POWER SAVE / DEMO (STANDBY) (for LBT-W5000 / W300 / XB700 / XB500). The demonstration appears automatically the first time you plug in the power cord, or if there is a power outage lasting longer than half a day."
I tested this today, as my LBT-W5000 was in Demonstration Mode. It definitely works. The only catch is (at least on the W5000), and it's a minor one, you have to reset your clock afterwards.

May 29, 2009 | Sony LBT-W5000 Shelf System

1 Answer

Protect push power


hi, everytime i switch on my sony hi fi it the display screen says protect push power. It won't let me do anything not even put cd's in. If you could help that would be very much appreciated.

Jun 12, 2008 | Sony LBT-XGR6 CD Shelf System

1 Answer

Sony LBT W5000


when the hi-fi is off and there is the sony demo push "display" on your remote.. yep yep. peace

Oct 06, 2007 | Sony LBT-W5000 Shelf System

2 Answers

HCD-XG500 it says push power protect


Power protect tends to mean the main power amp chip has "blown" and needs to be replaced. It only costs about 20 dollars (10GBP). If you are handy with a soldering iron it is easy to do (after you get the thing to bits !) It is the big black thing on the big heatsink inside. The Sony part number is STK442 - 130. Seems a waste to throw the whole thing away for the sake of 10 pounds !. Hope this helps. Nik Howell ([email protected])

Apr 27, 2007 | Sony LBT-XG500 Shelf System

1 Answer

System won't let me play anything


You need to replace the audio amplifier IC because are damaged

Jan 16, 2007 | Sony LBT-W900AV Shelf System

2 Answers

Sony lbt-x5g500


Power protect tends to mean the main power amp chip has "blown" and needs to be replaced. It only costs about 20 dollars (10GBP). If you are handy with a soldering iron it is easy to do (after you get the thing to bits !) It is the big black thing on the big heatsink inside. The Sony part number is STK442 - 130. Seems a waste to throw the whole thing away for the sake of 10 pounds !. Hope this helps. Nik Howell ([email protected])

Oct 13, 2006 | Sony LBT-XG500 Shelf System

Not finding what you are looking for?
Sony LBT-W300 Shelf System Logo

Related Topics:

254 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5686 Answers

The Knight
The Knight

Level 3 Expert

76100 Answers

Ekse

Level 3 Expert

13434 Answers

Are you a Sony Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...