Question about Polk Audio MMC5250 Car Component System

1 Answer

Broken crossover Hey, I have a momo 5250 cross, It has no cover so I could mount it behind the glovebox. long story short, cross comes loose, tears up the dual/single switch.... Anyone know a fix or a source for just the cross...? The speakers are fine so I hate to replace everything. Thanks! Thornton

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 752 Answers

They're usually just a standard DPDT slide switch. Try Radioshack.

Posted on Sep 22, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My dryer spins but barely, it seems to be scrapeing on the bottom? Any ideas how to fix?


Possibly loose belt. Mostly the belt tensioner is come off or its mounting screw came loose.
Try this:
Unplug the power.
Open the top lip (cover) . Open the front panel.
Check the tensioner under the drum. The spring must stay in place. All the mounting bolt or screws must stay in place.
Check the belt. if it's tear off or expend too long then possibly need new one.

Good luck

Mai

Feb 08, 2017 | Dryers

1 Answer

Where are the a/c blower control valves?


It's a small electrical box mounted on the black duct work behind the glovebox. Has 2 screws holding it on there. It's about 3 inches long and 2 inches wide. The black plastic cover you look at when you first look at it had to come off and then you can get to it. Should be 2 7mm bolts.

Feb 18, 2015 | 2002 Chevrolet Silverado 1500

1 Answer

2007 Honda Pilot EX-L lighter socket unscrewed


It clips in from the back. Just reach your hand around and push in from behind. If the clips are broken then that is another story.

Mar 19, 2014 | 2007 Honda Pilot

1 Answer

I have a 80 dodge truck carberated I am getting no fuel to carb and fuel pump is new i blew out lines and checked sender filter for blockage I'm stumped Advice please??


Most likely broken offset fuel pump drive, mounted on cam gear behind timing cover. Tear down required to inspect.

Jan 11, 2014 | Cars & Trucks

1 Answer

I need the mounting bracket that attaches to the story rod. the model of receiver is rt-a1655


check with bosch or cst/berger. robotoolz is now owned by bosch and they have eliminated most of the robotoolz product line

Jun 17, 2010 | Robotoolz RT-5250-2XPK ePlane XP High...

4 Answers

Where is the cabin filter on a 2003 honda odysseey


The cabin filter is located behind the glovebox.
First lower and remove the glovebox
If it has not been changed before, you will need to cut the plastic crossbrace behind the glovebox.
Once out of the way, unbolt the steel reinforcing frame behind the plastic and set it aside.
The cabin filter is mounted vertically behind it.
See images for further explanation:

51b70ba.jpg
645c9b6.jpg
27573b7.jpg

Feb 26, 2010 | Honda Odyssey Cars & Trucks

2 Answers

I have a Panasonic EAA046B amp connected to a Polk Momo speaker system installed on my 2006 Sea Ray boat that was factory installed. Last week when we turned on the stereo all we got was short basey thuds...


Hello, if you know how to use a volt/ohm meter and you are comfortable with taking the bottom cover off the amp I can assist you in testing a few things to narrow down the problem. The easiest way would be to talk to you on the phone if you don't mind. I own a car audio installation and amp repair shop. If you want to do it by e-mail we can do that to. I would have to walk you thru the steps, it would'nt take long. Taking the amp out and taking the cover off takes longer. Anyway let me know. It sounds like you may have a power supply problem. Or, it could be a few other components inside. It's hard to say without doing the test that I would help you with first. Cause the amp is coming on but you say with some thumps coming from sub and nothing from the other speakers. It maybe doing the same on the other speakers but because there are crossovers on them it would cut off that low frequecy noise. You could also maybe have some shorted output transistors but like I said, have to do thaqt initial test first if your up to it. Send me a private message so I can get your info or i'll give you mine to decide what you want to do.

Aug 18, 2009 | Panasonic Car Audio & Video

1 Answer

No sound out of tweeters, highs out of woofers?


it does sound like you shorted out your crossover which can be fixed if you know what you are doing, but in the long run i would try to get another one i know that raidoshack sells some small ones and is also cheap, if your positive that you didnt short out the crossover se if it needs power, see if you can cross your woffers and tweeters on the crossover, if not is there any settings that u can change on the crossover? hope i helped :)

Apr 28, 2009 | Jl Audio VR650-CSi Car Component System

1 Answer

2002 Toyota Highlander AC main control


Before tearing out the AC control, does the temp knob feel loose or wobble alot more then the fan knob? If so pull the temp knob straight off. Look at the small nut around the shaft the knob came off of. Its common for them to come loose. Just tighten it up some and reinstall the knob. Your temp will work normally now.
This fix is for the manual system not the auto ac system.

Mar 28, 2009 | 2002 Toyota Highlander

1 Answer

Speaker has no bass


Make sure there are no wires that could be crossed (i.e. positive and negative).  Also check the speaker for any tears below the cone in above the magnet.  Hope this helps.  Good luck.

Jan 06, 2009 | Denon SC-M201 Main / Stereo Speaker

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

55 people viewed this question

Ask a Question

Usually answered in minutes!

Top Polk Audio Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4915 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

78238 Answers

Are you a Polk Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...