Question about Husqvarna Garden

1 Answer

Electrical- everything just stopped, have good battery, but everything is "dead"

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 188 Answers

Check the battery connections are clean and tight.
Check the connections on the starter solenoid. The electrical system power comes from here.

Posted on Nov 18, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Would a dead battery stop your key from turning on in a 2003 gmc envoy


Sounds like a flat battery. Just enough to power your lights but not enough to power the starter motor. Try recharging the battery.and check battery connections are good.

Feb 22, 2015 | 2003 GMC Envoy

1 Answer

Mazda 626 1999 with electrical problems. Replaced alternator, battery checked out, electrical quits while driving.


When you say everything goes dead are we talking all lights, radio, wipers? If so, main power or ground cables bad or fusible link. If just engine, check coil, ignition module, crank/cam position sensor.

Jan 16, 2015 | 1999 Mazda 626

1 Answer

97 HD Dyna wide glide electrical system dead


Hi Anonymous, check your main fuse/circuit breaker for continuity and check your battery ground cable at both ends. Good luck.

Jan 31, 2013 | Harley Davidson FXDWG - FXDWGI Dyna Wide...

1 Answer

Electrical problem


check ignition switch terminals and block connector...

Jan 09, 2013 | 2004 Yamaha V Star 1100 Classic

1 Answer

2005 yamaha v-star 1100 with no power to starter or headlight when I turn on the key. Is there a relay of fuse somewhere that might be bad


Did you ever get this figured out? I have same problem on '04 V Star 1100. Started to take off from a stop sign and everything went dead. Found fuse under seat, it's good; battery is good, put on charger anyway... NOTHING electrical works when you turn on the key. HELP?!

Sep 11, 2012 | 2001 Yamaha V Star 1100 Classic

1 Answer

Had starting problems and cleaned terminal wires, car started. Yesterday same problem, adjusting wires did not work. Had battery jumped, car started. I warmed up car for 5 minuted before driving. Car...


I would say that you need to replace the alternator. The car was running on the batteries power. When you drove the car, it ran the battery completely dead.

Jan 14, 2011 | 1997 Ford Taurus

1 Answer

Everything electrical stops working, and then starts.


I had a similar problem with a Ford F350 diesel truck where the truck when started would cycle off and on until it settled down then ran steady. Finally it hadn't power to anything. I found that there are two heavy 10 gauge wires that lead from the positive terminal of the battery, leading to a connector block, and the terminal was corroded so thin that if finally burnt off resulting in a dead truck. I would check out that same circuit in your Jeep, every car has one, it is a fusible link type or just leads to the main fuse block. There may also be another possibility, and that being a dead short that immediately drains the battery to zero. Check the battery voltage with a voltmeter, if it's at 12 volts, then look elsewhere. From your description though it looks like the first problem.

Jun 24, 2009 | 1996 Jeep Grand Cherokee

1 Answer

Electrical


sounds like you have got dead cells in your battery , they wont hold a charge , the loud click was probably the cells in the battery arking and killing the cells off ,id fit a new battery and all should be well.
hope this helps
kind regards
bert31000

Mar 18, 2009 | 1997 kawasaki ZZR 600

1 Answer

Motorcycle wont start


Check the battery connections, especially if you hear a click just before it goes dead. I know that on my bike, when this happens, the screws that hold the battery cables in place have backed out and not getting a good contact. You would think that with a bad contact that it would stay dead when you turn the key off then back on, but oddly, everything comes back on normally until I hit the starter button. Check the cables.

Aug 05, 2008 | Harley Davidson Harley-Davidson Motorcycle...

Not finding what you are looking for?
Garden Logo

Related Topics:

33 people viewed this question

Ask a Question

Usually answered in minutes!

Top Husqvarna Garden Experts

Phil Walker
Phil Walker

Level 3 Expert

605 Answers

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

Roland W VanLue
Roland W VanLue

Level 3 Expert

486 Answers

Are you a Husqvarna Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...