Question about Craftsman Garden

Open Question

Craftsman riding mower 917.28714 runs fine for a few minutes then starts slowing down and eventually comes to a stop though the engine is running normal

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 71 Answers

SOURCE: Craftsman 42 inch riding mower. Runs great

how old is your plug? try cleaning and regapping it or replacing it at any rate make sure it is gapped correctly also make sure there is no rust dust or debris is on flywheel or coil also the flywheel keyway does more than hold the flywheel in place it servs as a timing pin and sometimes the slightest wear on it can cause the machine to start hard but otherwise run great good luck hope you find the problem.

Posted on May 02, 2009

smartr10U
  • 1305 Answers

SOURCE: Craftsman mower with 20hp B&S Intek won't start/run

That throttle cable issue sounds like it may be the culprit. the cable housing (the outer casing for the wire throttle cable) may not be anchored correctly. Which may be allowing you to move the throttle without any change at the butterfly control on the carb. make sure the cable housing is anchored at both ends.. by the throttle control and at the carb area.. That may be your problem... hope it is that simple...
K

Posted on Jul 23, 2009

  • 299 Answers

SOURCE: Craftsman riding mower won't move.

yes it is a bad belt unless it is a hydro-stat(no clutch) you need to look under the mower and see if the belt is on correctly

Posted on Sep 30, 2009

  • 1 Answer

SOURCE: possible carburetor problem? Mower runs for

i have a lt 1000 2005 when i start it with cold engine it boggs for a minute then it starts to run smoothly please help me

Posted on May 08, 2010

  • 391 Answers

SOURCE: white smoke coming out of mower

It sounds as though you are losing power (electrical power); see if charging the battery fully allows it to run longer or if charging the battery helps.

Posted on Jul 16, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Oil leak on riding Craftsman LT2000 (Kohler)


Fortunately, the engine oil doesn't go through any rubber hoses, so they are mouse-proof. The oil probably leaked out through an engine seal. Oil on the engine surfaces would smoke when it gets hot. Check your oil level and top it up if necessary, before you run the engine again. The engine can run fine even with a slow oil leak; you just have to watch the oil level from time to time. The leak could be easy to fix - by tightening up a few bolts -- or expensive.
The gas runs through rubber hoses, though. If mice ate through that, I think you would have smelled the gasoline, and the engine wouldn't run for more than a few seconds. But if you see a severed hose, you should replace it. Take it off and bring it to a mower shop or auto supply shop, and buy something the same diameter. Inexpensive.
Hope this helped! If so, please rate my answer, thanks!

Jun 07, 2010 | Craftsman 17.5 hp 42 in. Deck Lawn Tractor...

1 Answer

Engine cutting off


Depends on how it cuts off. If it gradually slows down over a few minutes or surges, it's likely the carburetor needs to be cleaned and rebuilt. But if it's an immediate cut off, it's likely to be a safety switch such as the one that shuts down the engine when you get off the seat if the mower is running. Sometimes this happens frequently to a light person who bounces on the seat when mowing.

Jun 07, 2009 | Craftsman 17.5 hp 42 in. Deck Lawn Tractor...

1 Answer

Possible carburetor problem? Mower runs for


i have a lt 1000 2005 when i start it with cold engine it boggs for a minute then it starts to run smoothly please help me

Apr 19, 2009 | Craftsman Garden

1 Answer

Push mower runs then quits!!


My toro mower starts and will run for ablut 15 minutes and starts to cut out and eventually stop running. What could be the problem

Apr 01, 2009 | Craftsman Garden

Not finding what you are looking for?
Garden Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Craftsman Garden Experts

Dean Gruber

Level 2 Expert

110 Answers

Roland W VanLue
Roland W VanLue

Level 3 Expert

486 Answers

Dennis Key
Dennis Key

Level 3 Expert

2478 Answers

Are you a Craftsman Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...