Question about Music

1 Answer

Ibanez Srt preamp issue

I have a Ibanez aw70ece-nt with a srt preamp. Suddenly when I plugged my 1/4" no sound came out. Thought it might be a battery issue. So I changed the battery. Now my built in tuner doesn't tune and no sound comes out. All I get is a blinking green light. Please help.. Thanks.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

Try opening it up and pinching the two prongs around the patch cord to tighten it up. My bass was cutting out for a while and giving out no sound till i did that

Posted on Jul 29, 2013

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 5603 Answers

SOURCE: Hello, I have found that Ibanez

There is little data on the internet about this... However my AEL20E uses 2 AA cells. Some older ones may have used a 9 volt battery. Yours should use the 2 AA cells which go into the box right by the XLR output plug.

Posted on Feb 16, 2011

  • 1212 Answers

SOURCE: i've changed battery in isys+ pre amp on vintage vec500 and now tuner doesn't work (it is blinking green on note tuner no matter of tune and no note letters showing - blank screen)

Is the battery installed in correct polarity? If so- try rotate it in position to rub through potential corrosion.

Since it has a remote battery, it would not hurt to look at the installation to make sure no wires are broken. Especially the ground wire to the pickup.

It might also be a good idea to apply some contact cleaner to the output plug since it is in the power circuit. Cycle the plug in and out a few times to clean the contacts. Also some contact cleaner to the preamp controls would be useful.

Be aware some lubricants may contain silicone and that can interfere with wood finishes or repairs to the finish in the future.

Posted on Apr 07, 2012

rzepka159875
  • 2 Answers

SOURCE: Hi, My Ibanez AEL 20

Ibanez V72ECE hey i bought new ibanez and the tuner not working, i bought new batteries but still cant run. maybe its some way to activate it or its just bad one? rzepa181@yahoo.com plx helpme

Posted on Nov 27, 2012

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have an IBANEZ AEG10E with an Ibanez SST Fishman pickup. The problem is the lower three strings are not as loud as the Higher three strings when connected to an amp or mixer.


Assuming you have the bass eq turned up, the problem will be in the pickup rather than the preamp . It's easiest to just replace it.

Sep 25, 2015 | Ibanez Music

1 Answer

Ibanez Pre amp problem


It sounds like the guitar pickup may be faulty. It may be a loose connection on the which could be soldered easily or it may be damaged in some other way.

As this is isolated with your G string, I suspect the individual pickup unit is at fault.

Apr 16, 2014 | Ibanez Music

1 Answer

When i plug in to an amp i have no output


Check you battery and/or connections. You need to know in particular if the pickup wire is intact, and going to the volume/tone preamp. There would also be another wire going from the preamp to the plugin socket. If it uses a battery, check the power connections there. I hope this helps

Mar 12, 2014 | Ibanez EW20-MBE Acoustic-Electric Guitar

1 Answer

Hi, I have a problem with my ibanez ew20ase preamp tuner, it was working fine yesterday, now today it doesn't turn on at all, I've tried new batteries but to no avail, also, when I amp it up, preamp works...


I can't seem to find info on this preamp but, that sounds like a power supply problem, considering, the tuner is the part of the circuit that would need power. Volume and tone controls don't, unless they are active,(which I've never seen a reason for). I would try a new battery, because I think you left it on overnight, check the slot for corrosion or a loose wire or connection.

Dec 02, 2013 | Music

1 Answer

There's no sound when I put a cable in input, but when I put headphones too, there is a sound. How to reset ibanez mimx65?


If the sound you when plugging in the headphones is coming from the main speaker, it is just the interupt contacts on the headphones are making or breaking contacts. This can be a good sign if there is volume to it.

Make sure the plugs you are using are the right length for jacks in the Ibanez as there are 5 lengths in use.. If this just developed, the length issue is not a concern. If the jacks are loose, snug them down, it may be a faulty ground relying on the chassis contact with the jack.. It may be a broken wire. It can also be a dirty switch contact or dirty level control, especially the standby switch. make sure they are clean with some contact cleaner. Make sure your level is turned up too,

If you have effects, or a preamp on the guitar, make sure they have fresh batteries or good power connections and are not on mute.

Apr 11, 2012 | Ibanez MIMX65 Modeling Guitar Combo...

3 Answers

I have a Ibanez V Series V70CE. It play well. But sometimes when I connect it to the amplifier, there seems to be loose connection and no sound is heard. When I move the wire little bit sound come...


Many try to use poor quality guitar cables and have the problem. The sleeve of the guitar cable plug turns on the battery in the guitar. Always loop the guitar cable through your belt or the guitar strap to avoid the cable wisting the plug in the guitar causing noise and WEAR that wears the plug sleeve to the point it no longer will activate the guitar.

Sep 18, 2011 | Ibanez V Series V70CE Dreadnought Cutaway...

2 Answers

Hi, My Ibanez AEL 20 has a preamp - tuner 5AEQ45F. Tuner works but there is no signal in output jack. Guitar is quite new, and the preamp hasn't been used before. Can I get a PCB schematic diagram...


Remember that while in tuner mode, the audio output is disabled. Try additional presses of the tuner button to see if the audio comes back on. Also verify the volume and EQ gains are turned up. Verify the battery is new.

May 30, 2011 | Ibanez Ael20e AcousticElectric Guitar with...

1 Answer

Hello, I have found that Ibanez AEL20 guitars' 5AEQ45F (SRTn) preamp-tuner has a 6V voltage, my AEL20 guitar came with 1,5 V batteries (3V in total). There is no internet source to get the...


There is little data on the internet about this... However my AEL20E uses 2 AA cells. Some older ones may have used a 9 volt battery. Yours should use the 2 AA cells which go into the box right by the XLR output plug.

Feb 16, 2011 | Ibanez Ael20e AcousticElectric Guitar with...

1 Answer

Ibanez suddenly quit sending signal to the amp


First off make sure it hasnt had a KILL switch installed and that its not in kill position.

These models have suffered some wiring issues in the past and your may be one of those.

If you feel comfortable with a soldering iron then here is the wiring diagram

If not a local music shop will check it out for you and suggest any repairs.

Nov 19, 2009 | Ibanez Grg170dxbkn Electric Guitar Hsh...

Not finding what you are looking for?
Music Logo

Related Topics:

569 people viewed this question

Ask a Question

Usually answered in minutes!

Top Music Experts

Vito Vacirca Jr.

Level 2 Expert

140 Answers

yadayada
yadayada

Level 3 Expert

75197 Answers

kakima

Level 3 Expert

102366 Answers

Are you a Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...