Question about Hoover S3755 WindTunnel Bagless Canister Vacuum

1 Answer

Red power light blinks even with completely clean canister and filter

Power light indicates the suction power selected in 3 increments. But all of the sudden the light starts blinking almost immediately upon turning on. But suction seems fine.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 4 Answers

Check for a filter where the air blows out of the machine. Could be clogged.

Posted on Jul 26, 2013

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
wayneard
  • 1901 Answers

SOURCE: Red light for HIPPA filter won't go off

Red light is sign of reduced suction due to a blokage of some sort. If you are sure the filter is thoroughly cleaned, check the hose, wand, and the nozzle connector for obstructions of any kind.

Posted on Oct 25, 2008

  • 3 Answers

SOURCE: Hoover Savvy has limited suction when cleaning the floor and carpet

With the unit standing upright, double check the clear plastic air passages on the sides of the vacumn to see if they are clogged.

Posted on Jan 07, 2009

  • 1 Answer

SOURCE: no suction power ,brush wont spin on carpet power nozzle. When it

You need to replace the belt that turns the brush.

Posted on Jul 03, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Filter queen vacuum head has no power


More information needed. When you turn on the vacuum do you hear the motor running? Is the problem that there is no suction at the head? Is there suction at the canister when the hose is removed? I would first check to make sure that there is no obstruction in the hose. Have you checked the filters to see if they are clean?

Sep 11, 2014 | Filter Queen Majestic Canister Vacuum

1 Answer

Red light indicator comes on with suction only


Hi there Christy! It sounds like you possibly have a clog in your main hose. To check the hose for clogs remove the hose completely from the vacuum from both ends. Use a broom stick or something similar to loosen and remove any clogs from the hose. Remove the bottom plate and the brushes. Use a wooden spoon to gently break up and remove any clogs from the lower hose. Hope this helps!

Jun 16, 2014 | Hoover Nano Cyclonic Compact Bagless...

1 Answer

Kenmore canister vac 25614


Have you checked and made sure that the hose is COMPLETELY clear and the bag is not full?

Feb 13, 2009 | Kenmore 25614 / 25615 Progressive Bagged...

1 Answer

Lack of suction


I use a broom handle..works very well

Nov 26, 2008 | Kenmore 23612 Progressive PowerMate Bagged...

1 Answer

No suction for use of crevice tools, running hot, then shut off


Obviously no suction in hose would indicate a blockage, over heating is a breaker that shuts off the machine when it over heats. There is no way to clean hose the on this model because the hose does not detach at either end, therefore I had to employ the use of the good old wire hangar. Job complete up and running, with good suction. It is amazing what a prayer to God can do.

Nov 17, 2008 | GE 106766 Bagged Canister Vacuum

1 Answer

Red light for HIPPA filter won't go off


Red light is sign of reduced suction due to a blokage of some sort. If you are sure the filter is thoroughly cleaned, check the hose, wand, and the nozzle connector for obstructions of any kind.

Oct 25, 2008 | Hoover S3755 WindTunnel Bagless Canister...

2 Answers

Miele Solarus Canister Vacuum stopped working


I am an amateur and novice.
Tracked My Miele problem to a bad connection at the outlet plug.

i think the constant slapping of the plug against the housing during rewind prob disconnected the wires inside the plug? Replaced plug

Apr 14, 2008 | Miele CatAndDog700 Bagged Canister Vacuum

1 Answer

Performance indicator light is on and suction is not strong


You do have a clog! trust me. Check the wand and the yoke which is on the brush assembly. its the part that connects with the wand.
if thats not it then it has to be in the hose. the only way to get it out of the hose is to take one or both ends off and push a broom stick through it

Feb 03, 2008 | Kenmore 25614 / 25615 Progressive Bagged...

Not finding what you are looking for?
Hoover S3755 WindTunnel Bagless Canister Vacuum Logo

246 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1461 Answers

Brad Brown

Level 3 Expert

15633 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...