Question about MTX Terminator TN400/4 Car Audio Amplifier

Open Question

Mtx amp. 3 red lights

Everything was working fine. then out of no were turned on the car one day and nuthin works but the streo. the amp shows 3 red lights. not flasging just solid red lights. what do i do

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 631 Answers

SOURCE: mtx 1501d no sound

There are a number of things that can cause it to act as you described. Have you pulled the covers off of it yet to see if you can see any problems?

If you do, disconnect power from it and don't touch ANYTHING on the board when ANY of the 3 LEDs (2 are not visible from the outside) are lit.

Posted on Aug 19, 2008

Ad

SOURCE: Apx stopped working, MTX 702x

maybe the audio amplifiers Ic´s damaged or the power fet

Posted on Mar 06, 2009

jrw4u
  • 62 Answers

SOURCE: Everything works fine but my amp light is red.

if its not coming on it usually means you have a bad ground if it works for a little while then does it then its over heating and you will need to get a fan

Posted on May 01, 2009

nate6556
  • 103 Answers

SOURCE: MTX Terminator Amp...Red light comes on when it should be green.

its just a power light to let you know its on

Posted on Jul 25, 2009

judd0081
  • 334 Answers

SOURCE: I installed a MTX Thunder 3401 with a PA sub.

You are def overheating, If the ohms rating of the subwoofer is too low it will cause this same thermal over heat. If you have 2ohms in sub and a 4 ohms stable amp, you will overheat. Check the ohms rating of the sub to make sure this is not the problem

Posted on Feb 03, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a sylvania tv lc26oss1, red stand by light is on. How can I get my tv to come on


Press the power button, if that dont work hold the power button on the tv,, not remote.. For 12 seconds or untill the light flashes a different color or same color then let it go. Then turn tv on when the light is done flasging

Jul 08, 2014 | Computers & Internet

1 Answer

Crowm micro-tech 2400 goes straight to protect upon start


Ok,

Lets get this straight, you are saying that a CROWN MICRO-TECH2400 power amplifier show the two front red lights when you turn it on? Because it supposed to do that if everything is fine, when you turn your amp on and one of the lights or both don't turn on then you have a serious issue with this great amp, keep me informed in case you need further help.

Nov 07, 2013 | Crown Audio Players & Recorders

2 Answers

MTX tna251


I have the same sub combo. The problem is the amp is underpowered for the 2 MTX 12s, get a bigger amp and you should be fine.

Nov 13, 2011 | MTX Car Audio & Video

1 Answer

I have a MTX 300XD...it just stopped working. I tightened everything up and it still doesn't work. the red light is on but there is a green flash and when it flashes it makes a noise that I can hear...


What is the electrical system in the different car like?You may need to get a secondary battery for that amp.Also ceck your in line fuse,it may need to be larger.Sounds to me like you either do not have enough power,or a ground is not connected.

May 20, 2011 | MTX X Thunder 300XD Car Amp

1 Answer

Sony xplod amp won't work it stopped for no reason


try hooking the amp up with 3 wires, the red power wire, the black ground wire, and the remote wire, do not hook up the speakers at this time

Apr 25, 2010 | Car Audio & Video

1 Answer

I bought a MTX Terminator amp and the light is red when I turn it on, but it works. Red usually means protect mode but it works fine. Should the light be red or green?


all depends on that amp... if there was an issue it wouldnt work, and the light would be by a protect symbol... if its just red next to the power symbol i say no issue.

Feb 18, 2010 | Car Audio & Video

2 Answers

JBL amp, worked fine untill 2 days ago. protection light on..


might have roasted your speakers voice coils a little which may be sending the amp into protect mode throw a speaker on it that you know works and if it doesnt trigger the protect circuit then you probably have a blown or almost sub.

Jan 02, 2010 | JBL BP1200.1 Car Audio Amplifier

1 Answer

Sub not working and red light on amp stays on?


the amp is under to much pressure get a bigger 1

Nov 18, 2009 | MTX Thunder 421D Car Audio Amplifier

Not finding what you are looking for?
MTX Terminator TN400/4 Car Audio Amplifier Logo

Related Topics:

37 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

hoyzee1

Level 2 Expert

150 Answers

yadayada
yadayada

Level 3 Expert

80417 Answers

RegWorts

Level 1 Expert

12 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...