Question about Planet Audio PX1500M - 1500W MOSFET Monoblock Power Amplifier wit

1 Answer

Planet Audio PX1500M Amplifier Problem

I recently installed a Planet Audio amplifier in my vehicle. It worked fine for 2 weeks and then it suddenly stopped working out of nowhere. Short details about my setup: - (Cable) 4 gauge power - (Cable) 4 gauge ground - (ANL Fuse) 200 Amps - (Regular Fuse) 30 (In Amp) - (Amplifier) Planet Audio PX1500M [1500 Watts @ 4 ohms] - (Subwoofer) Kenwood KFC-W3013PS [1200 Watts @ 4 ohms] - (Amplifier Features) "Power" & "Protect" light indicators To better help understand my situation, as I stated before, I was driving and listening to music and everything was playing fine as it always does and then suddenly out of nowhere the sub stops playing. As I head home, I check to see what caused the problem and I noticed that the "(Power)" light of my amplifier is not lit up as it always is. As soon as I see that, I immediately checked to see the (power) and (ground) connections to see if they are not burned or lose. Seeing that that neither of the two are the problem, i still cut off a new tip for both ends of both cables to make sure that it's definitely not burnt. After I did that, I powered the amp back on and its logo lit up as usual but the amp would still not push the sub or even display the "(Power)" light. I checked the fuse and even went and bought some new ones hoping that would fix it and nothing. Both the fuse on the amp and the one in the engine bay were fine. Checked the sub and tried it on my friends system and it still bumped so I know the sub is not blown. Also overheating is not a problem since I've turned the car on multiple times and the amp still does not want to play through the sub. So my questions are: Why is the amp not pushing power through? Is my amp blown out? Can it be fixed? The help will be greatly appreciated!

Posted by on

  • Michael Rey Jul 16, 2013



    This website has the format all messed up so I hope this makes it easier to read. Again, thanks!

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    New Friend:

    An expert that has 1 follower.

  • Contributor
  • 1 Answer

Check the FUSE to ensure that current is not cut off.

Posted on Jul 22, 2013

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi,i got planet audio 1800w anarchy,now was playing great,but now when i play music after 20sec i loose sound and after turning it off for a while it plays again and 20-30 sec same thing any suggestio


Need to check your ground wire it has worked news from where you got it hooked up at or at the amplifier even though it seems like is hooked up if is not properly plugged up or if it your amplifier will come on but is not getting the necessary ground to work properly you may also want to check your Hotwire make sure that it is plug up properly and at the battery terminal make sure that it is not corrodedalso are you sure you are getting enough wattage to your amplifieranother words is your battery putting out enough power to it

Jan 22, 2015 | Planet Audio " AC1800.5 ANARCHY MOSFET...

1 Answer

Planet audio


Sounds like your power supply to the amp. Make sure you location has plenty of air flow around it and use at least 10 gauge wire to the power input. Same size on the ground and make sure all contacts are clean. Your alternator will run hot when the sound is cranked and the car is moving. The heat lowers the amperage output of the alternator and will cause the amp to cut in and out.

Nov 07, 2013 | Planet Audio PX1500M - 1500W MOSFET...

1 Answer

Planet audio px1500m


To many toys not enough power ...... Extra battery or bigger alternator

Nov 07, 2013 | Planet Audio PX1500M Mosfet Monoblock...

1 Answer

How many planet?


only 9 planet in this universe bobo

Apr 02, 2011 | Planet Audio VX4002 Car Audio Amplifier

1 Answer

It worked for a week and now im getting no power to my subs


if it stopped suddenly i would check the fuses and work your way back to the where the remote start wire is attached. if you where pushing it hard the fuse is likely. also check the connections on the amp closely.

Jan 28, 2011 | Sony HK720-4 Kole Audio 4 Channel Car...

1 Answer

Denon AVR-2309C1 will not play sound through


Turn off zone 2 then turn your receiver on the main zone on Radio, tune in a station and check for audio. Post a comment and let me know if audio works that way. If you don't have any audio, list your other equipment makes and models as well as how they are interconnected to your receiver (cable type) and I will help you troubleshoot

Jun 28, 2009 | Denon AVR588 Receiver

1 Answer

My amplifier stopped working? Why?


either smell your amp and see if it could have blown or the place that installed your deck didnt hook up your rca jacks

Mar 29, 2009 | DB Drive Speed A600 Car Audio Amplifier

1 Answer

I have a Planet Audio VX900


why do you need a car with an eeprom to operate your amplifier?

May 09, 2008 | Planet Audio VX900 Car Audio Amplifier

1 Answer

Planet audio vx3002


Sorry wayne2953 but this amplifier isn't stable @ 1ohm loads. This amplifier would be better suited running a pair of 12's, 4 12" subs could run if configured correctly but the subs would be underpowered and probably not sound very good.

Features of Planet Audio VX3002:

  • Max Power (2 Ohms) : 300W x 2
  • RMS Power (4 Ohms) : 150W x 2
  • Bridged Power (4 Ohms) : 600W x 1
  • Signal-to-Noise Ratio : 102dB
  • Frequency Response : 20Hz-20kHz
  • Dimensions : 10-5/8"W x 2-7/16"H x 16"L

Mar 31, 2008 | Planet Audio VX3002 Car Audio Amplifier

Not finding what you are looking for?
Planet Audio PX1500M - 1500W MOSFET Monoblock Power Amplifier wit Logo

205 people viewed this question

Ask a Question

Usually answered in minutes!

Top Planet Audio Televison & Video Experts

The Knight
The Knight

Level 3 Expert

75424 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Cindy Wells

Level 3 Expert

5419 Answers

Are you a Planet Audio Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...