Question about Office Equipment & Supplies

1 Answer

Faulty mitsubishi legnum ignition coil

One coil, after running the engine for a couple of minutes starts heating up and eventually starts to melt the top of the unit. not sure what causes this. any help to rectify this problem would be appreciated. cheers.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers

Please indicate local agent in sri lanka for kycera taskalfa 180

Posted on Jul 15, 2013

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Mitsubishi legnum vr4 1996 cranks but don't start no spark to coil


run fault codes
could be crank/ cam position sensor
ignition control module
immobilizer not operational
broken timing belt/chain

Aug 22, 2016 | Mitsubishi Cars & Trucks

1 Answer

It will crank and run good for 10 minutes and shut off. Once it shuts off when you restart it, it will only run for a couple of minutes and shut off again ?


I would start by getting a can of carburetor cleaner and have it 'at the ready' and try the 'start, run stall, start run stall' operation again. Only THIS time, once the engine begins to stall, give it a couple of quick shots of the cleaner into the air filter to see if it stays running on the cleaner.

If it does, then it's still a fuel problem. If it doesn't, then it probably an ignition problem. I would be sort of leaning towards the ignition coil getting weak. The reason I'm saying that is your statement about it running (I'm assuming cold start) for at first, 10 minutes then it stalls. Start it again and it runs for a couple of minutes and stalls again.

This could possibly be from the coil getting warm/hot and not producing the needed spark. After a 10 minute run it simply gets too hot and stalls the engine. After the next restart, the coil is already warm from the engine and so it don't take as long for the coil to get hot and stall the engine again.

Hope this makes sense and helps you out.

Apr 25, 2015 | Honda Gx340 Gas Engine 11hp Motor Pressure...

1 Answer

My 1996 legnum was jumping from 4th 2 3rd gear n back while accelerating,, lost all power...died n wont start again? help please.. there are no signs of any fluids leaking


Legnum?
Mitsubishi Legnum????
Mitsubishi Aspire
Mitsubishi MX/MF
Mitsubishi VRG
Mitsubishi VRM (Hong Kong)
9 engines offered, day 1.
and many trans,
4-speed automatic
5-speed manual
5-speed semi-automatic

Mitsubishi F4A23-2; 4 Speed
KM175, KM176, KM177 - F4A21-2 (176-5), K4A22-2 (175-5), F4A23-2 (177-8); ES Model
41TE
F4A33-1

the truth is , you didnt post country, nor engine size.
they match engine power to transmission (load rating)
so>? forget that.. that is for later.
IT DIED< so if the engine dont START the tranny issues are moot.
so does it crank.????
if it cranks , it next needs spark got spark to all cylinders.
that is if its not the Diesel engine, IS IT??





May 04, 2014 | 1996 Mitsubishi Galant

1 Answer

Engine #4G94 Mitsubishi Pajero IO coil running hot when ignition is on


coils are normally hot when the engine is running but if it is over hot ( burn to touch) then it may be a 74.5 volt resisted coil running on 12 volts . IT may be excessive current draw through it from a faulty ignition module in the distributor or it may be just a failing coil.. Leaving an ignition on without running the engine will overheat a coil.

Apr 03, 2014 | 1987 Mitsubishi Montero

1 Answer

1995 ford 4.9 stright 6 runs for a couple min then dies


The parts you replaced don't typically fail due to heat/cold cycles.You need to see if it might be the ignition coil.Make the coil easily accessable(take of the engine cover).Have a 12v test light and some sort of spark tester handy.Start the engine,let it run until it quits.See if you have spark at the coil.If not, unplug the low voltage connector on the coil,and put the test light across the connector,and crank the engine.The light should flash on and off.If it does,replace the ignition coil. If it doesn't flash,you may have a bad crank sensor,but this usually won't make it shut off,instead,it will cause it not to restart after heat soaking for a couple minutes.(I'm betting on the igniton coil).

Oct 26, 2012 | 1995 Ford Econoline

1 Answer

97 Mitsubishi legnum,runs great but takes a bit to start, thought it might be fuel pump relay as you can,t hear pump start when key is turned on, is that normal for legnums.


Hi,
is your car a GDI engine? If it is GDI you can't really hear the pump working when you put ign on.
Give me some details and I might be able to guide you there.
Chassis, engine numbers, GDI ??

Apr 23, 2009 | 1997 Mitsubishi Galant

1 Answer

Overchargin battery pro


then the same problem occurs again. I tried a new voltage regulator but it is still charging at 15.3 volts at an idle. If anyone has any suggestions it would be greatly appreciated!!! That sounds more like an ignition problem to me - especially if you can fire up the bike a few minutes later. I'm suspecting a heat related problem with the ignition, most likely in the coils or pickup. Not being familiar with the layout of your bike, I can't give you much more help than that.,,,

Nov 10, 2008 | 2008 Beta RR 125 Enduro

2 Answers

Vr4 with miss and back fire under load


If this just started, maybe after a hard run, you may want to check your sparkplugs. I've melted the insulator on one of my plugs after a prolonged, spirited run causing same symptoms.

Sep 25, 2008 | 1998 Mitsubishi Galant

Not finding what you are looking for?
Office Equipment & Supplies Logo

Related Topics:

18 people viewed this question

Ask a Question

Usually answered in minutes!

Top Office Equipment & Supplies Experts

kakima

Level 3 Expert

102366 Answers

k24674

Level 3 Expert

7993 Answers

yadayada
yadayada

Level 3 Expert

75051 Answers

Are you an Office Equipment and Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...