Question about Kenwood Car Audio & Video

Open Question

Kdc x597 wont turn on after install

Hello installed the harness and tested for power and ground, all good, unit wont power on though

Posted by Anonymous on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: jvc KDAVX44 install issue

No, you do not need to connect the parking break wire for the unit to be powered. My radio worked when the parking break wire wasn't attached, but you cannot watch video's or use USB without attaching it to something... you can bypass the parking break to a switch if you like.

Posted on Jul 08, 2008

  • 1 Answer

SOURCE: Pioneer deh 2300

if you were in augusta,ga i would give you one.i have a lot of them.... pioneer is the only cd player
i use

Posted on Sep 25, 2008

tommyboinow
  • 324 Answers

SOURCE: New KDC-135 has Power but Faceplate won't light up

you shold always twist the end of the wiring together and tape them never use connectors, remove the connectors and twist the wires driectly to each other and tape them wiht electrical tape, the connectors almost always can not deliver the proper voltage..

Did you make sure you have the yellow to a constant connect wire and the red to a turn on?if not this can cause the radio not to work......

you can test wich is wich by turning the key off and putting the yellow to the one you think it is and red to the one you think it is, if you have have it right you will hear the CD player make a click run sound...... if not you will not hear any thing.

Posted on Nov 26, 2008

  • 2 Answers

SOURCE: kenwood KDC-MP438U acts as if there is no power to it,dead nothin

The speaker wires are very sensitive. You need to make sure that they are not grounding out. Once the unit senses this it will shut off. Pull the plug out of the back and start over.

Posted on Jan 05, 2009

  • 18 Answers

SOURCE: I can't play my iphone on my kenwood KDC-MP435U

Jennifer, I have the same issue. the problem is that the 2007+ generations of Kenwood receivers are not compatible with the iPhone. You will need to get a 2009+ series in order to use your iPhone with the head unit. I had the same issue with the Kenwood KDC-MP435U in my mustang. I am going to get a newer head unit that supports the iPhone. You cannot do it with the MP435U.

Posted on May 30, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenwood kdc x597 no sound through the rca conection to my amplifier


Make sure RCA is on threw head unit,
2.make sure you have good cables
3.most ken units have 2 sets of RCA
hook ups one is for cd/changer the other
is a low pass for amp.
4 you have bad RCA channels send to
kenwood for service

Jun 01, 2014 | Car Audio & Video

1 Answer

How to get clock to display on kdc x597


Mine has a clock setting ,, but there is no clock showing on the face at all..

Jan 27, 2014 | Kenwood eXcelon KDC-X597

1 Answer

How do i get sound to play?


  • Did you check your factory wiring connection , going into your adapter wiring harness?? And double check that you have a strong ground wire connection......

Jan 26, 2014 | Kenwood KDC-X597 eXcelon In-Dash USB/CD...

1 Answer

Will not turn on


depending on who did the install . if it was a shop take it back should have a warranty. If he owner who posted the question install clarion radio here are some ideas that need to be checked out to determine what is the problem...

1. did the installer fry the radio during install
2. you must have a good ground and (12.0 volts to 13.5 volts on the red ignition switched wire only when the ignition is on or cars running) and (12.0 volts to 13.5 volt on the yellow wire which is constant power wire at all times.. even when the cars not running this is what keep all the station save and clock working with correct time)


A. buy a digital volt meter
then remove radio from dash and check the for power with out damaging any harness or wires.

what you are going to do now is unplug the wire harness from the back of the radio to use this to check for power and grounds that will make the radio work...

1. turn on the car or truck set your voltmeter to dc voltage take the wire harness for the radio and find the black wire going into it and then (take the black test lead from the volt meter and slide it into the spot on the back of the wire harness where the black wire is make sure the metal tip of the test lead is all the way in and it is making contact to the metal pin to get a reading) the black wire at harness is the ground wire

take the red test lead from the meter and do the same thing but this time your going to find the red wire on the harness . which the red wire is the ignition switched wire which is controled by the cars ignition switch

once these to test leads are touching both the red and the black you should get a reading on the meter like 12.0 volts to 13.5 volts
remember what your reading is cause at this point you need to check one other power wire to determine that problem here .
now turn off cars ignition.

There is a yellow wire that is call constant power in the radio harness turn off the car at this point and move the red test lead to the yellow wire on the radio harness. now look at the volt meter to see if you are getting a reading like 12.0 volts to 13.5 volts

if nothing here either here are some things to check


1 ignition is not in proper postion to power up radio harness
2 test lead from volt meter not making contact to metal pins on wires in the harness ( must touch metal pin not the casing of the wire to get a reading)
3. blown radio fuse in the fuse panel of car or truck or suv
4. no ground for radio ..(with out a ground radio power circuit is not complete)

how to check to see if radio ground is good
A. find a pice of metal in the car that is attached to the frame of the car sometimes you might find that there is something behind the radio or the antenna casing will work because the way the antenna grounded.
B. now retest the red (ignition switched wire ) and the yellow (constant power wire) again using the new ground location take the black test lead and touch what you think is another good ground.. now take the red test lead and touch it to the yellow wire on the radio harness make sure it far enough up into the back of the harness to make contact with the metal pin at end of wire with out damaging anything.
C if you have found a good ground you get a reading,,, just like i told you before..12 volts to13.5 volts this mean getting power

D. now check the red (ignition switched wire again ) using the new ground location . don't for get this time you must turn on the ignition switch to power up this wire and when done turn off ignition switch.

if you find that you have power now by using the new grounding location change the radio harness ground wire to this location..

if you still have no power check all fuses in the car one of them may be blown ..

if you feel after reading this that you don't think you can do this simple task look for a mecp certified installer in your area to to this for you ...

Oct 25, 2013 | Clarion Car Audio & Video

1 Answer

How to install KDC-252U in a 2000 Toyota Tacoma two-door


Check the fuse box in the engine compartment and look for the interior illumination fuse. Before you replace it you will need to unplug the radio harness and check the new unit's memory lead, the switched 12 volt lead, and the Ground wire. Somewhere one or two of these have been either connected incorrectly or the wires were pinched when the dash was reassembled.


Also check the fuse in the new unit's harness and make sure it is ok. Here are the basic power wires in the Tacoma...yellow is 12v constant, red is accessory (turns on with key),and black is ground.
If there is a blue wire, it needs 12 volts when the car is running and the radio is turned on. Check your new unit's wiring diagram for the power antenna or amplifier turn-on lead and connect that to the blue wire.
Good luck

Dec 23, 2012 | Cars & Trucks

1 Answer

KDC-MP4032 head unit wont turn on


hi, seeing that your kenwood showed up "protect" you may have an audio circuit/amplifier fault within the unit. try resetting the unit to see if unit comes "on" again. if the unit comes on and protect flashes again, then you definitely have an internal audio circuit fault. if not then check all power connections(yellow and red wire voltages, as well as ground connection), as well as the condition of the face pins!

May 31, 2012 | Kenwood KDC-MP4032 CD Player

1 Answer

Installing a kenwood kdc-135 in a 2001 monte carlo ls


Hello, my name is Israel and I will help you. The following should be able to help you out. Please rate and good luck.

constant 12+ orange
switched 12+ yellow
ground black/white
illumination gray/black
dimmer brown white
Left Front + tan
Left Front -

Apr 13, 2010 | Kenwood KDC-135 CD Player

2 Answers

Kenwood KDC-138: Removed Old stereo, installed new KDC-138, I'm getting power to the plug that plugs into the back of the unit & fuse is good. I've tried pushing the reset button. Nothing comes up on...


do you have power at both supplys on the wire harness?( red and yellow) red wire will have power with the key on. Also make sure your ground is hooked up right.

Aug 02, 2009 | Kenwood KDC-138 FM / AM Receiver

1 Answer

Have power to the unit, but will not turn on at all. Is there an internal fuse in the bse unit?


The only fuse that is serviceable will be inline on the Yellow or Battery constant wire. Both this wire and the orange (battery switched) wire need to have 12V in order for the deck to turn on. Have you tested your ground as well? Some decks ground to the chassis and therefore if not installed there will not be a ground and therefore no power.

Jul 06, 2009 | Kenwood KDC-MP435U CD Player

1 Answer

Kenwood KDC-MP438U acts as if there is no power to it,dead nothin


The speaker wires are very sensitive. You need to make sure that they are not grounding out. Once the unit senses this it will shut off. Pull the plug out of the back and start over.

Dec 30, 2008 | Kenwood KDC-MP438U Car CD/ MP3 Player

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

32 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4836 Answers

yadayada
yadayada

Level 3 Expert

75197 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...