Question about Audio Players & Recorders

Open Question

Polk dsw 660 red light

Sub doesnt work. Red light stays on wont go to green

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 54 Answers

SOURCE: Sub woofer flashing red and green

sir,,i think there is something wrong with the connections or the cross over,,,kindly check it out or mjaybe the cone of ur speaker is damage,,,hope too help you thnkss??

Posted on Jan 29, 2008

Ad
  • 2 Answers

SOURCE: Always turns to standby

Hi, I was able to take care of this issue by talking to Onkyo tech support. They diagnosed over the phone and concluded that the receiver set the volume for the sub way too low (-12), therefore sub was not receiving the input and was doing what it was supposed to be doing. They walked me through manually increasing the volume and now everything works great.  Good luck! I hope this helps.

Posted on Apr 13, 2008

  • 1 Answer

SOURCE: psw 3000 sub

I had the same problem. It is a loose conection on the print. The Amp unit goes into failsafe mode. You can check the Rc control. You are only alowed to turn it on and off. No signal regulating.
The solution is to remove the backside, and check the print for bad connections or even broken parts.
I experienced one leg on a transistor tha had broken.
Good look

Posted on Oct 12, 2008

  • 3 Answers

SOURCE: infinity tss-1100 sub problem

hey buddy, I have the same system, and although I haven't experienced it on this one, I had the Harman Kardon equivalent to the TSS-750, and the sub did this same thing. It was a loose RCA connection, and, as I was well outside of warranty, I took the amp out of the back and just re-soldered the connection myself. It now functions flawlessly for my bedroom setup. I hope you get it all worked out on your system! I can't imagine using this awesome system without its deep notes!

Posted on Feb 14, 2009

  • 1039 Answers

SOURCE: Sound cracking and the red/green light flashing

What is your question?

Posted on Aug 29, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Help with repairing this product, Polk suggests replacing the amp !!


To troubleshoot this you need at least an ESR meter. Capacitors can fail with no outside indication.

Jun 19, 2016 | Polk Audio DSW PRO 500 Subwoofer Speaker

1 Answer

What could be the issue with my sub woofer power?


Many of these SUB amps ended up with Capacitor failures in the Power supply section . Find someone who works on amps or TVs to have a look see.

May 26, 2014 | Polk Audio Polk DSW PRO 550WI Subwoofer

1 Answer

Polkaudio dsw 660 green light no out put


I have the same issue. It started after the phase switch (0 degree or 180 degrees) broke. Light is green but no sound.

May 12, 2014 | Polk Audio PSW10 Subwoofer

1 Answer

Micropro 2000 has power but has no sound even for test tones. No test tones. What is it?


This could be either a source or a sub problem.

The missing piece to this puzzle is the source identity and setup. Is IT set up correctly for a subwoofer?

If you want to test the sub by itself just temporarily feed one of your FRONT speaker outputs directly to its Speaker IN connectors.

... Or ANY device or source you have can be directly connected to its RCA Line In. BE WARNED - IF IT WORKS IT WILL BE LOUD

Register and download the manual for free at retrevo.com

http://www.retrevo.com/support/Polk-Audio-DSW-microPRO-2000-Subwoofers-manual/id/23015dj593/t/2/

The unnamed elctronic source will have a manual, too. Use it to troubleshoot.

Jul 08, 2011 | Polk Audio DSW MicroPRO 2000 Subwoofer...

1 Answer

The Ground wire is hooked up right but the red light wont go off and stay green so the amp will work. It is very frusterating all the cables are the right size its is a 1000 watt amp. I have two 500 watt...


Sounds to me like the amp is going into protection mode. Try placing one sub on the amp with very little gain. One of the biggest reason why this happens is because the subwoofers are wired wrong. What is the brand and model number for your amp?

Apr 14, 2011 | Car Audio & Video

1 Answer

Polk Audio DSW Pro 500 remote doesn't"t work. I've tried replacing the battery and was told by another technician to take the sub-woofer out and make sure the cable is plugged up to the amp and the IR...


Is this NEW? Or did it just fail spontaneously after working for awhile?

Is this just a remote control issue or is the sub dead, too?

From the manual...

No sound coming from subwoofer.

If hookup is "SUB OUT" to LFE, check and make sure your receiver is set to Subwoofer=YES. If hookup is via speaker wire, check that the polarity of the wires is correct.

Subwoofer has no power.

Is the AC MAIN switch on? Check outlet; check fuse after unplugging the subwoofer. The fuse is located under the power cord
receptacle. Fuse type and rating is found on the back panel.

Remote control doesn't work.

Remove the plastic tab to activate the remote control's battery or try replacing the battery. Ensure the IR sensor is not blocked.

If it's a new problem with a previously working remote...

http://remotes.com/remotes/servlet/rs?a=Display&contents=help_deadremote&uuid=A12954406270641


It describes a way to possibly fix your remote or at least prove it works or doesn't.



Find new or replacement remotes:


http://remotes.com/remotes/servlet/rs?a=Display&contents=home&uuid=A12992635562861


or eBay: search for "(model) remotes", check the 'include description' box. Usually cheaper than the vendors.

Mar 06, 2011 | Polk Audio DSW PRO 500 Subwoofer Speaker

1 Answer

I unplugged my rca cables from micropro 4000 and it made a loud boom. Now it no longer puts out any bass. I pushed on the sub and it feels good. The sub powers on just no bass.


Open the case and check the resistance value of the actual speaker - should be around 8 ohms. If it doesn't get a reading, then it's bad.

Jan 01, 2011 | Polk Audio DSW MicroPRO 4000 Subwoofer...

1 Answer

Got a brand new dsw pro 500 and hooked it up to a new pioneer elite receiver through the LFE input. LFE and subwoofer are turned on but the sub does not make sound.... whats up?


if there is multiple jacks on the sub be sure they are hooked up correctly simple mistake if not no doubtly a simple overlooked setting on your amp good luck you will get it

Nov 20, 2010 | Polk Audio DSW PRO 500 Subwoofer Speaker

1 Answer

DSW PRO 600 not getting signal from receiver. Why?


You don't name the electronics, which can be the source of the problem. See #3.

1. If you suspect the cable why don't you just swap in another RCA cable? BTW: there's no such thing as a "subwoofer" cable. Monster makes their money on those beliefs. Cables don't wear out but they can go bad if one or more conductors fails. Oxides devolp at either end which can inhibit conductivity. Remove each end and reinsert it with a twisting motion.

2. Maybe. You need to ensure the sub is defined. Run speaker level check. If no sound at the sub, prove the LFE/sub channel has output by running the RCA cable to a recorder or your TV (low volume). If there's no signal, duh, no speaker will work with it.

3. Mmm, not if it's exhibiting the same problem as the old one and the Polk 450. Have you looked at the setting of the Standby/Auto/On Switch? And the Power Mode LED's? Red is bad.

Mar 31, 2010 | Polk Audio DSW PRO 600 Subwoofer Speaker

1 Answer

My ps3 doesnt work


if it wont load your icons and freezes before your xmb, put it into safemode and try restoring the filing system. to get it into safemode...

hold down the power button while the console is in standby. the light will go from red to green.it will beep once flash green beep again, and then beep a third time. after the third beep the light will turn red.

once the light is red, take your finger off the power button and place it back on the power button. the light will go from red to green, beep once flash and then beep twice quickly. after it does the double beep, take your finge roff. the light will stay green and you'll get a screen asking you to connect the controller.

after connecting the controller, try option 3, or whichever option is restore filing system. this can possibly correct media loading and will 95% of the time fix the console when it freezes before loading up your icons(the xmb)

Mar 19, 2009 | Sony Playstation 3 (PS3) Console

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

104 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5487 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

The Knight
The Knight

Level 3 Expert

75599 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...