Question about Bissell 1697-7 Powersteamer Pro Deluxe Vacuum

2 Answers

Bissell 1698-1 Solution applicator indicator (red spinner) does not rotate and no solution is being applied even though both the water and cleaning sol'n tanks are full and properly nested.

Posted by on

  • 1 more comment 
  • mgholder3 Dec 23, 2007

    Same problem as above, roller moves but no solution is being applied and the red indicator is not moving. The water and cleaning solution are both full.

  • nadoak2000 Dec 30, 2008

    the solution is not going out on the carpet

  • Anonymous Jan 14, 2009

    my bissell is 1697w model. I spent twenty minutes on the line with the bissell customer service rep. My steamcleaner is broken.

    No water will come out of the bottom. I dropped mine down the stairs. I think something is lose inside. It doesn't close properly anymore, either.

    First they make you clean the sprayers on the base of the unit under each tank (the water resevoir and the cleaning fluid tank) using an old toothbrush. These things don't look like sprayers to me. Just look at the base of each tank on the machine base. By the way they are the same color as the base unit on my machine. More color mayhem. They are circular and have a thin circular cylinder in the middle. Easier to spot on the cleaning fluid tank.

    It's very confusing because they made me believe there was an extra gasket that was missing at first. (a gasket to them is a round red rubber ring). This gasket should be attached to the water resevoir bucket (that's what I call it), There is general confusion and mayhem regarding the color of the gasket as well.

    They will make you prime the lever that feeds water through the machine (hint it's on the handle) for one minute with the machine powered on. Then, they do the same thing with the dial on the machine set to powertools. If water shoots out... done but not for me.

    I had to prime the lever continuously for another thirty seconds with the machine turned off.

    nothing worked for me. and they don't now what's wrong with it. I have to take it to a repair shop. they don't even know how much it will cost to repair.

    If you dropped it... it's probably broken.



2 Answers

The heater is blocked wih lime scale

Posted on Nov 13, 2007

  • Level 1:

    An expert who has achieved level 1.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 16 Answers

These units have a heater which could be lime scale.

seriously call bissels help line its on the tag that has your model #
they will show you how to prime the pump and refer you somewhere if you need help locally..

get a pin. or something similar. locate the red spray nozzles on the bottom of the machine - clear nozzles.
do the same on the spray wand. - make be clogged with soap

basic prime is easy.. use the wand. place the machine on something like a workbench.. fill the bladder on tank hot water no soap. assure the bladder doesn't leak and the tank has the rubber piece on the bottom and that if you push it in it releases water.. if it doesn't soak it in hot water. if it doesn't have one get one.. it would likely just leak onto the floor without. install tank without the main lid on.
remove any tool that may be hooked to wand. hold the wand lower than the machine - gravity right. hold spray but and turn on machine. if it sprays without the tool clean your tools.

from the floor and the red spinner... remove the cap for the spinner. remove the spinner and the screen.. pour hot water into the opening... caution it may go through to the floor... if it does the nozzle is clear and your machine may just need to be primed..
turn on machine and hold trigger on main handle. it should have water some to the open cap.. if not then maybe check to see it will spray from the wand and don;t skip steps... if it can spray from the wand and not to the floor and everything else has passed then try remove and reinstall the main handle.. yeah you put in on when you got it.. remove it.. underneath the handle is a square button.. the upper just pushed it anyhow so try pushing it or just reinstall the handle as firmly as you can.. should have tension on trigger..

if none of those work then it may be lime scale... lastly.. wondering about why the machine is so loud without the lid on the tank and why I told you to take it off.... well the tank could be warped or something may be holding the tank from connecting to the machine.. if it sprays without the lid but not with the lid on.. remove and reinstall the clearview cover.. its likely on wrong or you may have a warped tank

Posted on Dec 19, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

My Bissell carpet shampooer will not dispense water or cleaning solution, nor is the "flow indicator" spinning

most of the Bissell carpet cleaners that have the water heating feature stop pumping water at one time or another. Make sure the belt is still on the pump and if it is then the problem is probably in the heater core in the handle. Hard water deposits plug the tiny little water ways inside the heater core. Pull the heater core and take it apart and clean it with a strong scrub brush and I think vinegar works for cleaning I was told. I just use soap and a brush. Then flush all your lines with hot water. The cause is from hard water deposits or leaving the soap in the cleaner after you use it. Both will stop it from pumping water

Apr 29, 2014 | Bissell 1698-1 PowerSteamer ProHeat Plus...

2 Answers

Flow indicator does not spin when the trigger is depressed like nothing is coming through, pump?

Usually that is showing no soap in soap tank even if there is water in the water tank.After filling soap tank make sure it locks in real good ;Thats been my problem a few times.I didnt know the water and soap were in seperate tanks the first 2 times I used mine lol....

Jun 22, 2010 | Bissell 1698 PowerSteamer ProHeat Upright...

1 Answer

Not spraying or picking up water


Here is a tip that will give you all the information you need to fix your BissellProheat Vacuum Problem.

Bissell Proheat Upright Wet/Dry Vacuum Problems


Feb 02, 2010 | Bissell 1698 PowerSteamer ProHeat Upright...

1 Answer

I have a Bissell Proheat Powerlifter model 1698 that has problems with the cleaning fluid draining from it's container in less than a minute. Has anyone experienced this problem??

is there a puddel of water under it? it may just have a split pipe even a split in the bottom of the tank or its lost the little velve that slows the flow of water to the brushes

Oct 30, 2009 | Bissell 1697-7 Powersteamer Pro Deluxe...

1 Answer


Did you blew thru the heater with both hoses off of it? If you did and it was clear, could be the pump, it is just working weakly. Is the top cover flush with the base in the back? If it has broken loose and has risen up, then it won't work. Here is a diagram that may help:


Aug 02, 2008 | Bissell 1698 PowerSteamer ProHeat Upright...

1 Answer

How to use bissell carpet cleaner

On the 1698 modle thier is a large clean water tank and a smaller shampoo bottle which seats on the side of the machine.
the shampoo goes in the smaller bottle fo the two.

Jan 02, 2008 | Bissell 1698 PowerSteamer ProHeat Upright...

2 Answers

No water or soap coming out

the filter could be block under the flow indicator cap,
but water should still come out of the hose

Nov 07, 2007 | Bissell 1698 PowerSteamer ProHeat Upright...

2 Answers

Water and clearen not coming out.

If the modle is an old modle the heater could be blocked,or if it a new modle try taking of the of the handle and ad a small shim to the bottom of the handle plunger to make it a little bit longer ,the plunger might not be reaching the valve,
also unscrew the clear cap which which is on top of the red spinner to see if the white filter under the spinner is clean and free from debris.
when you put the cap back on make sure its not to thigt and the spinner move freely, if the suction is poor make sure the red lint filter in the clean water tank is clean

Oct 20, 2007 | Bissell 1698 PowerSteamer ProHeat Upright...

Not finding what you are looking for?
Bissell 1697-7 Powersteamer Pro Deluxe Vacuum Logo

467 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18419 Answers

Brad Brown

Level 3 Expert

16806 Answers

Jim Thurston

Level 3 Expert

672 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides