Question about Motorola DCP-501 Receiver

1 Answer

Sound quit My unit worked fine for maybe 3 weeks... then suddenly, while I was listening to the radio, the sound just stopped. Everything else on the unit still functions fine, but there is no sound from the receiver for tv or dvd or radio. Any ideas, please? (My unit was new in the box, but purchased on e-bay so there is no support available from Motorola).

Posted by on

  • Anonymous Aug 12, 2008

    My sound just quit, no overload or anything. I have tried everything in the manual but still no sound. The people that I bought from, like this unit, are worthless. After many, many phone calls I am directed to this web site, which is no help. If you buy one of these units, expect to be ripped off.

  • Anonymous Aug 23, 2008

    I was using my DCP-501 and the sound just quit at all speakers. I have sound at the head phones jack. I have checked and my speakers are fine. I have did the four button factory default reset and nothing.



1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Check the fuses inside?

Posted on May 19, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

No sound on AM/FM but Sirius is fine

I would look at the antenna connections ... you will need to remove the unit from the dash to get to the back of the radio. [Google removal of that specific radio for your vehicle]. You may be able to get your hand up under some dash boards to reach the back of radio?

The antenna conception is typically a round coax conductor that goes to a plug into the back of the radio.

Try moving the plug around while radio is on ... if you get signal pull out connector and clean contacts with rubbing alcohol. Test again and reinstall.

Hope this helps!

May 04, 2016 | 2012 Dodge Grand Caravan

1 Answer

Sta 3190

Check amplifier IC, check all board solder for dry one's.

Feb 12, 2014 | Audio Players & Recorders

1 Answer

Pioneer Radio in 95 Ford F-150 doesnt produce sound

Maybe there is a separate amp with an open fuse.

Dec 19, 2013 | Pioneer Car Audio & Video

2 Answers

Radio working just fine But no sound coming from speakers

if the radio still has power the audio amplifier ic in your radio has failed.
take your radio to an electronics repair shop or, replace the radio; this not something you can fix unless you know how to use an oscilloscope.

Aug 01, 2010 | Harley Davidson 426290 AM/FM Radio

1 Answer

The sound stopped working on my koss KS2503. Yesterday everything worked perfectly fine. Today there is no sound. Everything else seems to work. I checked all the connections and have had no success. Is...

unplugg your tuner from the AC wall outlet then check the setting on the tuner do not try to watch and listen to the tv only try to listen to the radio or a CD and select the right option on the tuner to do so. If you have sound on any of the or CD/MP3 then the problem lies on the setting not correct for the TV/VCR/DVD mode.

Sep 12, 2009 | Koss KS2503 System

2 Answers

NAD T743: The digital channels stop working after a short time.

Hmm, sounds similar to my problem. Analog input and FM seems to work but all coax/opto input are dead ( for me there isn't a buzz).
Have you, fredrik648, solved your problem?
Anyone with ideas what to do?

///Johan Westerlund.

May 11, 2009 | NAD T743 Receiver

2 Answers

93 LX 5.0 replaced battery, ran fine then would not start

sounds like you have a good battery, get the car started put a voltmeter to wire connected to the back of your alternator. if you have at least 13.25 volts you have a good unit if any lower replace the alternator
the click sound you are hearing comes from your relay it is getting low voltage from the battery. because the battery has no juice caused by a bad alternator

hope to help shack

Apr 15, 2009 | 1993 Ford Mustang

2 Answers

Crackley bubbly sound

  1. What version of Windows?
  2. What hardware?
My initial guess is distortion.  With some hardware, and at least on Vista, I had really bad pops/cracks with Audition 3 initially using a Creative Labs Audigy 2... sound card.  Then after getting an M-Audio Delta 1010LT, no more problems EVER.

Aug 13, 2008 | Adobe Audition 1.5

1 Answer

No Sound Through Speakers

Hi Jake,

If you haven't done so already, I'd try double checking the speaker wiring, you may have some exposed or badly kinked wires behind the unit.


Matt Coyote

Feb 20, 2008 | Car Audio & Video

Not finding what you are looking for?
Motorola DCP-501 Receiver Logo

Related Topics:

168 people viewed this question

Ask a Question

Usually answered in minutes!

Top Motorola Audio Players & Recorders Experts

Computer Repairing
Computer Repairing

Level 3 Expert

14641 Answers


Level 3 Expert

12962 Answers


Level 3 Expert

102366 Answers

Are you a Motorola Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides