Question about Audiovox P88 CD Player

2 Answers

Power to unit but not working

I have power to the continuous power wire and the ignition wire but have nothing working when connected to thew playe player, no display lights either.

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.


    An expert whose answer got voted for 20 times.


    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 98 Answers
Re: Power to unit but not working

Have you checked the ground??? power doesent mean anything if there is no way for the unit to connect to ground.... also some decks have a little reset button that you can press with a pen tip. I am not sure if this deck has that but it worth a look.

Posted on Aug 21, 2007

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that has over 10 points.


    An expert whose answer got voted for 2 times.

  • Contributor
  • 30 Answers
Re: Power to unit but not working

First of all, if you connect iginition and constant to the same wire, it sometimes will not work, make sure they are hooked up to dedicated wires in the car. Also once they are connected and the car is on, press the source (src) button or am/fm button. Check the fuse on the back of the stereo by the wire harness too. Also make sure yellow is on constant and red is on ignition.

Posted on Aug 20, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

When i power it on it shuts off i got a kenwood kdc-mp825

Disconnect all of your speaker leads at the head unit, make sure none are touching, then power it back on. If it still cuts out, check your ground, if it doesn't, re-connect speakers one by one and test power again. It will either cut out when you get to a speaker or wire that's shorted, or work just fine. it's protecting itself from damage by cutting off when speakers are either bad or have shorted wiring. Most common shorted wiring happens on door speakers at the hinge. If it continues to cut off without speakers connected and you have a good ground, the unit needs service. If it still plays and you find the speaker or wire that's causing the problem, disconnect the wire at the speaker and test again, if it works, replace the speaker, if it doesn't, replace the wire. Hope this helps

Jul 07, 2011 | Kenwood Sirius KDC-MP825 CD Player

1 Answer

My ignition barrel broke for my vauxhall corsa,been fixed but my sony gt200 cd/radio will not come on . will not play.usually when you clip the front face unit into place the system lights the moment...

your cd switch wire is not recieving any power. when you turn on your key it turns on the switch wire. the wire/contact on the ignition barrel may not have been connected properly. check the wiring and the barrel again
if this doesn't work connect the yellow and red wire at the back of the will work without the keys now

Sep 23, 2009 | Sony XPLOD CDX-GT200 CD Player

2 Answers

Kenwood KDC-138: Removed Old stereo, installed new KDC-138, I'm getting power to the plug that plugs into the back of the unit & fuse is good. I've tried pushing the reset button. Nothing comes up on...

do you have power at both supplys on the wire harness?( red and yellow) red wire will have power with the key on. Also make sure your ground is hooked up right.

Aug 02, 2009 | Kenwood KDC-138 FM / AM Receiver

1 Answer

No power to front panel but have power to main unit.

You Have constant power (yellow wire) but your Acc wire or switched power wire (RED WIRE) does not have power. Check the connection of this wire. You most likely have a blown fuse in your vehicles fuse panel.

May 19, 2009 | Sony Xplod CD Player w/MP3 Playback...

2 Answers

Phase linear uv8020

you probably have constant power running the radio. do you have constant and ignition wires from the radio hooked up or did you twist the yellow and red wires together? if this installation was done correctly than you the unit should power off when you turn the ignition off.

Mar 29, 2009 | Audiovox UV8020

1 Answer

How to connect a pioneer super tuner to a 91 honda accord

With a DC voltage tester, check the two power leads for 12+ volts and proper operation, and be sure the unit is properly grounded.

The two power leads are,

1.Constant feed: which should be connected to an un-switched power source that delivers continuous
power to the units memory.

2.Switched feed: which should be connected to a switched power source controlled by the vehicles ignition switch.

Before installing in dash check unit for proper operation.

Good luck

Mar 27, 2009 | Pioneer DEH-P2900MP CD Receiver...

1 Answer

1991 buick park avenue. new radio isnt wanting to power up (no power)

there is a wire on the back of your radio that is red and it has to be hoocked up along with the yellow and the black, you have to hook that red wire up to a power source as well that is the wire that turns the radio off and on with your key.

Apr 12, 2008 | Car Audio Receivers

1 Answer

Unit will not turn on

This seems like you have accidently rewired part of your electrics. You may have wired the power wire into the wrong place, and also wired your electric door locks into your accessories. YOU NEED TO BACKTRACK. Find you doorlock wiring and get it back to a constant power supply. Best bet is to wire your power wire of unit to cigarette lighter by splicing the wires or jacking the outlet at the back. Here is a guide to install your stereo. Following those steps and see if you went wrong somewhere.

Mar 18, 2008 | JVC KD-G230 CD Player

1 Answer

Power on problem for XD7500

Hi. You need to check a few things. make sure you have power on both the red and yellow wire with the key on. If only one has power the radio will not work. If the red and yellow wires are switched it can also affect the way the redio operates. One is constant power for memory the other is key on power so the radio knows to shut off with the ignition key off. also make sure that you have a good ground connection on the black wire.. if nothing works yes you probhably have a bad radio. the dual brand radios are notorious for poor solder connections on the mainboard due to the way they build thier cheap circuit boards..

Aug 02, 2007 | Dual XD-7500 CD Player

1 Answer


Did you hook up the red ignition wire?

Sep 14, 2006 | Sony CDX-MP40 CD Player

Not finding what you are looking for?
Audiovox P88 CD Player Logo

Related Topics:

93 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audiovox Car Audio Receivers Experts

xxxxxx xxx

Level 3 Expert

4681 Answers


Level 3 Expert

57279 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you an Audiovox Car Audio Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides