Question about Sony XM-2100GTX Car Audio Amplifier

2 Answers

No sound coming from amp

My LED light comes on, but the amp isn't working. I checked all the connections and fuses and they are all still good. What's going on?

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 2 Answers
Re: No sound coming from amp

Could you please tell me how to wire up a sony amp XM - 2100GTX with one sub.


Posted on Aug 29, 2011

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 113 Answers
Re: No sound coming from amp - Sony XM-2100GTX Car Audio Amplifier Car Amplifiers

What color leds are on?

Posted on Aug 22, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

Everything did work but kept blowin fuses by the battery. Now a red light stays on, on the amp & the blue/green power lights dont *** on. What should i do?

Check all of your power connections, your speaker connections and battery connections. if all are good and clean (no shorts/wires touching) then try unhooking your speakers and see if the lights come back, if that helps then you have problems with your speakers, if not then amp is bad. I hope this helps ya.


Feb 17, 2011 | Phoenix Gold Titanium 800.1 Car Audio...

1 Answer

Boss bass 600 Amp comes on but does not have sound

yes and also moisture. i have had plenty of amps die like this on me! needs repair

Jan 06, 2010 | Boss AUDIO SYSTEMS BASS600 Car Audio...

1 Answer

Amp worked shortly, now no power

It sounds like you clipped the amp and did damage to It and possibly the speakers. I would check all connections and wires first. If you used too light of wire you may have either burnt the insulation off or burned through the wire. High power amps need large power cables. If thats all ok, did you have a fuse from the pos power terminal? Check that. If every fuse is good and the connection are good then it sounds like you may have blown an internal component in the amp such as a Transistor, Diode, or Capacitor. This would mean taking it to a service facility.

Jul 19, 2009 | Car Amplifiers

3 Answers

Kicker zx 400.1 amp no power.. is it fried?

Well Friend, the chances that your amplifier is Fried are very low. First of all deactivate the Auto Turn On Feature on the Amplifier. Second, check that the voltage is received at the Power connector of the Lead that is coming from the Battery using the Multimeter to make sure that the Main Fuse is all right. If No Go, then check the Amplifiers fuses thoroughly. Then check if the Protection LED is lit. If it does not work after all of it, get it checked at any local radio shack as I'm sure, it cannot get fried just like that, as it is possible that some internal connection has fried or became loose and will be fixed without spending much. I wish it will help you..

Mar 14, 2009 | Car Amplifiers

1 Answer

No sound

check ur fuses box for a blown fuse or if ur amp has a fuse check that as well and if blown u might have to change ur fuse if not ur amp is blown

Feb 18, 2009 | Car Amplifiers

5 Answers

LED turns on, but power light doesnt and there is no sound coming out of it.

it sounds to me like you have a bad ground or a short in the ground wire. try checking the ground cable as well as theremote wire (blue), and make sure the ground is connected to an unpainted,clean surface such as the frame of your car.

Sep 04, 2007 | Jensen PS2130 Car Audio Amplifier

2 Answers

Powers on but no sound

Check the main amp fuse under the hood, even if it looks good just change it. Often times that light on the amp can come on just from the power amp tunon wire. Try a friends subwoofer box just to make sure the connectors on your box are good, and if that doesn't work then give me some more details....year/make/model of car, what kind of sub, what types of things do you see on the side of the there a green light as well as a red light?

Aug 18, 2007 | Xtant A3001 Car Audio Amplifier

1 Answer

No Sound coming out of amp to subwoofer

check the fuse box and make sure there is no loose connection there. also check the wire that feeds power to that amp. good luck

May 23, 2007 | AudioBahn DUB Mag Audio DUB1002 Car Audio...

20 Answers

Amp isn't putting out any sound

I have a Digital Audio model-DA2200W, Was listening to my tunes loud as always....then the subs quit bumpin...checked the subs cuz i thought i blew em...theyre fine...The power on the amp is still light and all..just no output..I opened it up to see if anything looked burnt looks it toast or can i fix it??

May 25, 2006 | Power Acoustik LT-980/2 Car Audio...

Not finding what you are looking for?
Sony XM-2100GTX Car Audio Amplifier Logo

Related Topics:

141 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers


Level 3 Expert

56798 Answers

Are you a Sony Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides