Question about Pioneer DEH-P4600 CD Player

1 Answer

NO SOUND I bought this player two years ago and a few days ago suddenly I got no sound. I checked all my wiring and my speakers and everything is fine. I need to know what happened and what else I can do to try to fix this! Thank You

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert whose answer gotĀ voted for 20 times.


    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 98 Answers

Hi.. DO you have a chrysler product? if so make sure you have the blue factory amp wire hooked up.. In any case i would get a little known good speaker(even a house stereo bookshelf speaker is fine) and test at least one pair of speaker wires for sound output right at the back of the radio. If you do not have sound output and your deck works fine otherwise then 99 times out of 100 the internal amplifier ic or "chip" is bad. I have replaced several of them. Phe part is not hard to find if you know where to look. It does require total dissassembley of the deck and yo uhave to be very skilled with a soldering iron and desoldering braid- but it can be repaired!.... le tme know if you decide to try to repair it an di will do my best to wank you through it..

Posted on Aug 18, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer


im install cd player for my car, but not sound came out at all. removed it out, try check for connection, but everything was fine. then i did try play around for speaker 's wire speaker. i saw blue ( power ant) just connect to nowhere. then used blue wire to connect for output speaker, then sound show up. but rerarely to heard. cuz sond was too low. even volume was max. i thought maybe they need for more ground to run out put, or sound chip 40 legs is gone. ( need to replace for it?

Feb 13, 2011 | Xtreme Sound WMS336 CD Player

1 Answer

No sound from speakers

Check to see if one of the speakers are grounded out, disconnect 1 speaker at a time from the deck and see if the sound comes back on. Itsa protection feature.

Jun 02, 2009 | Xtreme Sound WMS303CS CD Player

1 Answer

No sound on coming out of speakers and theres no wires touching everything looks like it works fine

Make sure you didn't accidentally hit the mute button.
You should always test sound with a CD, testing sound via AM/FM will produce interference and almost no sound when between stations, also don't to forget to connect the antenna lead.

Check that the speakers are wired correctly.
Check that the sound controls are adjusted properly, i.e. Balance, Fade etc.

Good luck...

Feb 24, 2009 | JVC KD-G210 CD Player

1 Answer

CDA 9885 No idea why it suddenly stopped working

It sounds like you have a bad ground connection. You need to take the radio out and check all the connections. I bet you have a loose one somewhere. That is what the problem was with my bronco

Sep 08, 2008 | Alpine CDA-9885 CD Player

1 Answer

No sound...

you have wires grounding out at the back of the unit. i suggest trying to completely rewire it and see how that works. its easy if youve never done an install so dont sweat it. email me if you have any questions.

May 13, 2008 | Panasonic CQ-C7301U CD Player

1 Answer


check all your fuses and then take the face plate off and push the reset button. if that doesnt work just check the wire connections sometimes if the wires dont have enough contact they want work. i had that issue when i upgraded the speakers in my jeep the connections were not good enough.

Mar 02, 2008 | Virtual Reality VRCD500-SDU CD Player

1 Answer

Plays radio not cds

You may have Power antenna and amp remote turn on wires switched. Your system may be looking for turn on signal from radio and only gets it when am or fm is on because power antenna wire is hooked up instead of amp turn on signal.

Jan 18, 2008 | Kenwood Sirius KDC-MP522 CD Player

1 Answer

No sound

I have the same problem but it works for about two minutes before it cuts off I think its a short in the speaker wire because I've tested everything else and it still did the same thing

Jan 15, 2008 | Alpine CDA-9853 CD Player

1 Answer

No Sound.....

Do you have the speakers connected properly? If Yes check it with a 1,5 Volts batery to hear a click sound at your speakers... You will find the speaker cables behind the cd player.

Aug 10, 2007 | Panasonic CQ-C1121U CD Player

Not finding what you are looking for?
Pioneer DEH-P4600 CD Player Logo

134 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pioneer Car Audio Receivers Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

xxxxxx xxx

Level 3 Expert

4679 Answers


Level 3 Expert

56631 Answers

Are you a Pioneer Car Audio Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides