Question about Sony XM-475GSX Car Audio Amplifier

2 Answers

Amp problems my sony amp xm475gsx doesent have any sound ,it has a over current lite,on top ,,, can you help,,thanks jay

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers
Re: amp problems

I found the service manual on Ebay,Here is the item number: 230196848929. Use it and a DVM to find the bad componets and replace them. Parts I use are on

Posted on Nov 27, 2007

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 113 Answers
Re: amp problems

Disconnect all power to reset try after 20min

Posted on Aug 22, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Amp goes into protect when turned up.

that amp is only stable 2 about 4 omhs mono the powersupply shut dowm drawing t much current it supposed 2 2 fix this u need a 4omh load mono change speaker config so u get 4 omh or buy amp stable down 2 1omh can be expensive

Aug 28, 2009 | Sony XM-2002GTR Car Audio Amplifier

2 Answers

Sony explode amp ''OVER CURRENT'' light on -no sound

just feed 240V through the RCA inputs and check if the amp power light comes on. if it does the the amp should have automatically been reconditioned.... you are now ready to rock n roll!!!

Mar 23, 2009 | Car Amplifiers

1 Answer

Got car am input spliced from rear speakers,

the polarity's are backwards just change the positive and negative connection on one speaker not both or switch it at the amp whichever is easier but only one

Mar 22, 2009 | Car Amplifiers

2 Answers

Rockford T10001bd: Capacitor buzzing

If the top is split open, it has vented electrolyte. This is most commonly caused by more serious problems in an amp. Do the other adjacent caps show any signs of damage?

Is it blowing fuses? Connect a 20 amp fuse in-line with the B+ line of the amp. If it blows the fuse, the amp is drawing excessive current and most likely has more serious damage than the single vented cap.

Dec 04, 2007 | Rockford Fosgate T10001BD- Car Audio...

4 Answers

Sony XM-475GSX

its fried.... yo ucant keep running them hot forever...especially the cheaper amps.. if you are near chicago i do repair amps but other then that theres not much you can do..

Aug 17, 2007 | Sony XM-475GSX Car Audio Amplifier

2 Answers

Kenwood kac 859 amp

hi, note that if you are not using the proper gauge b+ and gnd cable with this amp then the current available at the amp wont be sufficint to keep amp on. also try using this amp while vehicle is idling. if this doesnt work then disconnect all spks from amp and check if red lite stops flashing. if it doesnt stop flashing then amp has internal fault. if lite stays on brite then proceed to check each spk load impedance, then reconnect each spk individually. the minute red lite starts flashing it will give you a clue that the channel or spk load is faulty. cheers

Jul 27, 2007 | Kenwood KAC-859 Car Audio Amplifier

1 Answer

Error code on alpine mrd 500

It's a current overflow in the system. You can also get this message if the voltage is too low. Also it can mean a short in the speaker cable. E3 Error is a general error "eccessive current overflow". Check the fuses, I believe there are 4 in this unit but not sure. Check your crossovers. I hope this helps you out. Is this a new hookup or did you buy anything new or change anything?

Jul 06, 2007 | Alpine MRV-F345 Car Audio Amplifier

1 Answer

Over current light comes on.

Over-current lights are often caused by speaker wiring or impedance problems. If you're trying to use the amplifier in bridged mode to both subs, that may be causing the problem; re-wire the speakers so that each sub is connected to one amplifier channel. If you still get the over-current light, disconnect all speaker wiring from the amp and see if it still occurs. If it does, there's an internal problem with the amp. If it doesn't, then there's still a wiring problem with the subs. You may have a defective sub, or a speaker wire shorted against another wire or terminal.

Jun 23, 2007 | Sony XM-1502SX Car Audio Amplifier

Not finding what you are looking for?
Sony XM-475GSX Car Audio Amplifier Logo

Related Topics:

599 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers


Level 3 Expert

56836 Answers

Are you a Sony Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides