Question about Altec Lansing M604 Computer Speakers

4 Answers

Altec Lansing M604- Zune is not charging while connected?

I just got these speakers as a present, I plugged my Zune in, looking forward to use this new toy but....unless im missing something the Zune is not charging. The zune was totaly dead on battery power, but when I hook it up to the speakers it still wont turn on. Power is on at the speaker, green light and all, but not a thing with the Zune. I would assume that the speakers are supposed to charge the Zune while docked? I left it plugged in, speakers on for a couple hours and still nothing with the Zune.

Posted by on

Ad

4 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I had this problem also...I unplugged the power from the dock for about a minute, plugged it back in, turned it on, placed my zune in the dock and it's been working ever since. Hope this helps someone.

Posted on Jan 19, 2008

  • deek05 Jan 19, 2008

    I had this same problem. I unplugged the power from the speaker dock, waited about a minute and plugged it back in. It seems to be working fine again.

×

Ad

Turns out the USB Cable needs to be plugged in to charge.

USB Cable in the rear of the device is the correct answer. Disappointing but it is probably hard wired, ie only two wires on the dock connector can be used for charging and they probably are hard wired to get their voltage from the usb cable. I would imagine this could be overcome with a better device. -- Still love mine though.

Posted on Nov 22, 2007

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have the same problem. I called Altec Lansing and they told me that my speakers are defective and should charge the Zune. They are sending me a new set under warranty. Normally they do not send out a new one before they receive the old one, but for this problem they volunteered to do so. I did not get this offer until the second time I called in, though. I mentioned that people were writing about this problem on the internet and she said she had two other cases of the same problem that day. If they don't send it first, they wait two weeks after they receive your old unit until they ship the new one so you will be without for a long time. Push to have them send it first.

Posted on Dec 01, 2007

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 2,985 Answers

Speaker charge anything - no way Speakers speak thats it. Unless the speak manual says otherwise have you read it?

Posted on Aug 14, 2007

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: THE PINS ON THE POWER CORD FOR MY ALTEC LANSING

Order a new cord from the website. Only $7.99

http://www.alteclansing.com/ae/us/accessories-parts/ac-cord-m602-m604-t612-/invt/a114651/&bklist=icat,3,shop,accessoriesparts#tabanchor

Posted on Jan 09, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Find a replacement pin connector for a M604?


http://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=2&cad=rja&uact=8&ved=0CEMQFjAB&url=http%3A%2F%2Fwww.fixya.com%2Fsupport%2Fp516420-altec_lansing_m604_computer_speakers&ei=Zzk7VM60JMyNNuOWgYAM&usg=AFQjCNGMt0tTThQP_RYor9iYUOceT0j2Jg&sig2=FDx4zaqBnoX6PUrdYrkR6Q

Oct 01, 2014 | Altec Lansing M604 Computer Speakers

1 Answer

Disassemble


Plug the power supply into the wall and the power cord into teh speakers. Plug the speaker wire into the speaker and the othe end into the musice source. turn on the speaker volume to mid rand and play some funky music!

Sep 13, 2013 | Altec Lansing M604 Computer Speakers

2 Answers

I have lost the cable from the back of the speaker to the power socket. Any ideas how to get a replacement?


Hi there , not long ago I was having issues with my VS 2420 I wasn't getting any replies to my queries when requesting help through the web site then someone forwarded me the following Contact: nicky.cook@alteclansing.com , seems to be manager customer care I got a reply within 24 hrs and a new one was shipped to my UK address within 58 , awesome service ! :D

Mar 19, 2011 | Altec Lansing T612 - High End Speaker...

1 Answer

M602 Speaker Problem,.. Popping Sound


This worked for me on my M604: Try inserting/removing a headphone plug into the jack several times to see if that clears the problem.

The "popping" sound is very similar to the sound that the unit makes when inserting headphones into the 'headphone' jack on the back of the unit.

The jack has a contact switch that triggers a relay inside the unit. If that contact switch is 'on the verge' of making contact, slight temperature changes may cause deform closer to it's contact target. The subsequent capacitance build-up and discharge across the gap could explain the cycle of popping noises after the unit warms up.

Jun 25, 2009 | Altec Lansing M604 Computer Speakers

1 Answer

Battery wont charge


I would say swap out the battery, since that's the least expensive thing you can do. Then if that doesn't work download and install this device utility
http://www.mydigitallife.info/2007/12/22/zune-device-diagnostic-tool-version-10/

Feb 13, 2009 | Altec Lansing M604 Computer Speakers

1 Answer

Zune 80 GB - Won't Charge


my 30gig was doing same thing i opened it up and one of cables just slipped out of port very simple to fix open you zune where the charger goes in there is a black cover remove this carefully then remove the 2 very small screws next use a very thin flat surface be very careful and you can see the edge where it seals just put you thin applient into the side and gently pull it up go all the way around once at top be gentle dont use the knife or whatever you used just slide it appart the back will come off then just reconnect cables good luck

Sep 30, 2008 | Altec Lansing M604 Computer Speakers

1 Answer

Hearing Zune


The contact where the Zune plugs in was loose.

Jul 23, 2008 | Altec Lansing inMotion iM414 Docking...

1 Answer

M604


hello FrankH2,

time to change your remote. You also get one from Altec Lansing, but you have to RMS if you register your product, or go on www.alteclansing.com and check the way to change your remote. Other than this, is go to repair shop near you , and see if the Tech personel, can check the remote, for fried line or capacitor.

Jan 07, 2008 | Altec Lansing M604 Computer Speakers

Not finding what you are looking for?

Open Questions:

See all Altec Lansing M604 Computer Speakers Questions

Altec Lansing M604 Computer Speakers Logo

679 people viewed this question

Ask a Question

Usually answered in minutes!

Top Altec Lansing Audio Players & Recorders Experts

Carlos L. Burgos
Carlos L. Burgos

Level 2 Expert

620 Answers

The Knight
The Knight

Level 3 Expert

75963 Answers

Sharps s

Level 1 Expert

41 Answers

Are you an Altec Lansing Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...