Question about Power Acoustik GOTHIC OV4-600 Car Audio Amplifier

2 Answers

Protection light i hooked everything up but the protection light stays whats the fuse rating for this amp cause i have a 15.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers
Re: protection light

Try playing with the fuse. wiggle it around and see if it turns off protect mode. if that dont work look at all your wires. your remote wire is really thin. you could of split it open when you were installing it.

Posted on May 15, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 311 Answers
Re: protection light

Have you wired it up properly + to + and - to - and the power + and -

Posted on Aug 13, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

Why does my spa 500 amp blow a fuse every time I hook up my 15" lanzar sub to it

Because it's drawing more power than the fuse can handle get a fuse with a higher rating. A 100 app fuse worked great for main power with my setup 760w amp a 15"sub 2 10"subs and a 12" sub. Also my amp had 2 30amp fuses on it one for each channel but I ran everything out of one channel.

Aug 02, 2016 | Lanzar Car Amplifiers

1 Answer

What does my protection light come on after hooking everything up

There is something shorting out the amp. What you will need to do is disconect all wires and hook up one at a time. Connect ground, !2 volt and remote see if amp turns on ok. If it does try connecting each speaker seperately to see if either one sends the amp into protect mode. Then connect the rca. See what causes the amp to go into protect mode.

May 08, 2013 | Car Amplifiers

1 Answer

I have an American Pro amp V.S.-1406. It has the amber lights on inside but no green power light. I am almost positive that everything is hooked up correctly but it just won't work. No sound. Good...

If you have no power light on or its not green or the color it's suppose to be when working properly then it's in protect mode. First unplug everything except the power wires and see if any of the lights change from amber. Being the color is amber this means its in protect. if still no green light for power or what color it's supose to be when working properly then you have an internal problem. Mostlikey the powersupply mosfets and/or the output transistors or mosfets. I have to look up this amp to see what it has for outputs. With a good ground and positive power wire hooked up, your amp has some shorted components. I own a small business repairing, selling, and installing car audio. I am MECP certified also I'm an electronics engineer and have designed 2 mono sub amps that sold very well. Saving up to have more built again. I have 20 years experience now so I have been doing this for a very longtime. My pricest are the cheapest and my work is professional. I do it cheap cause I'm tired of seeing people getting ripped off at allot of places and my overhead is'nt high. I also offer services that no one else does and I offer online video help to help a person test certain components berfore sending an amp in, or over the phone. If you need help just contact me through here and I will send my info. I get allot of business through this site and plus a few other sites. Hope this helps. I will look up your amp if I can find a manual to see what color the lights on it should be when working properly. Being amber though, in my experience that means it's in protect. Do what I asked first to rule out bad subs or RCA's causing it to go into protect.

Feb 13, 2013 | Car Amplifiers

1 Answer

My A8000t amps red protection light is on checked

When ever the amp stays in RED protection mode with out any speakers hooked up to it, YOUR amp has internal damage some where. Can't tell you how much to fix, Could be cheap or not worth it. Talk to your local electronic repair, would be a good start.

May 14, 2010 | AudioBahn A8000T Car Audio Amplifier

1 Answer

Amp burned out but fuses still good?

this is caused by inproper wiring from the speakers/subs to the amplifier.. an amp will still put out power to subs and speakers when it's wired improperly but it won't last for very long doing it... 6 months is longer than usual....

Dec 05, 2009 | MA Audio M1900XE Car Amp

1 Answer

Amp protector light going on and dimming


first thing you want to check is the fuses in the amp, and power wire if applicable. This might cause the protection light to come on. I do assume you are referring to the protection light on the amp itself and not your car.

Post back if you have checked your fuses and have still not solved the problem.

Thank you for choosing Fixya!

Oct 03, 2009 | Car Amplifiers

1 Answer

Changed speakers and now red protect light stays on? why?

the sub might have a short or is blown or the ohms are different

Mar 30, 2009 | Crunch PZi1000.1 Car Audio Amplifier

1 Answer

Protection light

take the amp out and hookit up to the car battery and let it charge then unplug it do this a couple of times then rehook it to the cars audio system it sounds like your amp may be locked..

also check your speaker wires from amp to speaker box then from the back of the box to the speaker inside the box you may have a short..

thats where i would start.. hope this helps

Dec 19, 2008 | Car Amplifiers

1 Answer

Sony explode amp for my car

Try disconnecting everything but the power connections. If the protection light still comes on, then there's a problem in the amp. If it goes out, then there's a problem elsewhere. In that case, hook up one speaker cable at a time and power on. If the protection light comes on, then either that speaker is bad, or you've got too many speakers connected to that one amp output. Too many speakers connected together can cause an overload and trigger the protection circuitry, or worse, blow out something out.

Hope this helps, and please rate my advice.
Thank you, and good luck!!

Feb 04, 2008 | Car Amplifiers

3 Answers

Red LED "Protection Light is on" What is the problem

The red light means the amp is in protection mode. A few things can cause protection mode..... First disconnect the subs completely from the amp, and turn it on, if it powers up you have blown subs. Also try checking the main power wire at the battery...sometimes the current your meter is seeing is backfeeding from the remote wire, so your main power line could be blown at the fuse under the hood. hope this helps

Jul 17, 2007 | Crunch BlackMaxx BMX2250 2 Ch 1000W Amp...

Not finding what you are looking for?
Power Acoustik GOTHIC OV4-600 Car Audio Amplifier Logo

Related Topics:

175 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Amplifiers Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Robert marquette

Level 2 Expert

102 Answers

Are you a Power Acoustik Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides