Question about Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Amplifier I just hooked my amplifier up in my car and i wanted to test it to see if it would work so i plug my sub in and it worked then i went on in putting the my other speaker on but it wont work and now everything doesn't work the power light is on no flicker or anything i have no clue on what to do

Posted by on

1 Answer

Re: amplifier - Sony Xplod XM-554ZR Car Audio Amplifier Car Amplifiers

Reset your sistem

Posted on Aug 15, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

3 Answers

KAC-9102d no sound, Amp powers on but no sound to the subs.

If the sub isn't working, you won't get a pop. All you need is a small speaker. Don't need a sub, you just want to test the sound. I recently blew 2 subs, no smoke, no smell, no sign of being blown. Absolutely nothing from the subs.... In the past my sub locked up. You can take your sub out of the box and hook the + and - to the battery to see if you can get the sub to pop there. I believe a small box will push a sub into a deep excursion to the center of the cone. I have 2 lanzar VW12D's that just quit. I hooked a 6 x 9 up to my amp and low and behold I had sound! Try that and see what you get...

Feb 07, 2009 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Subs dont beat like they should

you've spent alot of money on **** by the sounds of it!!. you should only ever run multiple subs the same brand, power and resistance you can just connect any old subs to a system you need to wire them depending on the load that the amp needs to see. first thing is to try the amp/s on a individual sub to check your amps still work once done check the subs 1 by 1.

Jan 20, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Sub not working any more

mine does the same DONT BUY SONY XPLOYED THEY EXPLOYED!!!!!!!!!!!!!!!!!

Jun 23, 2008 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Thunder 5604

okay u will have to troubleshoo the amp.....dose the amp light up?...when u have the radio on? also check your sub wires.going to the amp....make sure the rca'sare hooked up to the radio rear out puts are the radio sub out puts...and then test your amp gain adjustment...let me know if that work's

Jun 23, 2008 | MTX Thunder5601 300W x 1 Car Amp Mono...

1 Answer

Weak output from sub..

The woofer was not demagnetized.

If one signal cable is damaged, it could reduce the signal getting to the amplifier and could reduce the output.

Plug one RCA plug in at a time to confirm that both are working properly. If one is lower or not working, the cable may be defective.

If both work properly, double-check the settings on the head unit (sub-out, bass, crossover frequency...)

Oct 28, 2007 | Alpine MRP-M350 Car Audio Amplifier

2 Answers

No sound but powers light is green

You need to determine first if sound is getting to the amplifier. Then once you are sure of that you need to run a test to see if the audio is being sent to the first pre amp in the actual amplifier. Once this is done you can determine if the samplifier is actually the problem. If it is you will need a schematic to troubleshoot the device.

Sep 07, 2007 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Pioneer amp and sub problems

That's a 4-channel amp, not a 2-channel, which makes me wonder exactly how you have it hooked up to your sub. Is the LED light on the amp coming on? How many subs do you have hooked up to it, and how is it wired?

Mar 04, 2007 | Pioneer GM-6200F Car Audio Amplifier

1 Answer

Amp help

it might not be the amp that is not working it could be the sub or sub's. Try takeing a sub out of the box and look down the hole in the center of the magnet on the back of the sub and look and see if you can see any wire's or any thing that has come unwound in the sub and if you do see wire's then you have blown your sub. If you dont see any wires then you could completly disconect your amp for 20 to 25 minutes and then plug it back in and see if that fix's your problem. If none of this works then you can take your amp to an audio store and have them test the circut board in your amp.

Dec 22, 2006 | Sony Xplod XM-1652Z Car Audio Amplifier

Not finding what you are looking for?
Sony Xplod XM-554ZR Car Audio Amplifier Logo

Related Topics:

32 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers


Level 3 Expert

56548 Answers

Are you a Sony Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides