Question about Audio Players & Recorders

Open Question

Denon AVR-486 red blinking power button

The receiver was working properly for over 2 years, then just cut out mid song and the on/standby button was flashing red. I turned it off then back on it flashed green, then went to a flashing red again. its for work, so money is the main deciding factor whether it's worth fixing or scrap it and get a new one?

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
tech48
  • 624 Answers

SOURCE: Denon AVR-1907 blinking red power button

It sounds like you have a bad speaker on the zone 2, or you have the speakers connected improperly.

When you engage the zone 2 a relay clicks and the speakers then become part of the amplifiers circuit.

If the problem was in the amplifier, it would go into protect mode without even having speakers connected to it.

If the speakers all check good, you most likely have the wrong type of speakers, meaning the impeadance is too low, or you have too many speakers connected to it.

On the back of the Denon, you will see right around the speaker output jacks, what ratings the speakers should be. If I remember correctly, it says 6 ohms or more when using only "A" or "B", and it says 12ohms or more for "A" + "B".

If you have two 8 ohm speakers on the same speaker jack you now have a 4 ohm load. That is below the ratings and can cause the amp to shut down (go into protect). Since your amp shuts down right away, I think you have a bad speaker or way too many speakers connected.

I have seen many times when people will connect 2 or 4 speakers to the one of the outputs that are designed for only 1 speakers.

If you are using too many speakers you will need a speaker distribution box. It has a resistor network built into it so the amp never sees a lower impeadance than what it is designed for.
You can connect 4, 6 or 8 speakers to one set of outputs designed for 2 speakers. You do loose a lot of power to the speakers, but it is better than blowing up your amplifier.

If I can be of any further help, let me know.

Posted on Jun 22, 2008

Ad
  • 1 Answer

SOURCE: denon avr-2106 problem!!!

You're drawing too much power from it. Sounds like maybe your sub is hooked up wrong, double check that.

Posted on Jul 06, 2008

Foxyjay
  • 13 Answers

SOURCE: i have a denon AVR-2105

If your amp looks like it's going to work as normal (ie the front display lights up as it should etc), but then the amp goes into protection mode when the anti-thud circuit times out, then I know what's likely to be wrong.

It's one of the power amplifier channels which has gone faulty.

I just found this out after having this problem with my AVR-1906.

I took the amp apart and de-soldered the suspected channel power transistors (centre channel in my case).....and hey-presto! it fired up as normal (obviously the centre channel would be out of service).

I have ordered the replacement transistors from Farnell (UK) at a miserly cost of around £2-£3 each.

Just waiting for them to arrive.

An alternative is, if you don't use all your channels, take the transistors from a known working but not needed channel and swap them over with the duff ones.

Hope thats of use!

Posted on Aug 16, 2008

Foxyjay
  • 13 Answers

SOURCE: Denon AVR-1508

If your amp looks like it's going to work as normal (ie the front display lights up as it should etc), but then the amp goes into protection mode when the anti-thud circuit times out, then I know what's likely to be wrong.

It's one of the power amplifier channels which has gone faulty.

I just found this out after having this problem with my AVR-1906.

I took the amp apart and de-soldered the suspected channel power transistors (centre channel in my case).....and hey-presto! it fired up as normal (obviously the centre channel would be out of service).

I have ordered the replacement transistors from Farnell (UK) at a miserly cost of around £2-£3 each.

Just waiting for them to arrive.

An alternative is, if you don't use all your channels, take the transistors from a known working but not needed channel and swap them over with the duff ones.

Hope thats of use!

Posted on Aug 16, 2008

  • 5 Answers

SOURCE: Denon AVR older receiver but worked fine; now

Did you try to reset the unit? Resetting the unit has fixed every problem I have ever had......turn off unit.....hold down A+B at the same time then turn the unit back on...hold buttons for roughly 3 seconds....Let me know if it works.

Posted on Mar 09, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

DENON AVR 1507 short?


unplug it, let it set for about 15 min., plug it back in and see what happens. Hopefully it will recycle itself. If that fails, with your theater remote, you can pull up it's functions screen on your TV, and probably return it to factory default settings. That would be a last resort for me before seeking professional help. Good luck. . .

Jul 27, 2017 | Denon AVR-1507 Receiver

1 Answer

My Denon AVR-75 seems to stay in standby (red standby light is on) and I don'd get surround sound through it. How do I get it out of standby?


if the receiver does not power on from standby there is a problem like bad power supply or even bad macroprocessor. You need to bring it to a service center for diagnosing. 10-years old receiver, maybe better to buy new one.

Nov 23, 2011 | Denon AVR-75

1 Answer

Goes to standby with fast blinking red light after 5 seconds


From my experience you need to replace the Hi power module

Sep 11, 2009 | Denon AVR-1905 Receiver

1 Answer

Denon AVR older receiver but worked fine; now


Did you try to reset the unit? Resetting the unit has fixed every problem I have ever had......turn off unit.....hold down A+B at the same time then turn the unit back on...hold buttons for roughly 3 seconds....Let me know if it works.

Aug 20, 2009 | Denon AVR-1908

1 Answer

Denon AVR-2309ci receiver keeps losing power after a few seconds


This is a defective unit. bring it back to best buy and have them replace it.

Jan 02, 2009 | Denon Audio Players & Recorders

1 Answer

Denon AVR-1100 receiver "PROTECT" mode


replace all the electrolytic capacitors in the power supply. i had the exact same problem with mine and once i replaced the capacitors it powered up and stayed on and worked perfect.
these capacitors tend to fail as they're of poor quality.
this fault is very common on denon receivers, especially the later models.

hope this helps?

Dec 25, 2008 | Denon AVR-1100 Receiver

2 Answers

Denon AVR-1705 won't power up


when i turn it on it stays on for 3-4 seconds then shuts down

Jun 27, 2008 | Denon AVR-1705 Receiver

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

95 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5190 Answers

The Knight
The Knight

Level 3 Expert

74482 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...