Question about Aquabot Turbo T2 In - Ground Pool Cleaner

1 Answer

Troubleshoot aquabot turbo

Won't pump water moves slow

Posted by Anonymous on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Aquabot Master
  • 8,688 Answers

Bad pump motor possible bad drive motor also

Posted on Oct 26, 2017

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad
  • 83 Answers

SOURCE: Aquabot is pushing out water but will not move to clean the pool

I am not sure if this is the manual that you are looking for, or not, but just in case. If you following the link below it will take to you the T2 User's Guide, with the trouble shooting.

http://www.i-love-my-aquabot-automatic-pool-cleaner.com/support-files/aquabot-turbo-t2-manual.pdf

According to the trouble shooting guide:
Pumps Water, but Does Not Move or Moves Slowly
1. Remove any foreign matter that may be obstructing Drive Tracks.
2. Check Drive Belts and Tracks. Make sure they have not slipped out of place and that they're not loose.
3. Observe Drive Pulley, if it is not moving contact Customer Service.

Posted on Jul 09, 2009

  • 2 Answers

SOURCE: aquabot goes in one direction

Find a looooong straight area and, starting from the Aquabot, hold the cord straight and straighten it out by letting the cord twist so it isn't all gnarled and twisted - move down the cord, always keeping one hand firmly on the end of the cord closest to the machine (to prevent it from re-twisting). You'll find that the cord will spin like a top as you get closer to the end. Once untangled, pull down on the metal rings under each end of the top floating handle (may require a pull and a slap against the handle). MAKE SURE THE HANDLE IS LOCKED IN A DIAGONAL POSITION.

Posted on May 07, 2010

ynogami21
  • 670 Answers

SOURCE: My Aquabot seems to have lost power...it moves

Hi there,

I think you have a bad motor it would be better to have it checked on one of their centers or by a local technician to check if it has a serious problem or if it just needs some cleaning.

Posted on May 23, 2011

  • 25 Answers

SOURCE: The aquabot is not moving. Water is coming out

none

Posted on Jun 21, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How come my aquabot turbo will not move or pump water?


Probably the drive belt came off the pulley or the belt broke. Similiar to a vaccuum

May 27, 2014 | Aquabot Turbo Robotic Pool Cleaner

2 Answers

Aquabot Turbo T2 flips over when it tries to climb walls. Water is not coming out the top but the unit is moving fine. Does it need a new pump motor or can something just be clogged inside??


the likely problem is the float/handle. Make sure it moves freely and is always in the straight up position when on the bottom of the pool. If it's not then it is the problem.

Jul 20, 2011 | Aquabot Turbo T

1 Answer

Aquabot T4 RC, Pump runs for 1 second then shuts off for 4 seconds, then repeats its self.


Mine does this too some times. I find that if i manually force the wheels (out of water) to turn slightly and then put it back in the water it works again for a bit. I think something is jamming it but can not find out what the issue is. Let me know if you solve it!

Jul 04, 2011 | Aquabot Turbo In Ground Pool Cleaner

1 Answer

Aquabot wont pump or move, intermmittent


Well either you have a jammed up motor, or a bad motor, or the Controller unit has faulted.
http://www.robotshop.ca/PDF/aquabot-turbo-t2-manual.pdf
Above is a manual, this should help you it has exploded diagrams to help. There seem to be many ways that it could get tangled up, or maybe the belt has come off, any way it's about time to A: Get a screwdriver, or B: Call a service man....

Jun 01, 2010 | Aquabot Aquaproducts Automatic Swimming...

3 Answers

Aquabot is pushing out water but will not move to clean the pool


I am not sure if this is the manual that you are looking for, or not, but just in case. If you following the link below it will take to you the T2 User's Guide, with the trouble shooting.

http://www.i-love-my-aquabot-automatic-pool-cleaner.com/support-files/aquabot-turbo-t2-manual.pdf

According to the trouble shooting guide:
Pumps Water, but Does Not Move or Moves Slowly
1. Remove any foreign matter that may be obstructing Drive Tracks.
2. Check Drive Belts and Tracks. Make sure they have not slipped out of place and that they're not loose.
3. Observe Drive Pulley, if it is not moving contact Customer Service.

Jul 05, 2009 | Aquabot Turbo T2 In - Ground Pool Cleaner

1 Answer

Aquabot goes in one direction


Find a looooong straight area and, starting from the Aquabot, hold the cord straight and straighten it out by letting the cord twist so it isn't all gnarled and twisted - move down the cord, always keeping one hand firmly on the end of the cord closest to the machine (to prevent it from re-twisting). You'll find that the cord will spin like a top as you get closer to the end. Once untangled, pull down on the metal rings under each end of the top floating handle (may require a pull and a slap against the handle). MAKE SURE THE HANDLE IS LOCKED IN A DIAGONAL POSITION.

Jun 17, 2009 | Aquabot Turbo Robotic Pool Cleaner

1 Answer

Aquabot Turbo T won't climb


1.`. Replace your old, water logged floats. They will dry out when the unit is out of the pool, and the unit will work fine until they water log again, which may takes as few as 10 minutes in the pool. 2. Stop using all those words *********** didn't teach you and probably didn't even know...This is a common problem. http://www.i-love-my-aquabot-automatic-pool-cleaner.com/ gives some really good insight, too! S. Christian dansker01@msn.com.

May 11, 2009 | Aquabot Turbo T

2 Answers

How do you change the rubber traction belts on the aquabot turbo t2.


First of all your cleaner is under warranty for 4 years or 300 cleaning cycles and is prorated. That being said, here is the schematic and contact info. http://www.aquabot.us/parts/aquabot.html

May 07, 2009 | Aquabot Turbo T2 In - Ground Pool Cleaner

Not finding what you are looking for?
Aquabot Turbo T2 In - Ground Pool Cleaner Logo

Related Topics:

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aquabot Pool & Spa Experts

Ian Summerfield
Ian Summerfield

Level 3 Expert

502 Answers

David Spradling
David Spradling

Level 3 Expert

8688 Answers

Robco Water
Robco Water

Level 2 Expert

239 Answers

Are you an Aquabot Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...