Question about Audio Players & Recorders

1 Answer

Im getting a humming sound when i turn on my amplifier. How do i earth my turntable?

Ie recently connected my turntable to my Amp - which is BUSH (and old). Ie used a audio cable via a phono connecter to a 5 Pin Din. The humming was not there at the start but is there now. Ie been told i need to earth my turntable, but i cant see how i would do this!?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 15,441 Answers

One of the cables has a bad connection.

Posted on May 12, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: Sound very distorted

This turntable has a preamp switch on it, which is probably on and what is causing the distortion. Take off the metal record platter by lifting up on the two holes gently. Turn the pre-amp switch to 'off' and then try it again. This is probably it...

Or you can plug it into an input that doesn't have a preamp and that should work.

Posted on Dec 31, 2008

  • 42 Answers

SOURCE: Just set up new turntable AT-PL50. Sound very distorted

Your query incomplete. Please resumit.

Posted on Jan 25, 2009

  • 104 Answers

SOURCE: hum when turntable connected to phono sockets on amp

this turntable absolutely came with a ground wire that must connect to the gnd connection on the amp. maybe it got torn off or something but there should be clues on the back of the turntable as to what happened to it.

once the lead is found it must be connected to the amp gnd connect to get rid of the hum. this might require someone with soldering skilz or what have you in order rig up a new wire.

a tech might have to remove the bottom and solder in a new wire if it is cut or ripped off at the housing. This is common as people forget to unhook the gnd wire from the amp when moving things around.

Posted on Feb 11, 2009

  • 104 Answers

SOURCE: Connect a phonograph turntable to a receiver w/o phono connection

you will need a little box called a pre-amp. This hooks up between the turntable and newer receivers without a phono input. A basic explaination & drawing of this type of setup can be found here

http://www.turntableneedles.com/Pre-Amps_c_4.html

Posted on Apr 17, 2009

  • 1126 Answers

SOURCE: Connect Onkyo CP-1020F Turntable to Theater System?

Yes. It needs to have Line Level (slightly amplified or pre-amp'd) before your home theatre system can 'hear' it.

Posted on Oct 19, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I get an intermittent loud hum using NAD AV316 amplifier, with stereo speakers(B connection) with phono input from Dual 606 turntable. Hum increases/changes when tone arm on turntable is touched.


The hum of course is the 60 cycle line AC voltage. Make sure that the routing of the AC power plug is as distant as possible from the stereo RCA cables.

The most likely problem is the connection of the phono cartridge to the wires in the arm. These connections usually are silver plated and become oxidized creating a bad connection. Remove the cartridge and using a fine eraser polish the connections. There is a ground connection that makes the five wire connection. Be super carfull these terminals are very easy to break

The phono connections to the stereo is very low voltage subject to interference. The connection to the magnetic pickup at the tone arm is low impedance and is inductive. Any poor connection between the cartridge up to the AV316 will produce this hum. Continue to check connections and swap cables with a known good to resolve.

I have switched the left and right cables to ensure that the cable is not the problem.

Hope this helps?

26292079-cwuk2nnqz2kg21zgzsgwntxz-4-1.jpg

Sep 26, 2016 | NAD Audio Players & Recorders

2 Answers

How to connect a turntable connected to a yamaha a450 stereo amplifier...can I attache the a450 to the htr-6130 ?


If the turntable is newer kind you can connect it in any Stereo input like CD, VCR , etc.

If the turntable is older model you can only connect it to PHONO input (if amp has one) and make sure earthing cable is connected on Amp

Remember input is only stereo (unless your model has digital input) and select sound effect eg Pro Logic for enhanced sound,

Aug 26, 2014 | Yamaha HTR-6130 Receiver

1 Answer

My technics 1200 mk3d powers up and the platter spins but I'm not getting any sound out of it when my cartridge is in? Any help would be appreciated.


Disconnect ALL of the wires to the cartridge. With the amplifier on, the turntable connected, put your finger on each one of the wire ends to the cartridge one at a time. On two of the wires you should hear a loud hum, one on the left and one on the right. The other two wires are earths and will probably make little or no sound at all.
If you hear the hum then the amplifier is working and the connections between the deck and amp are good. In which case you have a faulty cartridge or poor connectors to it.
If you get no hum, then either the wires between the deck and amp are faulty. Or there is a fault in the magnetic cartridge pre-amp inside the amp. If the hum is weak, that too could indicate a faulty pre-amp. Or that your amp doesn't have one. In which case you will need to connect one between the deck and amp. This will apply if the amp has no dedicated "phono" socket.

Jul 15, 2014 | Audio Players & Recorders

1 Answer

Turntable troubleshooting


A loud hum is usually from an earth problem (in fact 'not earthed')
So your best bet seems to try the 2nd pre-amp again, and see if there is a pin or connector for an earth link. Mine earths to the chassis of my main amp.

Jan 31, 2014 | Audio Players & Recorders

2 Answers

I don't have a grounding wire and don't know what to use!


You can attach a wire to the metal part of the turntable and screw the other end to ground screw on the amp.

Mar 05, 2012 | Philips gemini XL-500 II Turntable

1 Answer

Humming when no input in jack; works fine with rca inserted; worries me that somethings is not right even though works fine with RCA or XLR plugged in, right channel only


Sounds like it could be feedback hum. Is there anything near it that could cause a reaction when unpluged? Such as a turntable, cassette etc. If so move them and see if it goes away. Even then it won't hurt the amp. I think otherwise worry when there's a hum when they are plugged in. PS check any earth connections too!

Jun 21, 2010 | Adcom GFA-5802 2-Channel Amplifier

1 Answer

Revolver 'Rebel' Turntable extended leads Rotel RA 50 Amp - hum


could try fitting a serpresser as like cars do
also try a farraday loop which means put a few loops in your lead

Sep 07, 2009 | Audio Players & Recorders

1 Answer

Problem with phono jack on amplifier for turntable. When turntable is played there is a lot of feedback which makes it difficult to hear the record. turntable is an aiwa and amplifier is sony but shouldn't...


sound like it needs earthed.
there should be a little skinny black wire either coming off the turntable or in between the phono cables screw this to your amp.
if not then check the head shell connection to the tonearm.
if after all that & still on luck the is only one solution left. buy a little mixer & connect the turntable to it then come out the mixer into the amps AUX or CD input.
good luck mate.

Aug 13, 2009 | Audio Players & Recorders

2 Answers

Pioneer PL-570 turntable (c.1973)


Yes first check is that the Gnd wire from your turntable is connected to the Gnd (ground) post at the back of your amplifier with a good clean tight connection.
If the problem persists, check ALL your hi-fi components mains plugs for earth connections including your turntable, then remove the earth connections on all but one component so that you are left with only item earthed.
What does sometimes cause problems is if 2 or more hi-fi separates are earthed and connected to each other the earth cables along with the hi-fi interconnects form an inductive loop that picks up interferance such as mains hum etc.
Regards John

Sep 16, 2008 | Pioneer PL-990 Turntable

1 Answer

Humming noise/ feedback


your mixer should be grounded by the power cord, and the decks have a seperate ground wire which connects, usually on a screw terminal, to the mixer, which provides the ground for the decks. I would try the headshells to make sure they are tight and connected correctly also make sure the power socket on the wall is earthed properly.

Feb 19, 2008 | Stanton STR8-150 Turntable

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

63 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5011 Answers

The Knight
The Knight

Level 3 Expert

73591 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...