Question about Eclipse EA3422 Car Audio Amplifier

1 Answer

Problem with an eclipse EA3422 amplifier

When the stereo is on the volume cannot be turned up or the sound cuts out completely. The speakers were checked out and so was the amp by a professional but they say that the speakers are fine, however they thought that initially the ground wire had shorted out the amp, but when they took the amp apart they couldnt figure out what was wrong with it. They tried to replace a few parts and to no avail they couldnt fix it.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

Your problem is with your stereo/radio, not your amp... Take a friend amp and connect it up as you have yours and see if it does the same thing.

Posted on Aug 15, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2001 chrysler voyager installed a kenwood stereo and when i raise the volume to where its lound the radio will turn off and on untill i lower the vol


My electronics savvy source says you may be overdriving the amplifier in your Kenwood stereo to an impedance-mismatched set of speakers, meaning that the speakers are impedance mis-matched to the Kenwood stereo, and therefore operate ok (but inefficiently) at low volume, but cut off completely at higher volume.
Fix: match the impedance of your speaker network to the specs on your Kenwood car stereo. Once this is done, you should be able to crank up the volume to the point of permanent hearing loss.
SAFETY CAUTION - sound levels above 85 decibels produce NIHL (noise-induced hearing loss).
http://www.dangerousdecibels.org/education/information-center/faq/

Oct 18, 2011 | Kenwood Car Audio & Video

1 Answer

How to wire for 3 ch mode


this is the manual and you will find all you need in it.

http://www.fixya.com/support/p78783-eclipse_ea3422_car_audio_amplifier/manual-18248#

Jan 29, 2010 | Eclipse EA3422 Car Audio Amplifier

2 Answers

Car Ampli Problem


forget hooking this on a subwoofer. this amp produces only 50 watts per channel at 4ohms or 70 watts per channel at 2 ohms RMS...
If you try bridging the sub, it will only give out maybe 100watts bridged.
So..... if your sub is, lets say 1000watts RMS, youre just going to bust your amplifier to smoke...
Find a more decent and powerful amp. This amp is only intended for separates and lowend subs with an RMS of 80 to 150 watts

Sep 08, 2009 | Eclipse EA3422 Car Audio Amplifier

1 Answer

Sony xplod XM ZR602


What ohm is your sub running at. Sounds like your runnig your amp to low an impedance causing it to thermally shut down, when it cools a bit it turns back on. Either that or you have wires crossed somewhere. Check your wiring and make sure the load of the speaker does not fall below the rcommended ohm of the amp. Usually 4ohms mono and 2ohms stereo

Sep 07, 2009 | Eclipse EA3422 Car Audio Amplifier

1 Answer

Car speakers cut out (no sound) when volume turned up


I would check the crossovers.
If you are turning it up too loud, then the amp may be clipping (into distortion) and this is then setting the protection circuits off in the crossovers.

Jun 16, 2009 | Eclipse EA3422 Car Audio Amplifier

1 Answer

L or r speakers will not play when the volume is low


sounds like you have a wiring problem or the amp is bad. take it to a stereo shop.

Nov 16, 2008 | Eclipse (XA1000) Car Audio Amplifier

1 Answer

Amplifier cuts out when turning the gain up


Make sure the amp is getting good power and ground - there should be 12V across the two terminals. Also make sure you're giving it the proper ohm oad - how do you have your subs wired up? Do your headlights or interior lights dim when this happens?

Sep 16, 2007 | Eclipse EA3422 Car Audio Amplifier

1 Answer

Compatibility


this is a safey feature in your amp. you are drawing too much power for the amp to put out so i shuts off when the breaking point of the total rms calue is reached. i would suggest getting a more powerfull amp, a larger ground/powerwire combo, or a farad capacitor to balancethe powerin andthe power out.

Sep 04, 2007 | Eclipse EA3422 Car Audio Amplifier

1 Answer

Interior speakers cut out when the volume is turned up


You may have speakers of an incorrect impedance attached to the unit since the problem occurs when audio signal level is increased and the current goes up.The unit is shutting down to prevent damage. I would check the speaker connections and make sure that the speakers impedance are matched for the unit you are using.

Sep 03, 2007 | Eclipse EA3422 Car Audio Amplifier

Not finding what you are looking for?
Eclipse EA3422 Car Audio Amplifier Logo

Related Topics:

95 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eclipse Car Audio & Video Experts

The Knight
The Knight

Level 3 Expert

75178 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

xxxxxx xxx

Level 3 Expert

4917 Answers

Are you an Eclipse Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...