Question about Televison & Video

Open Question

White steam press model PSP-990

I have had this steam press for about 10 years. I didn't use it much until last year. One day I plugged it in and it didn't turn on. I paid about $270 when I bought it so I don't want to just pitch it, but I don't even know if they make this brand anymore. I can't find anything. It looks similar to the Yamata PSP-990 but I'm not sure. I'm looking for a place to repair the press before I decide to let it go. Please help. Thank you so much.

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 90 Answers

SOURCE: problem

power board is bad if it doesnt power up -- the red flashing lights mean that you need to upgrade the software-- you can get a new software upgrade on the website for philips --- use a thumb drive to install it into the television

Posted on Feb 24, 2009

Ad
  • 21 Answers

SOURCE: TV Screen Stripes

NOt very clear.....

Multiple stripes all over the screen? Vertical or horizontal?

If it's only like an inch vertical lines put a mark on the cabinet where exaclty the line is, turn off the TV then open the back, you'll see lots of ribbon wires (gold color) from the plasma panel it self going to buffer boards, using the mark find the closest ribbon wire where the line is showing then remove and clean the contacts, make sure to reseat it properly when putting it back otherwise you'll just add more lines or black bar on the screen if pins are not seating properly.
But do not be afraid if the lines get worst just turn the power off right away and reaset the ribbon wire till you get it correctly.

CAUTION;
DO NOT try to do this while the TV is on oherwise you'll burn COF (Chip on film) on the panel and you'll end up replacing the whole PDP.

Good luck!

Posted on Mar 11, 2009

  • 1779 Answers

SOURCE: my viewsonic nx2232w moniter just one day stopped

The problem sounds like the Power supply module to start with.

Posted on Jul 13, 2009

  • 92 Answers

SOURCE: White dots fill up my screen

Change the Y-sustain & Buffers.

Posted on Sep 08, 2009

  • 366 Answers

SOURCE: I have exactly the same problem-Navigator only turns to the left

it sounds like it needs a turbine kit with a-frames, it's a common problem with this cleaner. you can expect to install a turbine kit every other season if not sooner. If the wings and shoes are good, check the bearings both on the turbine and the a-frames. If they're good, check steering valve. hope this helps...

Posted on Sep 16, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Blue smoke No oil consumption + more questions


white smoke could be coolant burning and not oil possible head seal on the way out or a leak in the jacket into the cylendars, check coolant levels are ok, also check oil filler cap and see if any creamy or gray gunk is showing on it, this would also indicate the same. you can also check exhaust with a cloth to see if a lot of steam is also coming out with the smoke. I hope this was useful

Sep 02, 2012 | 2002 GMC Yukon Denali

1 Answer

2001 sport trac intermittent trying to start the motor,It has a new battery,but that didn't help,it will work for a few days,and then it doesn't start again.


Had the same problem last year. Turned out to be fuel pump. Tech at a local TLE said it was going out. Took almost a month to get dealer to agree (four trips) and change out pump. Had gas tank cleaned out also, years of buildup inside clogging pump. No problems in the year since.

Oct 12, 2011 | 2001 Ford Explorer Sport Trac

4 Answers

The mop just stopes making steam to the head. Could this be A heat coil problem? Also a lot of others have had This happen.


On these steam mops, you have to use distilled water, if you use tap water and do not have a house water softner or some kind of water filtration system, the water running thru the tubes of the steam mop
will develop calcium deposits, these deposits are caused by hard water and will clog up the tubes, and keep the mop from producing steam, then you will have to replace the lines. i own this brand of steam
mop and had the same problem you had, I replaced the lines and started using distilled water, and have not had any problems since and that was last year. good luck!


Aug 18, 2011 | Euro-Pro Shark Steam Mop - Gray/ Purple...

1 Answer

My AC worked great until last year and then after a power steering hose leak was discovered, the ac until stopped blowing cold air. I took it and paid 75.00 to have it recharged with coolant and it worked...


My air conditioner started blowing hot air last summer. I put coolant in it and didn't run it until the beginning of summer this year (2011). All of a sudden it started working again. Sometimes it blows hot but if I keep it running full blast the coolness comes back. I don't know why this happened.

Jun 26, 2011 | 2004 Kia Optima

1 Answer

When I plug in my Breadman Ulitmate TR2500BC bread maker, the light from inside the unit turns on, however, the beep that is made when the unit is plugged in did not sound, the red light on the top is not...


Sounds like you may have left it plugged-in during a lightning strike and/or power surge. Such events can permanently damage the circuitry. That's why most breadmaker instructions tell you to unplug the unit when you're not using it.

Just the same, try the following steps to see if you can restore function:

Reboot the breadmaker's electronics by pressing and holding down the Stop button down until you receive a visible and/or audible confirmation, usually within 1 to 5 seconds. Note: Some models require you press and hold the Start button instead. Others require you press and hold the Select button instead.


Hope This Helps!

Jun 14, 2011 | Breadman TR2500BC Bread Maker

1 Answer

Need piston clearance value on a rebore for a 1964 Honda c105 and can push rods be straightened? Frame# c105-0040778 what year?


Piston clearance is .002. The push rods can be straightened, be careful not to crush them. It's also not critical that they are perfectly straight. Not sure about the year, Honda actually didn't create "model years" until 1972. They used a letter and # designation (for example, 68-71 CB 750's are K1) until the changed something about the bike.Good luck!

Jun 09, 2011 | Honda Honda Passion Plus Motorcycles

1 Answer

I have a 7hp Briggs & Stratton, about 8 or 9 years old. I replaced the fuel with fresh fuel treated with Mechanic in a Bottle. I replaced the spark plug. First try of the day it will fire off, cough...


Hi,
Is there any chance there is water in the gas tank?
Usually black smoke is from unburnt fuel, blue smoke is burning oil, white smoke would be steam from water in the gas.

Have a look at these tips for difficult to start engines:

http://www.fixya.com/support/r9118692-lawnmower_not_starting

May 09, 2011 | Garden

3 Answers

I have a Bionaire Steam Mop, Model SM-02. The water appears to be heating up, but no steam comes out. It was purchased at Macy's last spring for limited use in a summer cottage. So, it's less than...


Solition: 1 tbsp of vinegar in the 1 cup of water added to mop reservoir

I purchased my Bionaire steam mop in Nov. 2010 but did not try it out until just recently (Mar. 2011) - and had the exact same problem as you... green light on, base feels warm, sounds like it's working, but no steam coming out.

I called Bionaire customer service and the lady there told me to try adding 1 tablespoon of vinegar to the 1 cup of water that you put in the mop. Then she said to leave the mop plugged-in (but not switched on) for about 30 minutes; so the green light is on; then to turn the switch to "on". I did this and, when I switched it on, it still did not produce steam. In frustration, I unplugged it and left the mop (with the water/vinegar mixture still in it) sitting upright for two days. After the two days, I was just about to empty the mixture out of the mop and thought I would try it one more time... and IT WORKED!!!

I hope this solution works for you, too!

Nov 02, 2010 | Kitchen Ranges

2 Answers

Rowenta steam iron no longer steams


Your local grocery or hardware store will sell "descaler" for coffee pots and irons.

Mix as instructed (water/descaler) and pour the disolved mix into the iron. Set the iron on the highest steam settings (heat and steam volume). After it is hot, let it steam into the sink, pressing the steam button over and over to let the descaler work through all the tubes/passages, until it has all been pumped out.

Refill with more descaler (if it is not completely unplugged) and repeat until you are satisifed with how the iron is working.

After descaling, run clean water through it with the same process (but no descaler) several times.
aymloekh0fg4hpz2e87n86udvs4fowqwshuaaaaasuvork5cyii=

Mar 24, 2009 | Rowenta Professional DE841 Iron

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Televison & Video Experts

The Knight
The Knight

Level 3 Expert

74459 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...