Question about Sigma Sport BC 1609 Cadence Wired Computer

Open Question

Sigma flash Everything is set up, but i still can not get my mph to register on the screen. How do i get the speed sensor to register?

Posted by on

  • Xue Shi May 11, 2013

    Just bought a new iRobot scooba 390. Charged the battery and filled clean water but it doesn't start moving. The check tank light was on but it was new and first time using. Any help would be great appricaited.

×

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Not registering speed


Check your magnet is aligned with and adequately close to the sensor, and that the sensor is not too far from the computer. Also check batteries. Try taking the computer off the bars and moving it nearer to the sensor to see if it is a range problem.

Oct 14, 2013 | Sigma Sport BC 1009 STS Wireless Computer

1 Answer

Syncing with Sigma BC1009


Had this same problem and nothing worked after trying everything I could think of. Speedometer would never display a blinking 0 (just stagnant). Turned out the computer mount on the handle bar was turned around backwards. The sigma letters go towards the front of the bike. Placed the device in the mount, the 0 started blinking and sync'd up with sensor. Finally works!

Sep 13, 2012 | Sigma Sport BC 1009 STS Wireless Computer

1 Answer

I have set the computer up, i think but its not registering when i ride my bike. Am i missing something or not set it up correctly the batteries are fine in both parts? can somebody help


If it's mounted correctly the display will indicate a speed whenever you rotate the wheel with the sensor and magnet on it. The magnet needs to pass within about 2-3 mm of the sensor.

http://www.sigmasport.com/en/produkte/bikecomputer/topline_wired/bc906/?flash=1

Jan 19, 2011 | Sigma Bc 906 Computer

1 Answer

I was going out 60 mph and then it started reading 0 mph while i was still going need to know what i need to do to fix that everything else works


there are two parts to register to your speedometer. the first part is the speed rotor, that's is located behind the front sprocket cover. it is held on to the front sprocket by the allen head bolt. the second part is the speed sensor, that's the part held on to the front sprocket cover with a 4mm allen head bolt. speed rotor is about $15, try that first since it's cheaper. then about $85 if the speed rotor didn't fix the problem.

Jan 17, 2010 | 2007 Suzuki GSX-R 600

1 Answer

Mph won't register,all other functions seem ok


check battery in wheel sensor or adjust wheel sensor til it just misses spoke sensor fixes most issues

Jul 07, 2009 | Sigma Bc 906 Computer

1 Answer

Odometer/speedometer


hello are the tires factory if the tires are larger or smaller than the size specified it throws yor speed sensor off speed wont register the right way if not i would say faulty speed sensor

Sep 13, 2008 | 1998 Dodge Ram 3500 2WD

Not finding what you are looking for?
Sigma Sport BC 1609 Cadence Wired Computer Logo

Related Topics:

38 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sigma Sport Cycling Experts

kirkjw

Level 1 Expert

12 Answers

Andrew Taylor
Andrew Taylor

Level 3 Expert

15716 Answers

Tom Chichester

Level 3 Expert

35747 Answers

Are you a Sigma Sport Cycling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...