Question about Hoover SteamVac V2 6-Brush Widepath F7426-900 Vacuum

Open Question

Why wont Soap solution dispense for Hoover F7426-900

I took it apart to track down problem with suction and after testing all seals and hoses with water it flows freely. Also just purchased new water tank with soap container but it still doesnt work. When I use it the water dispenses fine and recovery is fine but no solution. It smells like something burnt out? It couldnt be the motor . It works good spinning the brushes and after reading other posts one answer says this model dont uses solenoids but another post said it does. Can you help ?

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
reddevil6
  • 1673 Answers

SOURCE: hoover steam vac v2

Either you need a new tank, or there is a problem with the platform that the tank sits on. The tank has to sit correctly or it won't work.

Posted on Jan 06, 2008

Ad
reddevil6
  • 1673 Answers

SOURCE: Not dispensing soap; won't pick up moisture.

Check the filter on the bottom of the lid for the dirty water tank, make sure it isn't pushed all of the way up, needs at least a gap of 1/4 inch or so. Also make sure that the lid for the tank is locked down and not loose on one end.

Posted on Jan 06, 2008

reddevil6
  • 1673 Answers

SOURCE: Will not dispense water or solution

On the bottom of the tank is a valve, push it in and see if water comes out Where the tank sits, there is a black round seal, is it in the proper place? The rod in the handle hits just under that seal, with the tank off, you can see if the rod is movin up and down when you depress the trigger. The resevior asm. may be bad, that is what the tank sits on.

492f9ff.jpg

Posted on Mar 11, 2008

reddevil6
  • 1673 Answers

SOURCE: Model F7441980 Hoover Dual Action Spin Scrub Wide Path

You will have to replace the tank, and it will come with the soap dispenser attached.

Posted on Mar 30, 2008

  • 4088 Answers

SOURCE: brush spin,good suction at hose, no suction at

Air passage from back of brush head, through the joint, and up to bag, may be blocked.

Posted on Jul 12, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Steam Vac Is Not Dispensing Soap


Try using a rubber tipped air nozzle and compressed air at the end of the soap dispenser line. Brief intermittent blasts of air should take care of it.

Nov 16, 2013 | Hoover F6212-900 / F6215-900 SteamVac...

1 Answer

Water does not come out when button is pushed


Check these items:
(1) When the trigger is pulled, does the rubber pad behind the tank seal on the handle get pressed down? A rod in the upper handle presses this rubber valve to dispense water/soap.
(2) Are any hoses kinked closed at the bottom pivot point of the lower handle, where attached to base?

Nov 19, 2009 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

Hoover steam cleaner wont pickup water


in the front on top the cover that curves down to the floor is where the suction is .it should be plastic you can see into.its probably clogged with hair and dirt.you need tro take that top off and it comes apart in two sections .the middle seperates from the outer part.once apart you can clean it with soap and water.after you get that off you will see on your left side a long square port that needs to be cleaned also.please leave feedback.i hope i was of some help to.pete

Apr 30, 2009 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Hoover agility--poor suction, still!


When you remove the dirty water tank, on the machine, there is a screen that gets clogged and will prevent good suction, is this one clean? If it is, do you feel suction at that screen, if so then there is a problem with the tank. If no suction there, then you will have to check it over for a air leak or a bad seal.

99c831d.jpg
f5a2155.jpg

Apr 29, 2008 | Hoover F6212-900 / F6215-900 SteamVac...

2 Answers

I have a Hoover Fusion Plus. I rarely use it. Lately it does not have any suction HELP!!!


Sounds like you have a clog in the hose or down by the brush roll, the dirt inlet maybe clogged.

Mar 09, 2008 | Vacuums

1 Answer

Can't get water to spray out of the hand tool nozzle


When you attach the main suction hose to the front of the machine, you also have to connect the soultion hose to a valve located on the side of the machine. When the machine is running, take a small screwdriver and depress the centre of this valve. You should get a spray of water out of the valve which will confirm the valve and pump is working. Now, connect the small solution hose, making sure you push it on all the way. When you pull the trigger on the handle of the hose, you should get spray. If it does not, you may have a plugged nozzle sprayer.

Feb 16, 2008 | Hoover F7425-900 SteamVac V2 Widepath...

2 Answers

Hoover agility wont suck


There are 2 filters and if either one gets clogged, it will not suck up the water. One is from the bottom, it is red, pull it out far enough to clean it. The other one is behind the dirty water tank, remove the tank and you can see it on the wall covering the inlet for the suction. Clean it off, you should have suction now.

Feb 13, 2008 | Hoover F6212-900 / F6215-900 SteamVac...

3 Answers

HOOVER STEAM CLEANER PROBLEM


The soap dispenser is supposed to be attched to the water tank. That grey piece, if it is round with 2 small ears on it is the metering plate, it controls the flow of water. It sits on the table that the tank sits on, insert it into the hole and turn to lock it in place.

Jan 14, 2008 | Hoover F7220900 SteamVac V2 Upright Vacuum

1 Answer

Not dispensing soap; won't pick up moisture.


Check the filter on the bottom of the lid for the dirty water tank, make sure it isn't pushed all of the way up, needs at least a gap of 1/4 inch or so. Also make sure that the lid for the tank is locked down and not loose on one end.

Sep 10, 2007 | Hoover F5906-900 Upright Steam Vacuum

3 Answers

No suction


Hmmm...I have the same problem...if you remove the water tank and the water collection bucket and look at what is remaining. Now step on the lever to lean the upright part back and there is a hose there that goes from the hand held hose into this hose into the dirty water tank. MINE is broken at that center point between the handheld hose and the dirty water square thingy...It's probably fixable...maybe this helps you?

Nov 05, 2006 | Hoover F7431-900 SteamVac Vacuum

Not finding what you are looking for?
Hoover SteamVac V2 6-Brush Widepath F7426-900 Vacuum Logo

Related Topics:

24 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18407 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1467 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...