Question about Utilitech 1-1/2 HP Irrigation Pump UTP15P1

Open Question

Will this pump loose its prime from a faulty seal?

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 3208 cat engine that losing it prime when running , and when u got to take the filter of you lose all your fuel back into the tank , I'm thinking priming pump ????


if the priming pump is the type where you have to undo it to pump the piston and do it back up when you have primed the system then it is possible that the pump seals will be faulty. Many operators cannot be bothered with screwing the handle back down and so run into problems from worn out seals in the pump

Dec 19, 2014 | Cars & Trucks

1 Answer

Hayward super pump won't prime


Priming issues are almost always due to a bad gasket or loose fitting.
  1. Remove the leaf trap lid. Examine the gasket for debris, cuts or folds that might prevent a tight seal.
  2. Remove and examine the winter plugs for proper seal.
  3. Remove, re-tape or putty the threaded fitting directly in from of the pump.
  4. Check all unions, fittings and connections from the skimmer and main drain to the pump.
  5. On rare occasions the impeller may be impacted with debris preventing water flow. Remove the four screws holding the motor to the wet end exposing the impeller and examine it. Hayward impellers are also know to break at the shaft. This will sound like the pump is operating but never pumping water.
  6. If everything looks normal, try pouring water over the entire wet end while priming. This will sometimes allow water to fill a void you missed. The pump will probably loose prime again until the issue is corrected.

Aug 17, 2014 | Pool & Spa

1 Answer

Hooked up pump after the winter primed it but will not suck up water?


check top seal and intake union see if loose air leak will cause not to prime

May 21, 2014 | Hayward 1 Hp Max - Flo Swimming Pool Pump

1 Answer

How to prime a sand filter pump


use a garden hose connected to house supply to fill the housing and pump head , after that Pump should be able to take over and use water pulled from skimmer , if all your joints and seals are good , if it looses prime ,even after resting for a little while , ck all your joints and seals for leaks ,remember not all leaks ,Leak Out some leak In !!

Apr 23, 2014 | INTEX Sand Filter Pump

1 Answer

Renault kangoo hard to start , then runs fine . Needs to be hand primed every morning , runs fine all day then needs to be primed again every morn


this is an indication of a loose fuel fitting or a faulty valve in the system. Check that the filter is tight and sealing properly--check all lines are tight and not cracked or broken,. Check that the hand primer is in good condition and if a pump with rod is pushed all the way in and screwed up tight. The problem is a slow leak in the line allowing the fuel to drain back to the tank

Dec 12, 2013 | Renault Cars & Trucks

1 Answer

The well pump is running, but no water is supplied to thr irrigation lines. once I put water in the pump housing by removing the pump guage the pump pumps water through the irrigation lines. when it shuts...


Sounds like you have an air leak. First check your fittings, next carefully run water over the pump seals (avoid getting water on the motor or you'll hurt yourself and the pump if not worse) the pump will prime if the leaking seal is covered with water. Take your time and be careful and it should only be a matter of a loose fitting or simple seal swap.

Mar 08, 2011 | Sta Rite Ds3hf 1.50 Hp Self Priming...

1 Answer

It has lost it's prime


Without more info it's hard to say. This could be something as simple as a dirty lid "o" ring, if it is streched out or cracked you will need a new one. If not you can clean with dish soap then when you relube "o" ring use teflon or silicone grease then wipe excess off as this excess will collect dirt, also clean lip of pump pot also. If this is not the problem then you may need to replumb pump or replace seal. When you loose prime if the pump runs for any lenigth of time the water left in pot will overheat and cause plumbing to warp or seal falure.

Aug 15, 2009 | Sta Rite Ds3hf 1.50 Hp Self Priming...

1 Answer

Does not pump water. It is wired correctly, has a new magnetic impellor assembly as well.


Make shure you prime the pump before you turn the pump on If you keep loosing the prime the pump is sucking air from around seals or a jount on the down spout

Jul 12, 2009 | Little Giant 2 Md Pump Head Less Motor

2 Answers

Pool pump won't prime. Impeller replaced, worked for a couple of days. I changed the filter now same as original problem won't prime. I thought perhaps it was clogged; however since it was running and...


sounds like a priming problem. look at the check valve in front of the pump in the suction line. sounds as if it is loosing its prime so you don't have enough water close enough to the pump to get it primed.

Feb 18, 2009 | Pentair 1.0 Hp Whisperflo Pump

Not finding what you are looking for?
Utilitech 1-1/2 HP Irrigation Pump UTP15P1 Logo

Related Topics:

55 people viewed this question

Ask a Question

Usually answered in minutes!

Top Utilitech Plumbing Experts

Dave

Level 2 Expert

155 Answers

J.D. Browning
J.D. Browning

Level 3 Expert

2760 Answers

Boyet Soriano
Boyet Soriano

Level 2 Expert

293 Answers

Are you an Utilitech Plumbing Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...