Question about Hifonics Brutus BX 1505D Car Audio Amplifier

1 Answer

Problemm okay i have this amp and it was working fine but now i have a red power but i still have the hifonics lit up but i dont get no sound through it please help!!!!!

Posted by on

1 Answer

Re: problemm - Hifonics Brutus BX 1505D Car Audio Amplifier Car Amplifiers

Reset your sistem

Posted on Aug 15, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Brutus elite hifonics BRE1600.1D. Not as powerfull now.

Make sure of voltage going in to Brutus.

Mar 23, 2014 | Car Amplifiers

1 Answer

Amp not working

sounds like the amp is going into protection mode. maybe a sub is shorted (blown). Or, the only other possibility is the mosfet transistors on the inside of the amp are blown.

Feb 01, 2010 | Hifonics Brutus BX 1205D Car Audio...

1 Answer

I have a 2000 watt hifonics brutus amp worked fine but 1 day it just stopped working..the power light doest light up but the hifonics led lights are still on...whats the problem?

there is a step up converter inside the amp that likes to come loose from the board. This may be your problem. Otherwise Check all the chips for burns or disconnect

Nov 13, 2009 | Hifonics Brutus BX 2005D Car Audio...

1 Answer

HiFonics txi4008 not working, partially lighting up

Sounds like your amp has some power supply compents shorted out. Maybe some of the power mosfets are shorted and your only getting a little bit of power. That why only the H is lighting and as far as the green light, it don't take much for it to turn on. If it was major it would go into protect mode but it is'nt. I repair amps for a living and I'm the cheapest you'll find. But if you know about electronics and think you can take a crack at it, check it out. Becareful you could do more damage. Let me know if your interested.

Jun 06, 2009 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Hifonics Brutus BXi 1208d Amplifier

Possibly you need to return the amp and get a new one cause that could mean an internal problem and its deffective, you could try replacing the fuses or try changing the ground wire, this problem is very unusual

Sep 13, 2008 | Hifonics Car Amplifiers

4 Answers

No sound in my Hifonics Brutus BXi 1206D amp

Have you confirmed that you have a good signal feeding the amp?

Have you confirmed that the speakers are in good working order and don't have any breaks in the wiring?

Jan 01, 2008 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Amp does not work

make sure your power and ground wires are 4 gauge thats a big power puller also make sure your wires to woofers are correct!and you want a short ground wire and a good spot for it no paint!!
if there out of phase that will shut it off BUT you might be needing a battery cap. MORE POWER!!!!they dont cost much
and save your battery and alt.hifonics is a good choice my favorite are the series 7 they dont make them like that anymore!
hope this helps one more thing your many amps is it?
my honda is only 60 amps your brutus pulls that all day !
(BATT.CAP.or HAVE ALT.WRAPED for more power.

Dec 01, 2007 | Hifonics Brutus BX 1505D Car Audio...

1 Answer

Okay i have a problem hifonics brutus 1500 mono d class amp

well your amplifier is obviously going into protect mode,(i used to have this amp and it is awesome) anyway i would go through just to be sure and check all the power connections with a test light, remote wire, positive, and ground. and check the fuse to see if it is still good. you can buy a test light at wal-mart and any automotive store. if you stil have a problem then i would check to see if your running below 1 ohm on this amp. that would cause it to go into protect mode. if all this fails i would just go buy a new one.

Oct 07, 2007 | Hifonics Brutus BX 1505D Car Audio...

1 Answer

How to reset my system?

disconect all power cables then short between terminals G&P G&R .a little spark but ok.try after 10min.

Aug 15, 2007 | Hifonics Brutus BX 1505D Car Audio...

1 Answer

Hifonics 1605d stopped working

the red light blinking because your amplifaier its dead look for the alimentation cabel end replace the calibration protector

Apr 16, 2007 | Hifonics BX1500D Car Audio Amplifier

Not finding what you are looking for?
Hifonics Brutus BX 1505D Car Audio Amplifier Logo

Related Topics:

180 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hifonics Car Amplifiers Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers


Level 3 Expert

6993 Answers


Level 3 Expert

56797 Answers

Are you a Hifonics Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides