Question about Insignia - 5.1-Channel Home Theater Speaker System with 120W Subwoofer NSHT511

Open Question

Subwoofer not working

My sub powers up but im not getting any sound. i was jamming hard, maybe the internal fuse for the sub?

Posted by Anonymous on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kef htb2 subwoofer not working plug fuse ok sub fuse ok is there an internal fuse


If you have external fuse there will be none internally. Chances are you have blown the amp if power is confirmed to be getting into the unit and there is no sound.

Sep 16, 2017 | KEF Audio Players & Recorders

2 Answers

Onkyo skw 591 subwoofer...blue light is on and no sound? any thoughts?


Hello, To test the subwoofer when the blue light is on if you apply your thumb to the end of the subwoofer cable (the end that you would plug into the receiver) there should be feedback from the sub. If there is no feedback then the sub is not working correctly. Thanks, FJD

Apr 27, 2016 | Onkyo Audio Players & Recorders

1 Answer

Looking for help diagnosing circuit board on sub12 venue series. It powers up red led, and goes green when sensing input. Power supply and speaker checks out good. Any suggestions? Thank You


the change from red to green is simply the auto sense of the input signal happening . have you ck the simple things first , like the volume control (im sure YOu didn't touch it , but maybe someone else did) , did the input jack sustain some internal dammge that might not be seen from the outside ? how did you ck the speaker ? did you sub it out with another known working one (doesn't have to be same size to try it) ???

Jan 21, 2016 | JBL Venue SUB10 Subwoofer

1 Answer

Jamo sub 250


Internal power? Check fuses. No fuses? Disassemble and check Power supply if it is internal. If it is external, check power supply with meter.;.

Apr 30, 2013 | Jamo SUB 250 Subwoofer

1 Answer

Klh s120eth subwoofer not producing sound.


Normaly C26 has turned bad. It's 22uF/25V and is easy to access when module is disassembled.

Dec 29, 2012 | KLH Audio Players & Recorders

1 Answer

Acoustic reaserch subwoofer dont have any sound


If this is a powered sub then it's most likely the internal amp inside it that has failed. It's more than likely the part that works the hardest on the board. IE the main amp semicoductor.

Dec 19, 2012 | Boston Acoustics Audio Players & Recorders

1 Answer

Why did my sub all of a sudden stop fuckin working it didnt start popping it didnt sound bad it just fuckin stoped and im pissed


It may have not liked your language, but much more likely that an internal fuse popped.
If it's under warranty, return it.
If not, open it up and look for fuses. Chances are, replace the fuse and you'll be up and running, no repair necessary!
Have a great F'n day!!!! LOL!!!

Feb 25, 2011 | KLH ASW10-120 Subwoofer

1 Answer

Subwoofer no receiving power or signal


Take it to a real technician. Sounds like you've proven the internal amp is shot.

May 12, 2010 | Jamo SUB 6510 Subwoofer

1 Answer

Logitech Z-2300 speakers


maybe the first step could be checking the subwoofer's fuse.it is located over the power supply connector.

Jan 12, 2008 | Logitech Z-2300 Computer Speakers

Not finding what you are looking for?
Insignia - 5.1-Channel Home Theater Speaker System with 120W Subwoofer NSHT511 Logo

Related Topics:

17 people viewed this question

Ask a Question

Usually answered in minutes!

Top Insignia Audio Players & Recorders Experts

Alan Matzke
Alan Matzke

Level 2 Expert

81 Answers

The Knight
The Knight

Level 3 Expert

74473 Answers

Curt Larson

Level 1 Expert

5 Answers

Are you an Insignia Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...