Question about Pool & Spa

Open Question

Need to fix multi-port valve on sta-rite T-210WF

I have water leaking out of all ports on my multi-port valve. How can I fix this?

Posted by Anonymous on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
john224
  • 1378 Answers

SOURCE: Water runs out waste line when pump is running. we

If you already replaced the gasket and upon opeing the valve, it is still in the grooves, look for a crack in the valve body and/or diffuser.

Posted on Jun 19, 2009

Ad
  • 93 Answers

SOURCE: Leaking from the backwash port in the filter position

it is not seated all the way try turnig to different positions several times if this does not work it probably sprocket wheel under handle assembly is bad or unseated make sure pump is off when changing positions

Posted on Jul 08, 2009

Coastsider
  • 331 Answers

SOURCE: need manual on cleaing sta rite systems filter

http://www.pentairpool.com/pdfs/System3SMOM.pdf

Posted on Apr 14, 2010

tweedleedee0
  • 15 Answers

SOURCE: I have a sta rite pool filtere and it is running

Pump motors used in most pool aplications can not be reversed. Changing the wires on the capacitor or reversing the line connections will not change the motor rotation. A failed capacitor can, from time to time, let a motor start "backwards" but it will not happen often if even at all. You might need to take the motor to a local electric2_bing.gif motor repair shop for an inspection.

Posted on Jun 27, 2010

  • 8404 Answers

SOURCE: when filtering water it is

Is this a multi-port valve offering back wash, no filter, rinse, etc. modes? Have you ever turned it counter clock wise? (Never turn it counter clock wise.)

You will need to remove the top and put a new gasket in the valve.

If it is Push Pull, remove the two screws at the top and pull the assembly out. Remove and replace all "O" rings. Lube with silicone grease for pools and reassemble.

I think this will fis you up.

Thanks for your question today.

Posted on Jan 30, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

BHR170 backwash port


When backwash is done it dumps to waist, down the drain just like your toilet

Jun 01, 2014 | Sta Rite Sta - Rite 24" Sand Filter & 1 Hp...

1 Answer

My sta-rite pump leaks out the backwash port looking for a rebuild kit


If you remove the bolts around the top the handle and lid assembly will pull out. Under that is a spider gasket that needs to be replaced. Clean out and dry the slots where the spokes of the gasket go, and replace with a new gasket using contact adhesive or vinyl adhesive to glue the gasket in. Do not put anything on the top of the gasket.

It's a good idea to replace the diverter o ring and bearing while you have it open. This requires removing the handle from the diverter. The o ring is on the diverter shaft, the bearing is the white plastic ring that goes between the lid and the handle. After that the backwash valve will work like new.

Mar 26, 2013 | Sta Rite Sta Rite Above Ground Sand...

1 Answer

Which part do I need to replace to stop the leak in my Sta-Rite multi-port valve ?


I couldn't see the video, but which o ring to replace depends on where the leak is. If it is coming from the side of the valve, that would be the lid o ring. If it is coming from the top center of the valve, that would be the diverter shaft o ring. If your losing water out the waste line, that means the spider gasket under the diverter needs replacing.

Jan 28, 2013 | Sta Rite Pool & Spa

1 Answer

When filtering water it is also leaking through back wash pipe it is a sand filter pantera hi-rate filter with sta-rite water flow control


Is this a multi-port valve offering back wash, no filter, rinse, etc. modes? Have you ever turned it counter clock wise? (Never turn it counter clock wise.)

You will need to remove the top and put a new gasket in the valve.

If it is Push Pull, remove the two screws at the top and pull the assembly out. Remove and replace all "O" rings. Lube with silicone grease for pools and reassemble.

I think this will fis you up.

Thanks for your question today.

Jan 30, 2011 | Sta Rite Pool & Spa

1 Answer

I have a sta -rite valve and the handle does not turn. What could be the problem?


If I can assume that you are speaking about a sta-rite multi-port valve it is one or all of the following.
1. The silicone disk underneath the handle is worn (this is what makes the handle glide when trying to turn it)
2. The spider gasket inside the valve is worn and sticking.
3. The handle spring is rusted and catching on the valve body.
Solution: Replace spring, silicon disk and spider gasket.

Nov 10, 2010 | Sta Rite 1 HP Sta-Rite Pump: 1.5" in/out,...

1 Answer

I have a sta rite (pentair) cristal flo high rate sand filter and it leaks where the valve screw together, do u know y. Also when i vacuum it puts everything back in the pool and the backwash leaks when...


You are on the right track. As far as the leak, I would replace item #10 on the schematic (o-ring) and put some pool spa lube on it. As far as the debris getting back into the pool, I would suspect the multi-port gasket which looks like item #7 (multi-port plug and gasket). Be sure to not get any lubricant on this assembly part. When this gasket is broken or warped, some pool water gets thrown past the filter media. Also make sure the spring (item #5) is ok too...Good luck

Jun 28, 2010 | Sta Rite StaRite Aboveground Pool Sand...

1 Answer

Water runs out waste line when pump is running. we have replaced the difusier section on the multiport. Old Sta-rite multi port. Not real sure if we got the section with the gasket in right. The return...


If you already replaced the gasket and upon opeing the valve, it is still in the grooves, look for a crack in the valve body and/or diffuser.

Jun 19, 2009 | Pool & Spa

Not finding what you are looking for?
Pool & Spa Logo

Related Topics:

98 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1340 Answers

Bill Jordan

Level 2 Expert

372 Answers

David Spradling
David Spradling

Level 3 Expert

5075 Answers

Are you a Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...