Question about Koiiler XM-8787C Car Audio Amplifier

1 Answer

WHEN CONNECTING MY AMP THERE IS NO POWER, AND I HAVE EVERYTHING HOOKED UP RIGHT.

THE AMP IS HOOKED UP BUT STILL NO POWER AND THE FUSES ARE BRAND NEW

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Greenhorn:

    A rookie expert who has answered 20 questions on their first day.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 49 Answers

The amp is most likely blown.

Posted on May 10, 2013

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

Tip

Car audio hook ups


when installing a car audio sytem it is always wise to leave the power wire the last thing you hook up.ive seen many brand new amps fry because of people hooking power up to fast,if it sparks your in trouble, amps power wires should always be connect to the amp it self before connecting to the power supply. saves on amps:] And your ground should always be less then 3 feet on an amp the shorter the better!

on Jan 02, 2010 | Car Audio & Video

1 Answer

The problem with my marshall ma100h amp is that out of the box brand new it stopped working within a few days. Earlier I turned on the amp power switch and let it warm up. About a minute later I kicked on...


Brand new? Take it for warranty repair IMMEDIATELY... don't mess with it !!!

The only thing for you to check is that you did not turn on "STANDBY" as this shuts down the power amp and the capacitors will bleed off and sound will fade. Try switch in both states before complaining

ONLY use the amp in STANDBY for a brief period (20 seconds) to let the tubes warm up... Leaving in STANDBY for a long period straains the input filter capacitor. If you are done with using the amp, turn it off...

Jan 14, 2011 | Marshall Amplification Marshall MA100H and...

1 Answer

I have everything hooked up and i keep blowing the fuses in the amp?


did you use connectors on the amp or did you just strip the wire back then screwed the wire down? is the amp brand new?

Sep 12, 2010 | Alpine MRD-M1005 1000 Watt Mono Amplifier...

1 Answer

I have an Dual brand 300 watt amplifier that I just bought and I hooked everything up right (battery---power, ground----sanded metal, bypassed remote with toggle switch remote-----+terminal on switch...


Is your toggle hooked to ground? Hook your toggle switch to the battery and then the other end of that toggle the remote input on the amp.

Aug 15, 2010 | Car Audio & Video

1 Answer

I tried hooing up my amp and subs but i get


make sure u have

power source with inline fuse working.
a ground line getting a good ground(scratch paint off care frame screw it down).
remote line from amp connected to the remote line on the radio.
and make sure you have rca running to the sub input on your radio.
and your speakers are connected.

Mar 25, 2010 | Kenwood KDC-138 FM / AM Receiver

1 Answer

I installed my amplifier today and it doesn't seem to turn on. I connected the remote wire to the dark blue wire on my harness on my cd player. The power wire is running from the battery and the ground is...


Check the fuse sometimes when hooking them up youll blow a fuse.but make sure your ground is to bare metal no paint should be on it. very important.. also make sure the blue wire has current using a light tester or volt meter. if you have a long wire run it directly from battery to see if its the remote wire . sounds like a bad ground is the amp new what is the brand

Oct 03, 2009 | Car Audio & Video

2 Answers

Visonik 350watt Amp Doesnt Come On....


With your multimeter set to DC volts, the black meter probe on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red probe alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Let me know if you have any other questions.


Oct 06, 2008 | Visonik V117SX Car Audio Amplifier

2 Answers

Blowing fuses


Here are some answers:

1. Make sure your amp does not have a higher amp rating then the fuse, For example, an 18 amp amplifier will blow an 15 amp fuse, so connect it to a 20 amp fuse

2. you have a connection issue, where something is shorting out

3. you are pushing the amp or car to it's limit with how loud you put it, and thus blowing it, fixed by getting a more powerful amp and a better fuse.

4. or there is something very wrong and cannot help you and you would have to bring it into a shop.

Nov 18, 2007 | Car Audio & Video

3 Answers

My Hifonics TX1505D


dude check your remote wire and your ground also make sure you power wire hasn't come undone anywhere i mean really look at this stuff

Nov 18, 2006 | Hifonics TX1505D Car Audio Amplifier

Not finding what you are looking for?
Koiiler XM-8787C Car Audio Amplifier Logo

Related Topics:

66 people viewed this question

Ask a Question

Usually answered in minutes!

Top Koiiler Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4874 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Koiiler Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...