Question about ResMed S8 Elite II w/ Humidaire H3i CPAP

Open Question

Start/Stop Button not working properly

For some reason out of the blue, the start/stop button is not working properly. Sometimes, if I hold it down for several minutes and work it around it comes on and shuts off but it is not the easy touch it has been.

Posted by on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

HAD UNIT FOR SEVERAL YEARS. IT STARTED TO OVERFLOW INSIDE AND FLOODS CARPET. TANKS DO NOT LEAK AND ARE INSTALLED PROPERLY


Larry, there is a float above tank,remove tank, adjust float lever , bend down arm gently, or loosen adjusting screw on arm adjust down and re tighten.
press the helpful button and follow me on fixya for more tips and info.

Feb 13, 2016 | Humidifiers

1 Answer

Flashing red flight


Its probably the cleaning light that comes on periodically to remind you to clean the unit. Shut off the unit AND when you do so hold down the power button for several seconds until the flashing red light shuts off. The cleaning light should stay off until the next cleaning is due.

Per the Air-O-Swiss FAQ:

Q: Cleaning light is flashing (AOS U650, AOS 7135, AOS 7142, AOS 7144, AOS 7147)
A: Switch the unit OFF and unplug it. Empty the water in the base. Rinse the base with hot/clean water. Do not submerge the base! Visually inspect the base for dirt or mineral build up. If soft water is used decalcifying the unit every 4 weeks with EZ Cal is suggested. If hard water is used the unit should be decalcified every 2 weeks. Do not forget to reset the clean light after resetting the unit.

Q: Reset cleaning light (AOS U650, AOS 7135, AOS 7142, AOS 7144, AOS 7147)
A: The cleaning light does not automatically reset. Hold down the power button (button A in instruction manual) until the light stops flashing. The light automatically comes on approximately 14 days after plugging in the unit.

Feb 15, 2014 | Air-O-Swiss U7142 Humidifier

1 Answer

Humidifier Running Continuously with Fan Blower


As long as the humidifier start/stop is regulated by air flow there is no way to cycle it on/off with another device. If, however you disconnect that capability and, instead wire it to the heat on cool on switch it will only turn on when the stat calls for heating or cooling. You may need to install an intermediate relay off the stat wires to regulate the different(assuming that they are) voltage of the humidifier start/stop.What a fun project, thanks!

Jan 22, 2013 | Humidifiers

1 Answer

Water flow to my humidifier wont stop. and the pump is constanly running.


Sounds like the float valve inside the water holding tank is stuck in the open (down) position. Unplug the unit and take the cover off the tank portion of the humidifier. Look inside and you will see the float valve, if it's in the down position, manually lift is up. If it stays in the up position the incoming water should stop, The next thing is to determine what caused it to get stuck? Is there some sort of debris in the tank? Is the float lever rod bent or out of place? Does the float on the end have a hole in it and is full of water? These are the things you need to start with in troubleshooting the unit.

Hope this helps to get your started in solving the problem.

Mar 11, 2011 | Aprilaire 550 Humidifier

1 Answer

I have the unit listed below and I have an amber button on the unit that keeps on flashing (reset button). I've try to push the button in and reset it but nothing happens... The unit also dos not have any...


Not having any water in the reservoir is more than likely the problem. Has someone turned off the water supply line valve to the humidifier? Does the inline, water sediment filter need cleaning or replacing? The real question is, why did the water supply to the humidifier stop? Troubleshoot that problem based on the questions asked above and you'll solve the problem.

Hope this helped you solve the problem.

Mar 10, 2011 | Honeywell HM509H8908 Humidifier

1 Answer

For some reason after 2 uses it has decided to stop pushing the moisture up and the whole unit got very hot including the tank of water?? I have used humidifiers for the last 30 years and thought this...


stop pushing the moisture up? I feel you may have shorted out the unit. ultrasonic humidifiers differ from old humidifiers that relied on a motor and a little rod that sticks in to stir and disperse water droplets. (the old ones were designed to get wet).. Now they are little small vibrating disks and a fan to break down water molecules. the unit is designed to get the moisture into the room. but if it starts to **** the moisture back into it's self from the fan in the bottom. then no good can come. I messed up my first one from not knowing to keep moisture out of the bottom. but a good return policy does wonders! :)

Dec 23, 2010 | Crane Frog EE-3191 1 Gallon Humidifier

1 Answer

Humidifier not working


Ensure there is water in the tank.
  • This may be caused by mineral deposits in the water channels. Try the following: Clean the water tank, base and vapor nozzel with a damp cloth to remove any build up in the water channel.
  • When was the last time the cartridge was changed. (If it’s been over 3 months, this could be the reason why the unit is not working properly.)
  • Unscrew the demineralization cartridge and run the unit, if it starts to mist then you need a new cartridge. (insert cartridge link here)
  • The screw cap for the water tank, onto which one first screws in the demineralization cartridge, has a small rubber gasket. make sure that gasket is not too far down against the outer screw cap. If it is the spring loaded button would not work properly to let the water descend into the base tank .
    The solution: push up on that small rubber gasket so that it is as far up and away from the screw cap as it can be without falling off, and voila! you get mist!!
  • If you have changed the filter recently then take out the cartridge and run the unit without the cartridge for about 15 to 20 minutes.

May 18, 2009 | Venta Airwasher VS 207 3.7 Gallon...

3 Answers

Vicks caporiser is spitting water instead of steam


Clean the unti - and do not add salt. I live in a major hard water city...and was amazed at how much dirt the tank collected. I tried adding salt to to stop the spitting, which did make a lot more steam, but did NOT stop teh water spit. I also noticed, with salt added, water in tank would only last 4-6 hours, not the 18-24 hours it should. I just figured it out, and now mine works great again, and does not spit. I cleaned the water tank throughly, several rinses, then wiped out entire inside. If you want it to work like new, you have to keep your tank as clean as new. I am going to start filtering my water that I put in with a double pantyhose I made simply so there no more dirt ~ a clean tank will fix the problem, it did mine :)

Aug 03, 2008 | Vicks Warm Steam Vaporizer 1.5 Gallon...

1 Answer

Humidifier doesn't stop


I had the same problem if you dissasemble the unit you will probably find a capacitor between two blue wires has blown out

Mar 30, 2008 | Holmes Products Cool Mist HM3500...

1 Answer

Air-O-Swiss 7133


Okay, I just started getting this same deal with my 7133 on it's third season. I found in a blog that if you hold down the button that controls the heat while turning the mist knob on, it resets the machine. It worked. The red light went green and I turned off the heat button for cool air and the upper light still stayed green. Fingers crossed this continues to work. good luck!

Nov 27, 2007 | Air-O-Swiss 7133 Humidifier

Not finding what you are looking for?
ResMed S8 Elite II w/ Humidaire H3i CPAP Logo

Related Topics:

97 people viewed this question

Ask a Question

Usually answered in minutes!

Top ResMed Humidifiers Experts

Mack Baxter

Level 3 Expert

383 Answers

Dennis

Level 2 Expert

231 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a ResMed Humidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...