Question about AudioBahn A2300HCT Car Audio Amplifier

1 Answer

A2300hct no aound

I have a a2300hct audibahn amp Fried two resistors, both replaced. Everything lights up and the light goes blue as if there is no problem. Now I have no sound from the amp to the sobs. What is a common problem for that? I heard theres been a lot of issues with these amps thanks, Andrew

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 113 Answers
Re: a2300hct no aound - AudioBahn A2300HCT Car Audio Amplifier Car Amplifiers

Are there power to the output transistors?

Posted on Aug 08, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Have a kenwood KAC-8101D and found a burnt resistor at R101 brown gren brown gold.. The blue power light turns on indicating power but no sound comes out anyone know what else is fried or what else to...

without a diagram, and the exact location of the resistor in the amp, it is almost impossible to say if anything else is defect. Most of the time, a burned resistor, if it is defect, it had to much current, so the transistor (alone or in a IC) got to much and perhaps also died.

If you don't have the skills, tools and diagram (service manual) don't start it, you end up with something that does not amplify anything.

Jun 10, 2014 | Car Amplifiers

1 Answer

Audiobahn 2300hct red led light comes on when engine revs up at idle amp goes blue and works fine. volts are running at 13.5 to 14.0 when reved and 12.4 at idle. what going on? amp worked fine when car was...

this is happening simply because your ground wire is either going bad, or it has a bad connection to your vehicle. check the spot where your ground wire connects to your car, and look for corrosion or a change of color in the wire. if you find anything like this, i would recommend replacing your entire ground wire. if the wire looks fine, just tighten your connection point, or move it all together.

Jun 06, 2009 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

Mxa422 protection

Outputs are fried. Try disconnecting your speakers and see if it still goes into protection mode. If it does then you A thumbs up would be greatly appreciated if answer is helpful for your question. THANK you and GOD BLESS

May 24, 2009 | Lanzar MXA422 Car Audio Amplifier

1 Answer

Red light comes on but amp still tries to kick.

Try removing the caps out of the system. It sounds like they have gone out. What is happening is the caps start storing up the power like they are supposed to do but then they are being discharged as soon as they are full. Bypass the caps and that should correct your problem.

Mar 14, 2009 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

I have an audiobahn a2300hct with blown components.


^ from are a good replacement. You need to replace all of the Z48s on the side of the amp where the ones that failed were located. Digikey will also have the resistors. There may be other problems. If you're new to repair work, read through the following page.

Basic Amplifier Repair

Let me know if you have any other questions.

Dec 10, 2008 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

AudioBahn A2300HCT no sound

Generally, if the amplifier smokes, the power supply FETs have failed.

Many times, the output transistors fail and that causes the power supply FETs to fail.

Audiobahn won't release schematics. The amplifiers are relatively simple and a schematic isn't generally required.

If you know how to check the transistors, check them to determine the severity of the damage. If you don't know how to check them, read through the following page following all links provided.

Basic Amplifier Repair

Let me know if you have any other questions.

Sep 04, 2008 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

Red status light on no power goes to my subs

no but u only need one. it needs to be no more than 10 inches from the positive battery terminal.

Apr 20, 2008 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

Wierd stopped working audiobahn a2300hct

Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up normally, the wiring and speakers need to be checked. If it still shuts down, the amp likely has blown output transistors.

Apr 05, 2008 | AudioBahn A2300HCT Car Audio Amplifier

2 Answers

Protect light stays on

It's likely that the output transistors have failed. If you measure the resistance between the second and third legs of the large transistors adjacent to the large (green?) resistors, you'll find several that read ~0 ohms. Its likely that only one of several that read 0 ohms is defective but all that read 0 ohms in the board are operating in parallel and must be replaced together so they match (electrically).

Disconnect the amp from the power source BEFORE trying to measure the resistance across the resistors.

Nov 25, 2007 | AudioBahn A2300HCT Car Audio Amplifier

3 Answers

AUDIOBAHN a2300hct problems

This indicates a possibility of a power supply issue, you may have to open up the unit and take voltage measurements to determine if the voltages are correct. In order to do this you will need a schematic diagram of the unit. Once you have the schematic you will be abor to tell which voltages are legitimate. I hope this helps

Sep 15, 2007 | AudioBahn A2300HCT Car Audio Amplifier

Not finding what you are looking for?
AudioBahn A2300HCT Car Audio Amplifier Logo

Related Topics:

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top AudioBahn Car Amplifiers Experts

matthew walsh

Level 1 Expert

69 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21840 Answers

Are you an AudioBahn Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides