Question about Blenders

Open Question

Blade of an Oster 2609 hand blender has gone loose. Is there any way to fix it?

The motor is fine. The whole unit works for a few seconds, but then the blade falls about half an inch and it stops spinning since it's no longer attached to the motor. When I took it apart, I found a loose little rusted washer in the lower half of the device, where the blade is. I can provide pictures if necessary. Is there any hope for this thing?

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: Blade not turning

I am looking at the same problem, the aluminum bottom part (on blade assembly) that contacts the black rubber on the motor part is no longer "attached" to shaft that drives the blade on top side. So like said the top and bottom "turn freely" but independent of each other.... not good, they should be one piece. Ebay does not have a replacement for this original part in my case and would have to buy a complete jar assembly. I will attempt to fix the original one by cutting a slot through aluminum and center shaft and dropping in a pin to make them turn together, with a spot of weld to hold pin to shaft... not sure how long this will last.... unless somene has a better idea to fix it?

Posted on Oct 29, 2008

  • 10865 Answers

SOURCE: Need replacement blade for Russell Hobbs hand mixer

go to this page http://www.russell-hobbs.com/parts.shtml and order what you need directly from Russel Hobbs.

Please mark this answer as a fixya! thanks

Posted on Mar 18, 2009

falter
  • 245 Answers

SOURCE: Krups blender blade stops

well it looks to me there is some thing not tight enough connection to ur blade.....as u say it works when empty but when u put soemting in its stops....this means ur blade is not tight on the shaft to the motor......or u may have done something wrong when u had the blender open........recheck ur work and make sure its tight,,,,,
if so u will have ur ice cold drink....cheers i hope so for ur shake

Posted on Jul 03, 2009

  • 145 Answers

SOURCE: unit seems to work fine, but when the pitcher is

Depending on the age of your blender, a new blade assembly may be available. I would recommend calling Kitchenaid Customer Service for pricing. Their toll-free telephone number is:

1.800.541.6390

Posted on Jul 28, 2009

  • 2 Answers

SOURCE: A blade on my immersion blender was bent slightly.

If you have a model with the detachable blades. Otherwise, you'd need to purchase the blending rod from www.wpcookware.com.

Posted on Mar 17, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Blades won't spin


The motor may have failed.

Dec 25, 2013 | Cuisinart Blend & Cook Soup Maker

1 Answer

Blades on ninja blender won't spin, but motor seems to be working.


I don't have one, but inspect the shaft, it looks like there is a key on the shaft, then inspect the inside of the blade where it goes on top of the shaft, see if it looks like the shaft has spun out the blade and this is why it's not spinning.

Remove the blade and the container, then turn on and see if the shaft is spinning, it should be most are a direct drive.

So now if the shaft is spinning, that most likely means that the blade hole is broke where it sets on top of the shaft.

Look closely at the inside of the blade, you should see some type of damage like the groves are worn, I hate to see you buy one and it was the shaft that wore, but usually the blade will go first.

Mar 31, 2013 | Blenders

1 Answer

My ninja blender motor starts but the blades don't turn


As stated earlier it could be the shaft needs lubing, remove the bottom part of the blender blade... the rubber thing that engages on the motor. I started with WD-40 and worked some lithium grease into it. Spins like new now.

Jun 18, 2012 | Blenders

2 Answers

Motor base is working and container jar base turns by hand but won't work together to spin blades


Just fixed my blender. Motor was working fine, but the bladea wouldn't turn. I removed the blade piece from the base and tried moving the blades by hand and they wouldn't turn. So, I lubricated the blade at the location where it's supposed to rotate. I kept trying to move the blades by hand and gradually they started to loosen up. All fixed!!! I guess they get stuck after a few years of use.

Aug 13, 2010 | Back to Basics Smoothie Elite Work Top...

1 Answer

A blade on my immersion blender was bent slightly. The motor still works and the blades spin, but they no longer emulsify. Can I buy just a new blade attachment?


If you have a model with the detachable blades. Otherwise, you'd need to purchase the blending rod from www.wpcookware.com.

Jan 16, 2010 | Wolfgang Puck Immersion Blender

1 Answer

The blades stopped turning in the middle of blending a batch of hummus Its is a Kitchen Aid blender about 10 years old


Does the motor still work if you take the pitcher off of the base? If so, the rod that's in the blade assembly is probably corroded. The blades are connected to a metal rod that passes through a brass tube through to the piece that makes contact with the motor when you put the pitcher on the base. The grease wears down eventually and if you don't pulse and run the motor for a long time at once, the heat can corrode the bar and cause the blade to stop spinning. You can either disassemble the blade unit, or buy a new blade unit online. google blender parts and you can get one for $10

Dec 22, 2009 | KitchenAid Kitchen Aid Kitchenaid 5-speed...

1 Answer

Connection between the motor and the blender unit (where the spinning takes place) - get extremely hot and blender does not seem to blend well. Motor works fine without the top - and the top seems to spin...


Replace the blade assembly immediately. They are available from Cuisinart's website. Sugars and other stuff can gum up the blade assembly over time, so it will periodically need to be replaced. A quick and easy way to keep the blade assembly clean and working longer is to put water and a drop of dishwashing soap in the blender after use and run the blender at low speed for 15-20 seconds - an old Osterizer trick.

Jul 15, 2009 | Cuisinart CBT-500 SmartPower Premier Work...

1 Answer

Krups blender blade stops


well it looks to me there is some thing not tight enough connection to ur blade.....as u say it works when empty but when u put soemting in its stops....this means ur blade is not tight on the shaft to the motor......or u may have done something wrong when u had the blender open........recheck ur work and make sure its tight,,,,,
if so u will have ur ice cold drink....cheers i hope so for ur shake

Jul 03, 2009 | Blenders

1 Answer

Blender blade assembly no longer turns


I had this problem and, after seeing these posts, was motivated to avoid paying the cost of a new blade unit. Here's how it can be fixed:
1. Take a kitchen hotpad and hold the blade (top) side of the unit in your hand as you unscrew the rubber gear on the base. This is a left-handed screw, so you must turn it clockwise, to free it up. This should be doable by hand. Be careful, removing the gear exposes a washer note which side is up, and place both the gear and washer aside.
2. With the blades held in the hotpad, unscrew the top nut, again clockwise. This takes more effort, but it will eventually give way. As this nut comes off, it exposes a rectangular post, to which everything is attached.
3. Remove a washer with a rectangular cutout. Make sure you remember which side is up (I think it makes no difference). This may require some rocking to remove the washer from the round-threaded end. It will come off.
4. Remove both blades in a similar manner. Note their orientation, which is important.
5. Next, remove a rubber gasket. On mine, it has a groove which is asymmetric. I don't think the orientation is important, but, again, you may want to note it.
6. What is left is an axle inside a sleeve. There are no bearings. In mine, I had to tap/drive this out. Take a flat-ended rod (ideas: I used the hex-shaped post end of a nut socket. An old drill bit you don't care about, rotated would also work). Place the unit on the edge of the counter, up-side pointing up, in a way so the bottom end of the axle could fall free when you drive it out. Gently tap the axle through the unit, using the helper tool when the axle is within the sleeve. It will drive completely out.
7. Clean everything. I simply scrubbed the axle and took a small brush to the inside of the sleeve. This doen't need to be perfect, but anything left on either surface may ultimately impair the functioning of the axle.
8. Lubricate the axle with household oil or a dab of grease. You will find that the axle will now slide into the sleeve fairly easily (I had the best luck from the top.)
9. Reattach the base gear, then the top in the obvious order. Everything should spin freely from this point on.
REMEMBER: always use the hotpad whenever you grip the blades and to tighten the bolt on top so that the axle protrudes slightly above the nut.
Good luck!

Nov 02, 2007 | Cuisinart SPB-7 SmartPower Work Top...

Not finding what you are looking for?
Blenders Logo

Related Topics:

140 people viewed this question

Ask a Question

Usually answered in minutes!

Top Blenders Experts

eyecam

Level 2 Expert

87 Answers

yadayada
yadayada

Level 3 Expert

75077 Answers

Ross Keen

Level 3 Expert

1225 Answers

Are you a Blender Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...