Question about Car Audio & Video

Open Question

Starsound car amplifier model SSA-4495 1500 watss keeps on burning fuses when conected and what is the right fuse amperage

Posted by Anonymous on

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I shorted out the speaker wire going to sub and now the amp doesnot work


You have probably blown the internal power supply fuses in your amp or the speaker fuse in the amp. The chances of blowing your sub are slim.

The internal fuses can sometimes be hard to find. They aren't usually intended for the user to change. DO NOT replace them with higher amperage fuses if they blow after you replace them as there has been severe damage caused to the circuitry. Also, don't replace them with higher amperage fuses because you think that this will let you get more power out of the amplifier. This won't work, and you will end up blowing your expensive output devices.

Oct 05, 2014 | Audio Players & Recorders

1 Answer

Owners manual for ssa -s1d 7800 starsound amp


Try to locate their website, and look for it there.

Jun 05, 2014 | Audio Players & Recorders

1 Answer

Hi Guys I have an Starsound SSA-4495 series amp,


seems that the amp is fried, have it repaired.

Sep 16, 2013 | Car Audio & Video

1 Answer

Ground zero amplifier overheating and going into protect.


Since you changed the amperage of the fuses and the cable, you allowed the internal problems of the
amplifier to get worse than they were before the original fuses started blowing.

A fuse is a safety instrument that blows instead of your amplifier.

The problem is NOT the fuses frequently blowing, as such events warn you of internal problems with
the amplifier which you should have had serviced at the time to prevent them getting worse.

It is very much like the persons who replace the fuses in their household wiring with pennies, to prevent
frequent fuse replacement only to have their house burn down from overloaded circuitry.

Service your amplifier immediately.

Revert to the original amperage on all fuses in your vehicle to prevent a car fire.

Apr 07, 2009 | MA Audio Hard Kore HK-898 Car Audio...

1 Answer

Radio fuse keeps blowing


There is obviously a short there somewhere + wire touching metal or something, and putting any fuse especially a higher amperage in there could find your short real quick by burning up your wiring & car

Feb 01, 2009 | 1996 Toyota Camry

1 Answer

The fuse from the amp to the battery keeps burning


maybe it cannot accomodate too much power running on it...too much current, try another fuse with higher ampere rates

Jan 14, 2009 | Nitro BMW-486 Car Audio Amplifier

1 Answer

Questions about driver board


Are the ICs covered in epoxy? All of the ones I've seen were covered and not replacable.

On other 3S-tech boards, they use a TL072 and an LM211. These rarely fail. The problem with these boards is generally blown driver transistors or bad connections on the driver transistors and/or resistors near the driver transistors.

Let me know if you have any other questions.

Aug 13, 2008 | SPL Dynamics XL2-1600 Car Audio Amplifier

1 Answer

Have a kenwood kac849 600w amp keep blowing fuse on amp as soon as power is too it power wire got wet and now this can i bypass that fuse some how


It would be very dangerous to bypass a fuse. If it keeps blowing, bypassing the fuse will only create lots of internal damage and maybe a fire as well. The fuse is blowing for a reason, the amplifier is not going to somehow start working because you bypassed the fuse. You also need to stop trying to turn it on, every time it blows the fuse, it keeps stressing the components inside. You have a shorted power supply, probably water damage as well since the power wire got wet.

I repair car amplifiers for a living, and can tell you with all honesty that bypassing the fuse would be a terrible mistake to make, the amplifier would end up being un-fixable with holes burned right into the board.

Please, just take it in for service or get a new amplifier. That is the only sensible thing to do. The amp will not start working bypassing the fuse, it will only start smoking.

Jul 10, 2008 | Kenwood Car Audio & Video

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

60 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4869 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76630 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...