Question about Sony BRAVIA XBR 52 in. LCD Flat-Panel HDTV

1 Answer

XBR 4 vertical black band, ghosting/smearing, getting worse.

At a year and 2 months from new, my KDL52XBR4 developed problems. About 3 weeks ago on startup, there was a shrill whistle for about 2-5 minutes then gone - noise never came back. About 7 minute after this first morning startup and thereafter, a fuzzy black band instantly appears in middle of screen, 1 foot wide. Rest of screen gets darker. Perimeter starts to go black. A few days later, also started smearing, ghosting, not refreshing on right perimter, overlapping images. So it's gradually getting worse. After 5 minutes, TV snaps to perfect, no problems at all for the rest of the many hours the TV is on. Qualified technician looked at malfunction for 5 minutes, said LCD screen with attached `TCON(?)" needs to be replaced. Cost $2900, Sony will only help $900, so I'm out $2000, with only a 90 day warranty !! In my past experience (I'm retired mech./chem engineer), power supplies provide different voltage levels to radio/TV's. If voltage levels are off until defective power supply is replaced, warms up, or starts working right, won't that throw off flourescent back light starter and voltages running circuitry ? I've had only one diagnosis, and hate to spend $2000 on a 10 minute diagnosis. He didn't hook up any analysis machines, and was adamant about problem. What's a TCON ? Please advise. Thank you, Jeff

Posted by on

  • murchison Apr 24, 2009

    mine is has the same problem. upon cold start up, the left side of the screen is blurry, ghosting/smearing, flickering. JUST the left side. problem started out doing this for about a minute or two, now takes 20 minutes to come out of it. once it does, it is fine. AND, if i turn it off and then immediately back on, the picture comes up fine. seems like once things are heated up thers no problems. i bought mine in january '08 and problems started 13 months later. anyone have any more input?

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Hi, I have a similar issue which is progressively getting worse. My TV is on a sliding mount, and interestingly enough, sometimes I can "jilt" it by hitting it and it clears. This seems to me to be a connector problem, where heat (thermal expansions, electrical resistances) can introduce degrading signal. Now if I could find a manual on how to take this damn thing apart.......Certainly does't solve the warranty issue, but at least gives a reason for one to kick their TV.

Posted on Jun 18, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

DC385 does not run when trigger is pulled with a fresh battery installed.


the armature comuttator can be bad on some collectors and even broken you can hear it if you have a short period for the first time hearing a shrill sound then its also eating brushes and much whistling sound until it become hot control the sliding contacts on the purple and brown wires to the brushes and after that it should only make a buzz sound and has no power give not allways the batteries the blame in most causes like the brands MILWAUKEE and PANASONIC have some brushmotors they have allways the cause of problems EY7441 last a little time of 2 years It is almost a short circuit and then the collectors eating the carbon brushes in a few weeks and make a loud piercing sound, bad for the batteries Milwaukee has the same type of brush engines Johnson when there are people who think the batteries are bad ALLWAYS replace the armature if you hear a shrill sound and the machine become hot believe it in 80 % it is the problem new brushes are eaten again in a few weeks even Makita and Dewalt but not so much as the type of Johnson armatures buying new batteries shall not help much more but you can hear simply the difference and the rpm is much better and again much more powerfull AND MUCH CHEAPER look the difference of the 2 armatures left the older less powerfull armature and on the right the later modificating armature as Panasonic and Milwaukee having with much more power new development but MUCH MORE HEAT DISSIPATION and a very short lasting time if its to much charged then its sounds terrible replace it and your batteries are happy. .4a38f402-6535-4bb2-aaff-bf43754c8cd5.jpg

dc385-not-run-when-trigger-pulled-i4vlbz0ju4folwhesbgtpeko-1-2_0.jpg


dc385-not-run-when-trigger-pulled-i4vlbz0ju4folwhesbgtpeko-1-3.jpg

Oct 17, 2013 | Dewalt Dc385 Reciprocating Saw 18v Tool...

1 Answer

1997 buick hard to start why?


Have the fuel; pump checked for pressure bleed down after sitting, it should hold pressure within 5 PSI of rated running pressure after shutting sown the engine for extended periods.

Sep 02, 2012 | 2002 Hyundai Santa Fe

1 Answer

MY 3 YEAR OLD PACKARD BELL LAPTOP TAKES UPTO 3 MINUTES TO SHUT DOWN


You could try removing items from startup. Start > Run > type MSConfig > Startup. Uncheck items you don't want to load. This will make your PC faster. This can also be done with CC Cleaner if you haven't done so already.

Aug 27, 2012 | Packard Bell Computers & Internet

1 Answer

What is draining my car battery?


sounds like perhaps it is time to purchase a newer car and let that one find a new home . our daughter had a problem like this and after much expense was told to unhook every thing electrical she could . ended up being the radio/stereo in the trunk.

Mar 01, 2017 | 1999 Pontiac Bonneville

1 Answer

A few seconds after I turn my DC33 on it makes a very loud, shrill whistling / whining sound. I emptied the canister and cleaned all of the hair / threads from the brush roller and it didn't improve. ...


Hi Elizabeth,

I'm sorry to hear about this. If you give our Helpline a call, we should be able to identify the cause of the whistling over the phone, and help you resolve it - you can call us free on 0800 298 0298 (UK), or 1866MYDYSON (US). We'll look forward to hearing from you.

Kind regards,

Jack
Dyson Online Customer Support

Oct 29, 2011 | Dyson DC33 Bagged Upright Vacuum

1 Answer

2004 77000 Sonata emits a shrill whistle when moving forward


mmmhhmmm there can be 2 problems #1- your pulleys need to be replaced or #2 u need new belts
hope this helps

Feb 14, 2010 | Hyundai Motor 2004 Sonata

1 Answer

Philips 300wn5 green stripe on screen


I have a similar problem, what is the fix?

Mar 23, 2008 | Televison & Video

Not finding what you are looking for?
Sony BRAVIA XBR 52 in. LCD Flat-Panel HDTV Logo

713 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Televison & Video Experts

kakima

Level 3 Expert

102366 Answers

The Knight
The Knight

Level 3 Expert

74630 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Sony Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...