Question about Husqvarna Lawn Tractor 48" Deck, 23 Hp, Model# Yth2348

1 Answer

Won't go Hydro transmission has always made a ''growl'' when going uphill. Now it barely goes uphill and the tires are not spinning. How do I tell if it is slipping belt or transmission problem ?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

My lawnmower done the same thing right after we purchased it. They had to replace the whole motor

Posted on Mar 20, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1990 John Deere 185 Hydro that won't go uphill after it warms up. What is the problem?


perhaps not enough fluid in the transmission of the cooling fan is plugged with grass/dirt

Sep 25, 2015 | John Deere Garden

1 Answer

My swisher25hp-60 in.cut barely moves going forward


Was it working correctly earlier or is this your initial operation?

According to the product manual for "loss of drive":
1. Bypass linkages in the bypass position
2. Hydro belt worn, damaged, or broken
3. Idler spring loose or broken

1. Make sure that the bypass linkages are in
the drive or engaged position. Located at
the rear of the machine. Refer to decal on
the rear of the unit.
2. Replace Hydro belt.
3. Replace Idler spring

Apr 16, 2014 | Swisher Zt2560 Zero Turn Radius 60" Riding...

1 Answer

The hydro drive doesn't have much power


YES IVE SEEEN IT BEFOR SOUNDS LIKE THE BELT IS LOOSE

Jul 16, 2013 | Swisher Zt2560 Zero Turn Radius 60" Riding...

1 Answer

My Husqvarna riding mower is just a few years old. It now has problems driving uphill. What would cause the mower to operate normally on flat surfaces, but make it struggle to go gradually up a slig


A hydrostatic transaxle could be low on fluid, or have leaky pump or motor. Check the fluid level. If it is not hydro, check belt from the engine to the transaxle for tightness or slippage.

Dec 19, 2012 | Husqvarna Riding Lawn Mower 42 Inch Cut...

1 Answer

Huqvarna gth2548 won't go uphill


the trans on that mower is not strong enough to pull loads like that you most likely damaged the transmission but see if the belt is not slipping

Jul 31, 2012 | Garden

1 Answer

Going uphill it jerks and barely goes.


Clean out the air intake hole in the top of the gas cap. (Be careful not to get any gunk into the gas tank.)
- VS

Oct 01, 2010 | Craftsman 17.5 hp 42 in. Deck Lawn Tractor...

1 Answer

I have a stanley HYDROSTATIC (no shift lever , just forward and reverse foot pedal,) riding mower , looks like new , bought it used , rebuilt carb , runs great now butttttttt,,,,,when I took it out in...


I have several ideas, but I don't think you are going to like any of them. Fluid pressure in the forward flow is low. Possible causes: 1. Internal seal failure in the trans.
2. Trans fluid is low - has leaked out
3. Trans fluid is thin.
Any of these repairs require major transmission service or trans replacement. For the most part, Hydro transmissions are worry free. When they do have a problem, the recommended repair from Hydro is to replace the trans. They do not have a fill or drain plug, with the exception of having a vent, they are sealed. I have heard of people filling thru the vent, but not always with success and there is no way of knowing when it is full.
Sorry.

Sep 24, 2010 | Craftsman 17.5 hp 42 in. Deck Lawn Tractor...

1 Answer

I have a Craftsman mower 917.280810.It barely moves when clutch is released,even on flat ground.I changed the belt-no help.The transaxle pulley is engaged,and when I put my hand on the tire,the tire stops...


I don't quite get you, if the belt is running but the rear axle is not turning then your transmission is shot. If the belt is running and the rear axle is spinning with no forward or backward motion, then someone took the back wheels off and put them back on without installing the keyways.

Sep 20, 2010 | Craftsman 42 in. Deck 19.5hp Lawn Tractor

1 Answer

I have the same ,Sears Kohler tractor won't pull uphill


Have you checked the fluid level in the hydro trans, there is a drive belt from the engine to the hydro trans check and make sure that this is not worn or loose. Make sure that when you check the tension of this belt that you do not have the engine running or the parking brake set, since tension will be released from the belt when parking brake is applied. good Luck

Oct 07, 2009 | Craftsman 20 hp 42 in. Deck Lawn Tractor -...

Not finding what you are looking for?
Husqvarna Lawn Tractor 48" Deck, 23 Hp, Model# Yth2348 Logo

825 people viewed this question

Ask a Question

Usually answered in minutes!

Top Husqvarna Garden Experts

Jim Parker
Jim Parker

Level 3 Expert

1040 Answers

Phil Walker
Phil Walker

Level 3 Expert

602 Answers

Roland W VanLue
Roland W VanLue

Level 3 Expert

396 Answers

Are you a Husqvarna Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...