Question about Kicker IX404 Car Audio Amplifier

2 Answers

Subs not as loud as they should be plz help

Not enough BASS!!! I have a 99 chrysler 300m, stereo still factory, so no rca outputs. I installed a NITRO 1000 watt amp, and one Rockford Fosgate P3 10" sub. My rca's are connected thru an adapter i had installed at an auto joint. My sub works, i mean the bass comes out, but it sounds like nothing. If i close my trunk you can't even hear it! i've messed with the level and bass boost it's a 2 channel amp and i have the switch on lpf. please help me i'm goin crazy!!!!

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Kicker Master
  • 636 Answers

Since you used an adapter, the first thing I would do is adjust the output levels on the adapter to the RCA. If this is not helping you then I would definitely look into replacing we stock head unit since its in 1999 vehicle. These stock radios were made to put out anywhere between 8 and 11 watts per channel. If you put an aftermarket radio you're going to have a much cleaner stand because you will be eliminating the RCA adapter which is already restraining what the capabilities are of the RCA cables.

Posted on Nov 21, 2014

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 102 Answers

RCA output level and speaker level output have different voltages and currents. The problem you are describing is common to folks trying to connect an OEM dash unit to an aftermarket amp. If your amp has speaker level inputs, try wiring to those......best bet..buy a new head unit, it'll sound better...louder and cleaner.

Posted on Mar 11, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a stock stereo and two subs with an amp in the trunk. Also two alpine speakers in the rear. Whenever I turn my balance to the left my subs don't play. What's wrong?


Hello.... I am sorry to hear you are having problems. The reason for this is that since you have a stock stereo, the shop (or person) whom installed the amp and subs used a line out converter. What this part does is allows the connection of RCA cables to the factory head unit. Almost all bass signals are always in stereo, so since you were only hooking an amplifier for just subs, you can actually just connect to just one of the rear speakers instead of connecting to the right and left. Just makes the install a little quicker. There is nothing wrong with this as I usually do the same thing in our shop. However, if you are going to be using the balance control, then you will need to go back to the shop and have them hook the converter up in stereo (to both rear speakers). Hope this helps!

20 year car audio/video installer
Bay manager

Mar 15, 2011 | Alpine Car Audio & Video

1 Answer

Can i connect the amplifier and subwoofer to the built ford fiesta radio


If your amp has rca jack inputs only you will need in-line filters to reduce the stock stereo speaker outputs down to less than 3 watts. If your amp has high power inputs you can use those. If your amp does not have a built-in crossover then you will need to install a low-pass crossover or filter before the amp so the only the bass comes thru or the sub woofer will have major distortion. Another problem is the amplifier needs a turn-on signal for the blue wire and most factory radios do not have one. That means you will have to tie that wire into the switched 12v wire from the vehicle so the amp comes on when the key is switched on. It can be done be done but I don't think you will be very impressed with the sub due to most factory stereos have a limited bass range. Most aftermarket head units have built-in crossovers and sub outputs. They also produce much better sound than the factory unit. So in other words yes you can.

Sep 18, 2009 | Sony Car Audio & Video

1 Answer

Have stock radio # F75F-19B131-AA its in a 1998 F250 need to know how and if i can hook up one Amp for the two door speakers, and if i can hook up an additional Amp for some subs. Ofcourse if radio can do...


You will need a line level converter for starters (takes speaker level signal and converts it to line level/RCA signal) you connect this to the speaker left/right wires and it has a RCA left right on other end to connect and run to your amps, (you need this box because factory radios don't have RCA outputs on them) At that point all you have to do next is run the power/gnd/rem for your amp and then speaker wires to your front/rear speaker and then sub (if using). You can use one of these converters for your front/back speakers so you will still have use of your front/back/left/right fading options. make sure you disconnect th factory plug/harness at each speaker since the amp will be powering them and you will run speaker wires to each speaker. If you only want one converter it will be on your front channel and your sub will be power by the front. (you will fade to front for more/less sub bass unless your amp has a separate volume/bass control). If you want your sub to fade with rear speakers you will need to install another converter off of the rear speakers. Found a site with some photos that may help you with your project.
http://www.redlineforums.com/forums/howto-section/15003-how-sub-stereo-amp-install-factory.html

Aug 18, 2009 | Car Audio & Video

1 Answer

Can't get my amplifier to work.


My homie had the same problem with his escalade they adapted an rca line adapter from the factory wiring to geta signal to his amplifier and it just wasnt hitting like it should so we installed a new deck and plugged the rca cords right into it and boomboom pow it was hittin like a champ-we figured that the stock premium system that was incoprporated into the truck had some sort of an onboard amp that was filtering the bass from the door speakers and which was limiting the bass output to the rca adapter and thus on down the line to the amplifier- so maybe ya might want to look into getting an aftermarket deck and see if that helps your cause-good luck

May 21, 2009 | Alpine MRP-M450 Car Audio Amplifier

1 Answer

Installing self amplified sub to factory stereo


Hello Jax GS300,

Yes, you can use RCA cables. Just wire in a "low-level" converter.

Using RCA's is really the best way, allowing you to run shielded wiring to the sub, making it less likely that the wiring will pick up electrical interference. I'd install the converter on the rear speaker wires behind the dash.

If you do not want to convert the speaker output, you can drive the Kenwood directly from the speaker wires. The diagram in the install manual shows the connections coming off the rear speakers.

Here's a link to one output converter. This one will convert all 4 speakers.

http://www.crutchfield.com/p_142SLC4/Scosche-SLC4.html?search=level+converter

Hope this helps.

Apr 09, 2009 | Kenwood KSC-WD250 Car Subwoofer

3 Answers

Subwoofer makes a loud bass machine gun noise when powered up


Well, I have the same problem and I would think it has something to do with the RCA-connections. If I power up my head unit while I have my main fuse for the amp's removed and then replace the fuse as the head unit is already playing music (thus putting out a current through the RCA-connections) it works just fine. But if I just power up my stereo with the fuse in, my subs go all crazy. I guess it has something to do with disruptions in the rca cable. Maybe they are drawn too close to some power cables or speaker cables? Good luck!

Feb 12, 2009 | Alpine IDA-X300 Car CD/ MP3 Player

2 Answers

Subwoofer playing in stereo sound


i think uyou have to got to stereo mode and turn ion the subwoofer option. i have a h/k thats wart i had to do in evvery mode is designate the s/w. rating please

Jan 24, 2008 | Denon AVR-1907 Receiver

2 Answers

"cracking" noise


Your subwoofer is not capable of playing as loud as you want it to. That sound is the woofer reaching its limit. If you have any bass tone setting on your receiver set them to flat. If there are any other bass settings i.e contour, loudness boost etc turn them off. You can also try putting the woofer into a corner. This will increase the output. Closer to you would also be louder. Otherwise you need a sub with more output. Don't let the power rating fool you when you get a new one.

Aug 26, 2007 | Acoustic Research ARS108 Speaker

Not finding what you are looking for?
Kicker IX404 Car Audio Amplifier Logo

196 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

yadayada
yadayada

Level 3 Expert

70387 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...