Question about Passport Solo Radar Detector

1 Answer

Won't go off

Comes on, lights up, has sound but in 4 weeks of use it has never gone off.

I have a newer escort in my truck I purchased brand new about a year ago and its works perfect.

I travel approx. 75 miles a day and the one in my truck will go off and least once or twice a day for good reason but the Solo I purchased used about 4 weeks ago for my car has yet to make a sound except when I turn it on. I travel the same route with both.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 134 Answers

The first thing to try is to do what is called a "factory reset". What this does is to force your RD to reload all of its factory default settings straight out of the programmed firmware. These new settings will then overwrite any present settings which may be corrupted. Here is how to do it (specifically for the Solo S2):

Solo S2’s Factory Settings
To reset Solo S2 to its original factory settings,press and hold the Mute and M (Mode) buttons while turning Solo S2 on.Solo S2’s display will provide a “Reset” message,accompanied by an audible alert,acknowledging the reset.

Posted on Mar 17, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The left front and rear blinker doesn't want to flash on my 96 Ford escort 1.9l 4 door hatchback


Turn signal switch in steering column has gone bad. Swap out for new one. If light comes on but won't flash then its prob the flasher under dash.

Jan 02, 2016 | Ford Cars & Trucks

2 Answers

My coby tftv3229 wont turn on and I've only had it


If its two weeks old why are you here? Take it back to point of purchase and either have it fixed or replaced or get a refund.....

From the brand you likely are in UK but here all sets come with some kind of warranty==the problem sounds like a power supply issue but if you have a warranty and open the set it will void that warranty.

Apr 11, 2012 | Coby Televison & Video

1 Answer

Could driving the Ford Escort with the Service Engine Soon light On for 4 weeks cause the interlock switch to start going bad???


no.

The check engine light comes on because there is a problem with a sensor, system, or part the computer controls or monitors. It should not effect the shift interlock which is basically controlled by the brake switch.

Do you have brake lights?

Feb 03, 2012 | 2001 Ford Escort ZX2

1 Answer

94 escort wont start


sounds like you might just have a new battery that needs charging FIRST - before you try anything erlse - check ur new battery - they sometimes come without a charge.


How many miles - ?

First it is best to be sure the solenoid is ok. There are two large 'terminals' on the solenoid -
one leads to the battery - using a jumper wire or even a screw driver - [ get a pro or someone with more experience if u not confident here] - jump the large BATTERY SIDE terminal to the small wire terminal - it usually has a simple push on wire - remove the little wire - and put ur jumper cable on that terminal - - be sure the car is in park - and or emergency break on.
Also be sure your neutral safety switch is good. If ur car is automatic then put it in neutral - with brake on and try it -

Dec 23, 2009 | 1993 Ford Escort 4 Door

1 Answer

I have a GE Single Wall electric oven.(JTP25SOH2) The heating elements just stop getting hot. unit is about 4 years old purchased brand new. first the broiler stop getting hot then the baking heating...


First your broiler heating element may have gone bad and now you oven heating element may have gone bad. Using an OHM meter disconnect them and test for their value.Full scale on the meter means it is shorted. No meter movement means that it is open.Eitehr means to obtain a new element(s) and replace it/them.

Jun 11, 2009 | Ovens

2 Answers

Dashboard lights and back lights have gone out!!


This, without a doubt, is the main light switch. It comes complete with the wiper switch. Beware of using second hand ones.

Apr 12, 2009 | 1999 Ford Escort

1 Answer

Dash lights and lights on warning noise gone


IT SOUNDS TO ME AS IF IT COULD BE THE ACTUAL STALK, IT IS VERY COMMON ON THESE VANS

Feb 04, 2009 | 1998 Ford Escort

Not finding what you are looking for?
Passport Solo Radar Detector Logo

Related Topics:

225 people viewed this question

Ask a Question

Usually answered in minutes!

Top Escort Vehicle Parts & Accessories Experts

John Nolan

Level 2 Expert

347 Answers

Steve

Level 3 Expert

3287 Answers

Iron
Iron

Level 3 Expert

3018 Answers

Are you an Escort Vehicle Part and Accessory Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...