Question about Car Speakers & Subwoofers

1 Answer

I have a power acoustik LX2-1000 amp. for the life of me i can not get it to work when i hool it up the red protect light comes on and wont go off. i thought maybe it wasnt grounded good enough so i ran a new ground to the chasis of my truck and nothing.

Posted by on

  • Anonymous May 02, 2009

    i have the same amp and the same thing is happening to me i dont know that to do.i tried every thing i even hoked up the ground to my battrery and nohing......i am thing may be i blew out the channeels or some thing.....i guess it is a bad *** amp though..lx2-1000 2 ohm stable

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 4 Answers

Check the fuses and make sure there are no wires touching. Thats all i know for an amp. If you're positive its hooked up right with good wiring the only other thing i could think of is the amp is fried. sucks..

Posted on Mar 10, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What is this ? On the back of Power Acoustik 500w subwoofer


Sub-woofers work on a low hertz as per audio. You have a built-in amp that has a crossover that separates frequencies under 100 Hz. Typical Hertz range is between 20-60. Since you have a built-in amp the black rectangle is a heat sink which helps to dissipate heat away from the internal components and also seconds as a cover to keep debris and other foreign objects from getting to the amp and burning it out.

Hope this helps.

Feb 19, 2016 | Power Acoustik Car Speakers & Subwoofers

1 Answer

I have a power acoustik subwoofer, how do I know if the amp at the back of the round tube works the12" speaker wrks 500w voice coil 2, 89db low Q Driver. know it's for car's but I use it with tv spk


the shown photo is a bit confusing too me , clearly this is an automotive speaker , but in the photo there is clearly a home power cord shown , is this power cord connected anywhere on this speaker ? as if it is , id be afraid that amp has received home power and not car power , as the two are not the same and have tremendous differences and would be quite damaging to this amp possibly unrepairable damage

Feb 19, 2016 | Power Acoustik Car Speakers & Subwoofers

1 Answer

I have a kenwood subwoofer, the red light comes on but I am getting no sound, help?!


red light is usually bad like protection mode unless it is supposed to be red. amps are always green and red is protection indicator normally. look it up for your amp and if you bought it used you got ripped off

Mar 14, 2015 | Kenwood Car Speakers & Subwoofers

1 Answer

Hello i just bought a power acoustik cpt1-4000d amplifier and we and a friend of mine were hooking it up and he accidently blew the 4 30 amp fuses in the amp. so we replaced them with 4 40 amp fuses and...


You shouldn't have replaced 30 amp fuses with 40 amp fuses. The 30 amp fuses were in there for a reason. You'll probably find that if you put the correct sized fuses in then it will work. If it doesn't then you have burnt out or melted something and it will need repairing.

Nov 11, 2010 | Car Speakers & Subwoofers

2 Answers

Amp is going out.


Have you tried replacing all of your fuses? If that does'nt work check your ground........ I would check all your connections also could be a connection shorting out causing your red light to come on.

May 10, 2009 | Car Speakers & Subwoofers

1 Answer

I have an older red sony xplod 500w 4ch amp. the power/protection light is glowing red. what does that mean and how do i fix it? I have no sound.


The protection light comes on if the amp overheats or if the speaker outputs are shorted.

Turn everything off and check all of your speaker wires for shorts. When you locate and repair the short, the protection light should go out and your amp will work normally again.

Hope this helps!

Mar 26, 2009 | Car Speakers & Subwoofers

1 Answer

Power ligth (red) is on but dont work


ok so it when on protect check the fuse's or the amp might be bad

Oct 31, 2008 | Power Acoustik Car Speakers & Subwoofers

1 Answer

Protect light on car audio amp wont come on green light is on


if the Protect light is on, that would be bad, if the green lights on you've got power thru your amp, meaning you have a good connection

Oct 16, 2008 | Car Speakers & Subwoofers

Not finding what you are looking for?
Car Speakers & Subwoofers Logo

Related Topics:

129 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Speakers & Subwoofers Experts

xxxxxx xxx

Level 3 Expert

4706 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...