Question about Hitachi Rotary Hammer Kit 15/16,SDS, 0 4200 BPM,500 W, 5.7 Amp

1 Answer

Power light on amp will not come on

I have a legacy rebel amp(1600watts). it just stop working the fuse is good. but have no power light does anyone know what is wrong

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 90 Answers

The brushes need to be checked,
or the cord.

Posted on Dec 03, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I HAVE A 1200 Watt Legacy Rebel amp and when I power it on the lights turn on but no sound comes out. Please give any help


You need to make sure that the subwoofer leads are connected correctly. It may be that the subs aren't connected properly. That would cause the amp to turn on without any sound coming out.

Mar 06, 2011 | Legacy LA2259 Car Audio Amplifier

1 Answer

I hooked up my 2400watt legacy amp but the "ice" dont light up nor does the red nor green light on the amp also there is a place for two fuses on one side of the amp , do i need fuses b4 it well...


You must have the fuses in the amp in order for it to work. Consult the user manual or call a car audio store to see what fuse you need. The amp will NOT work without the fuses.

Feb 23, 2011 | Legacy LA2098 Car Audio Amplifier

1 Answer

Amp turns off


what ohm is it running at? if you have all three hook up it parallel then its to low of ohms and it would be louder if you unhook your 10" sub as it moves differently form the 12"s and it cancels out some bass. but if you want it then you have to change the wiring around a bit. take the positive wire off a 12 and put it on the positive side of the 10 and then take the ground for the 10 and hook it up to the positive side of the 12. so you should have one wire from the amp going to the negative side of the 12 and one going to the positive side of the 10 and a jumper wire from the 10 to the 12. and if it still shuts off then you have bigger problems.

Sep 25, 2009 | Ultra Linear UL-2200D Car Audio Amplifier

2 Answers

2005 Subaru Legacy electrical repair question?


The #3 fuse does service both windows and door locks and #2 services a control module that affects door locks. Inspect them closely since the fuse element can crack when blowing and this is much harder to see. Pull a least #3 and plug it back in in case the contact blades have stopped comunicating with the mating connector.

To troubleshoot this effectively, you really need a cheap multimeter and the Haynes service manual for your car, #89101.
The manual has very good electrical diagrams in section 12 so you can logically trace the problem. They are available at most every auto parts chain store and cost ~ $20-25 US.

May 22, 2009 | 2005 Subaru Legacy

1 Answer

1993 subaru legacy brake lights do not work. Bulbs and fuse are fine. How can I test the brake light switch? PS: this legacy has cruise control, so the BL switch manages that, too.


simple test light to the stop light switch mounted just above the brake pedal. power in one side push down on the pedal and power should come out the other wire.

Apr 01, 2009 | 1993 Subaru Legacy

2 Answers

Legacy 4000w amp acting funny with subs


You either have a short, or the speakers are too powerfull for it, or the most likely problem is that your fuse is like 15 amps, but the amp is like 20 amps, so check the amps and if they are near 13 or higher, put in a higher rated fuse. :)

Jun 17, 2008 | Legacy LA2259 Car Audio Amplifier

Not finding what you are looking for?
Hitachi Rotary Hammer Kit 15/16,SDS, 0 4200 BPM,500 W, 5.7 Amp Logo

Related Topics:

147 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hitachi Drills Experts

Phil Rivera

Level 2 Expert

83 Answers

xxxxxx xxx

Level 3 Expert

4807 Answers

Nick Olsen

Level 2 Expert

178 Answers

Are you a Hitachi Drill Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...