Question about Alpine MRD-M501 Car Audio Amplifier

1 Answer

My alpine MRD-M501 turns on, but on the display it reads ---A

My amp wont make any noise and it reads ---A, but if i cycle through the display modes it shows that the volts are 12.2 approx, and the temps are normal (73 degrees F) what can i do? i have replaced fuses, they were not damaged to begin with, and i have unplugged the system and plugged in back in a few minutes later.

the system worked while i was setting it up for a test run, then i unplugged it and ran all the wires in my car properly and neatly and then when i went to go play some music it didnt work. its not reading any current for some reason... please help. this is my first amp and stereo system i have had in my car. i have also checked all the grounds and other wireing and the stereo deck itself. everything else is fine, even when i hooked it up directly to a different battery, the amps were reading at 2.2 before this happened.

Posted by on

  • Mark Skinner May 17, 2013

    I have the same problem with the ---A being displayed. I do repair car amps for a living and never came accros this. Anyone else have this error message displayed? Please let us know and if you have figured it out. I will try what is in the solution.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Turn off all the settings on the amp for (example, sub ,comp, lpf, etc put them all on the off position and then turn off your car remove your face plate and then try it agin it worked for me. but dont turn up the settings to loud the subs might nit be able to handle all the power thats y it does that 

Posted on Mar 17, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

So I have two alp mrd 501 amps one in each car both amps shut down ( clips ) while driving I have rolled back the setting still happons ?


Well it sounds like the safety switch is turning on. Which means it turns off. If you could clarify that would be awesome and i'm sure i or someone else could answer you better

Mar 01, 2010 | Alpine MRD-M501 Car Audio Amplifier

1 Answer

Broken alpine amp terminals


THAT USEUALLY MEANS UR AMP IS WAY 2 POWERFUL FOR UR SUBS

Feb 10, 2010 | Alpine MRD-M501 Car Audio Amplifier

1 Answer

Bluetooth keeps dropping out. my phone is a nokia e51 sometimes gives error03 alpine cde103ebt


most likely when you paired your phone you did the standard discovery mode however on some model phones especially the Nokia you might have to force pair it and you can find that information on the menu settings on the bluetooth module, is it the BT-200,300,350,or 400?

Jul 18, 2009 | Alpine MRD-M501 Car Audio Amplifier

1 Answer

Amp powers up and reads 14.4 volts... 0 amps.


Check to make sure amp is not in safe mode, you can turn this on and off in the menu.

May 19, 2009 | Alpine MRD-M1000 Car Audio Amplifier

1 Answer

How to unlock my alpine mono power amplifier mrd m500?


Hi. If you shorted (touched) the speaker wires together, or let them touch the chassis of the car, then it may have locked out. Just turning the amp off and back on will fix this, so it sounds like you have done damage to it. Most amps have a speaker relay which gives a click sound when you turn on. If there is no click, then it may have a power supply failure.

Mark

Oct 24, 2008 | Alpine MRD-M501 Car Audio Amplifier

2 Answers

Alpine mrd-m501 amp


Disconnect the speaker wires from the amp, then try it again. If the error message doesn't appear, try connecting the speaker wires back to the amp one by one.

The error message is due to some sort of overcurrent in the amp. If the error does not go away when the speaker wires are disconnected, the issue is most likely with the amp itself and will need professional repair.

Mar 18, 2008 | Alpine MRD-M501 Car Audio Amplifier

1 Answer

Alpine mrd-m501 mono power amplifier


OK, It looks like you may have an internal problem. I must say from the begining if you do not have a background in electronics take the unit to a qualified service center. Now it sounds like you could have a power supply problem if you have power coming in onpen the unit and with the use of a schematic find the main voltage rail and test from there each test point and make sure it matches the schematic value. Look for burnt circuit tarces nad if you find the remove them and jumper with re-trace wire.

Sep 15, 2007 | Alpine MRD-M501 Car Audio Amplifier

1 Answer

Have no sound


More info needed. It's like asking how to completely disassemble a car and expecting us to do everything for you. Please take some time to do a bit of research on your part so that we can better assist you and not have to work hours to answer your question.

Sep 29, 2006 | Alpine MRD-M501 Car Audio Amplifier

1 Answer

Error codes


One of the parts went bad, and you need to take it into the dealer. The way Alpine's error codes work are very vague. E-3 could mean the psu fried, a resistor went bad etc.

Aug 12, 2006 | Alpine MRD-M501 Car Audio Amplifier

Not finding what you are looking for?
Alpine MRD-M501 Car Audio Amplifier Logo

226 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4724 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...