Question about GE 106766 Bagged Canister Vacuum

1 Answer

No suction or spews debris - GE 106766 Bagged Canister Vacuum

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 33 Answers

There is a blockage somewhere in either the hose, the powerhead, or the extension wands. Check to see if the bag is full.

Posted on May 19, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why doesn't suction work on eureka


The hoses may be clear but debris could be clogging the point where it is discharged into the bag or container. There also could be a debris clog at the intake.

Sep 03, 2014 | Eureka Vacuums

1 Answer

Why is the recovery tank on Hoover f6212-900 not filling up?


Hello! There are a few things that can cause the cleaner to lose suction. Please try these quick steps.

1. Remove the dirty water tank.
2. Clear the filter screen of any dirt or debris.
3. Turn the cleaner on, check your motor suction by the filter screen.
4.. Replace the dirty water tank making sure it is flush to the cleaner on all sides.
5. Lift up on top of nozzle and slide off cleaner.
6. Wipe debris off nozzle and front of cleaner with a damp cloth.
7. Replace dirty water tank.

If you felt suction by the filter screen your suction should now be restored. Hope this was helpful!

Jul 21, 2014 | Hoover F6212-900 / F6215-900 SteamVac...

1 Answer

No suction in hose


Remove the machine side of the hose--is there suction at the machine? If so, run a broom handle or similar through the hose to dislodge the clog. If no suction at the machine, you may need to fish out debris with a hooked stiff wire from the port. Remove the bag and examine the port area underneath for similar clogging. Finally, check the brush area underneath the machine bottom plate for more obstruction. Also, check the brush assembly for debris accumulation. Remove the drive belt and check for free turning of the brush. If turns hard, remove the brush, clean the bearings and roller pins, then apply a small quantity of light oil like 3-1 or sewing machine oil. Hope this helps!

Jun 20, 2010 | Lindhaus 380 Diamante Bagged Upright...

1 Answer

No suction to the canister


Sounds like you have a blockage somewhere. I would take the hose off the canister and test for good suction. if ok then you have an issue with the hose and wand assembly. follow this to determine where you lose suction.

Oct 20, 2009 | Vacuums

1 Answer

It has no suction...


Assuming that the vacuum will run, remove the bag and check the discharge to the bag from the machine for debris. Also check the suction to the vacuum blower by removing the beater bar cover plate and beater bar. Inspect the belt. While the bar is off, inspect the suction hose behind the beater bar. This is where I usually find the debris.
Regards, --WoobieDog--

Jul 10, 2009 | Oreck XL Ultra Bagged Upright Vacuum

2 Answers

No suction on Roomba 560


Larger debris is usually the responsibility of the brushes. Remove the bin and run the Roomba-- are the brushes actually turning? If not, call customer support for a new cleaning head module. If so, remove the grill from the back of the bin. Make sure that the little fan inside is clean, then reinstall the bin on the Roomba and run it. If that little fan doesn't spin, your Roomba has lost vacuum suction and you need a new bin.

Jun 02, 2009 | iRobot Roomba 560 Robotic Vacuum

1 Answer

The brush rotates on my dyson slim but there is no suction. though there is suction from the hose... has anyone any ideas????


Un-plug the machine first. Turn the unit over and remove the bottom plate. Check for and remove any debris in, around, or behind the beater bar assembly. While you're in there, look at the beater bar ends where the bearings sit. and clean any debris, hair, etc, from those areas as well.

May 17, 2009 | Dyson Slim DC18 All Floors HEPA Bagless...

1 Answer

Not picking up fuzz


I've had a similar problem with my DC07 Animal, although there WAS suction and the machine seemed in otherwise good condition, the vacuum seemed to be working normally, yet very little was vacuumed up. I would go over and over sections of carpet and get very little debris in the container. In my case, the cleaning brush roller bar was competely covered in debris (hair, dirt, string, stuffing from our chewed up dog toys, etc.). I removed the bottom cover and manually removed all this debris from the cleaner/brush roller, reattached the cover and it worked like new with great suction.

Apr 04, 2009 | Dyson DC14 Animal Bagless Upright Cyclonic...

1 Answer

I have a u3450 1500w hoover, suction on hose works fine, but carpet suction has never worked, how can i fix this?


There must be a restriction or blockage in the carpet suction pipe. Look at the port where the hose connects to the machine and check for any accumulation of debris or blockage. The same motor drives both suction inlets so it can only be that there is an obstruction.

Nov 02, 2008 | Hoover Vacuums

Not finding what you are looking for?
GE 106766 Bagged Canister Vacuum Logo

Related Topics:

131 people viewed this question

Ask a Question

Usually answered in minutes!

Top GE Vacuums Experts

Gerry Harvey
Gerry Harvey

Level 3 Expert

1456 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Archaeology
Archaeology

Level 3 Expert

662 Answers

Are you a GE Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...